1. AC Question's Avatar
    I am using samsung galaxy s3 ( AT&T) 4.3 jelly bean and i want to download the Dubsmash but it is showing that your device isn't compatible.. please help !!
    03-26-2015 03:19 AM
  2. belodion's Avatar
    It may be that the app will not work on your version of Android.

    Posted via the Android Central App
    03-26-2015 07:13 AM

Similar Threads

  1. Replies: 1
    Last Post: 04-02-2015, 07:53 PM
  2. Can I please get some help with my badly messed up phone?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-02-2015, 07:51 PM
  3. Replies: 1
    Last Post: 04-02-2015, 07:43 PM
  4. Why cant I down load pictures to my gallery on my note 4?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-27-2015, 01:29 AM
  5. Why cant i down load photos ?
    By Nextgengamer Jc in forum Samsung Galaxy Note 4
    Replies: 1
    Last Post: 03-26-2015, 10:26 AM
LINK TO POST COPIED TO CLIPBOARD