1. AC Question's Avatar
    Hi,
    My galaxy s3 is unrooted, and on android 4.3.

    About a week ago, the phone got stuck on reboot loop. What I did was I removed battery and reinserted it. It seemed to have fixed the issue at the time.

    2 days ago, the same thing had happened. However, removing the battery and putting it back in did not help.

    I pressed Volume down + Home + Power buttons and downloaded the firmware from Kies. After it finished downloading firmware, the phone worked for about 20 seconds, and then went back to the reboot loop. (tried this twice).

    Are there any other options I can try without wiping data, chat logs and phone contacts? (I didn't back up my phone for a long time)
    04-16-2015 08:38 PM
  2. Golfdriver97's Avatar
    Welcome to the forums. Have you tried clearing the system cache in recovery (Same button combo, but volume up instead of down)?
    04-16-2015 09:35 PM

Similar Threads

  1. Replies: 19
    Last Post: 10-24-2017, 02:16 AM
  2. Replies: 6
    Last Post: 08-30-2016, 08:10 AM
  3. Replies: 1
    Last Post: 04-18-2015, 05:32 PM
  4. Replies: 1
    Last Post: 04-16-2015, 10:25 PM
  5. Replies: 2
    Last Post: 04-16-2015, 10:24 PM
LINK TO POST COPIED TO CLIPBOARD