1. Alexander Lilleaas's Avatar
    So i have been trying to google this but i didn't find anything that was exactly like this.

    Anyway so i got an used galaxy s3 from a friend. So i formatted it and did the classic setup phase and downloaded some apps etc, but i had an issue that i was hoping to solve itself.
    Anyway it didn't and it is bothering me. I can't connect to some apps and servers like S suggest, sometimes i can't send my snap chat pictures, i'm having issues logging into **** and i generally can't do what i want sometimes.
    Stuff like downloading apps works and also hearthstone seems to work as well.
    It almost seems like there is a firewall blocking my phone out from my WiFi.

    Sorry for my post being all over the place but it is really bothering me and i got issues writing in an organized way.
    Thank you for potential answers in advance.
    05-06-2015 07:55 PM
  2. Rukbat's Avatar
    Turn on wifi. Turn off mobile data. Open a browser. See if you can get here, aol.com, google.com - some site you know works. If you can get to any site, it's not the phone or a firewall. If you can't, it's probably a router problem. If the phone is running 4.4.2 or later, and the router is using TKIP ot TKIP+AES encryption, your speed - on some sites - may be so lsow that it seems as if you aren't connecting. The only solution is to run AES encryption - on a router that works properly with Android. (If you have to replace yours, the cheapest one, and it works with Android, is the Netgear WNR2000.)
    05-06-2015 11:10 PM
  3. Alexander Lilleaas's Avatar
    Thanks for the quick reply. My phone works with the internet browser thats the weird thing. Both chrome and the standard browser runs fine.
    The weird thing is that it worked fine on my previous phone and my wifes phone works fine too.
    We are useing the the router asus RT-AC66U.
    05-07-2015 07:20 AM
  4. Alexander Lilleaas's Avatar
    I have now tested my phone on another Wi-fi and the problem continues. It's such a strange problem.
    05-09-2015 05:12 PM

Similar Threads

  1. Why is my brand new S6 so slow on Wi-Fi?
    By Andrew Mack in forum Samsung Galaxy S6
    Replies: 60
    Last Post: 11-18-2016, 02:43 PM
  2. Replies: 4
    Last Post: 06-06-2016, 09:10 AM
  3. Can I get some help with a Galaxy S3 Authentication error?
    By Jonbelize in forum Samsung Galaxy S3
    Replies: 4
    Last Post: 05-11-2015, 03:23 PM
  4. Cant use smart lock with fingerprint lock enabled?
    By green mtns rider in forum Samsung Galaxy S6
    Replies: 1
    Last Post: 05-07-2015, 03:32 PM
  5. "Google Chrome Total Connection Time"
    By giodomin91 in forum Samsung Galaxy S6 edge
    Replies: 3
    Last Post: 05-07-2015, 06:42 AM
LINK TO POST COPIED TO CLIPBOARD