1. ddbcmusa's Avatar
    So i just purchased a Samsung galaxy s3 on ebay, in a Manufacturer Refurbished condition, the seller was selling a lot of them, he already had sold like 25 of them, and he still had 10 available. And he had 99.9% positive feedback. It was a good deal fifty bucks cheaper than a used one. The ones he was selling were like new, no scratches what so ever. Only thing is that the phones are manufacturer refurbished. But regardless, when i opened it today i turned it on everything seems to be working fine, looked good to go. I selected the english language and a2dded my google account. I was so happy with it, until i went into the settings and i went to the wifi and in some of the letters, I started noticing like dots on some letters and like line dashes over them. I uploaded a photo of it...
    http://s14.postimg.org/5y1asonjl/20150618_231608.jpg , In the photo you will notice a little dash, in the box where it says enter password, between the ( and u. Also where it was Show password between the r and d there is also a little dash and where it says Show advanced options, on the V there is a dot and where it says cancel, on the second C it has a black dash. And where it says Save, on the V it a another black dash, and also wher it says connect, the second C has a black dash.
    So what can this be? A screen burnin maybe? I did the test already but nothing showed up. I also did the dead pixel test and still looked normal. So i know this is not normal though, i think it's some type of defect. I have owned other galaxy devices before and have never seen this on any of them. And after all it is a manufacturer refurbished phone. So not that i wouldn't have expected something to be wrong with it. So before i let the seller know, and return it or swap it for another one, what exactly can this be?
    06-18-2015 11:11 PM
  2. B. Diddy's Avatar
    Show us a screenshot: http://forums.androidcentral.com/amb...d-central.html
    06-19-2015 12:03 AM
  3. Golfdriver97's Avatar
    Not so sure a screenshot will show burn-in. How about uploading a photo?
    06-19-2015 12:21 AM
  4. ddbcmusa's Avatar
    I just edited it, i posted a link with a photo of the problem
    06-19-2015 12:22 AM
  5. ddbcmusa's Avatar
    I just did
    06-19-2015 12:23 AM
  6. ddbcmusa's Avatar
    Click on the link in the question
    06-19-2015 12:23 AM
  7. B. Diddy's Avatar
    They kind of look like dead pixels, which can change color sometimes. Try taking an actual screenshot (as opposed to taking a photo of the screen itself), and use a different device (like your computer) to view the screenshot. Do you still see those dots? If not, then the screen itself probably has some minor defects, like dead pixels. If you do see the dots, then it might be some software glitch.
    06-19-2015 01:21 AM

Similar Threads

  1. Replies: 6
    Last Post: 06-23-2015, 05:59 PM
  2. Replies: 1
    Last Post: 06-19-2015, 12:06 AM
  3. Why can't I charge my grand prime?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-18-2015, 11:52 PM
  4. Replies: 1
    Last Post: 06-18-2015, 11:50 PM
  5. Replies: 1
    Last Post: 06-18-2015, 11:46 PM
LINK TO POST COPIED TO CLIPBOARD