1. Jeff123816's Avatar
    I could really use some help with this. I had a phone die on me and I've gone back to my old Galaxy S3 which I haven't used in a number of years. It's still on stock Android 4.1.2 (the last firmware before they implemented KNOX) and is experiencing a lot of performance issues. I've tried updating without any success. It's an unlocked AT&T model but I'm now on T-Mobile and when I attempt to update OTA, it tells me that I'm on the most current firmware (obviously wrong). I would assume that I would need to be on the AT&T network in order to update OTA. So with that, I attempted to update it via Samsung Kies and a wired USB connection to my PC. This program is a nightmare and reminds me why I swore off Samsung several years ago. After resolving the initial connection problems, I finally figured out how to get my PC to connect to the phone. Unfortunately, when I attempt to ugrade the firmware, Kies gives me the message "sgh-i747 does not support initializing" and refuses to go any further. I've searched these forums and the internet at large and most posts seem to indicate that this message actually results from a connection problem (even though Kies shows a connection). I've installed both Kies 2.3 and 3.0 on Mac OS, Windows 7, Windows 8, even an old XP machine. I've used the original USB cable and have even tried different cables. I've also tried running Kies as an administrator in Windows. I've also tried activating the developer opinions and turning on USB debugging. No matter what, I always receive the same message. I'd like to use this phone until October but it really needs an update. Can anyone suggest another way for me to get this done?

    Thanks!
    07-13-2015 01:46 PM

Similar Threads

  1. How do I make public my activity log in Facebook?
    By AC Question in forum Facebook
    Replies: 1
    Last Post: 07-13-2015, 03:28 PM
  2. How can I get past Enter Backup PIN?
    By AC Question in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 07-13-2015, 02:53 PM
  3. While playing video recorded from S6 Edge stucks in computer?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 07-13-2015, 01:43 PM
  4. Replies: 0
    Last Post: 07-13-2015, 01:40 PM
  5. How do I transfer apps to my SD card on my Optimus 6?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 07-13-2015, 01:31 PM
LINK TO POST COPIED TO CLIPBOARD