02-20-2017 03:21 PM
303 ... 10111213
tools
  1. samleboy's Avatar
    I did this but it hasn't helped, any other ideas?
    03-16-2016 03:42 PM
  2. mddoc13's Avatar
    Anyone got a solution for this? Damn! I can't use Wi-Fi when I am overseas. And whenever I try to enable it, at times it will connect but eventually hangs my phone and auto reboot which is seriously frustrating. Factory reset don't help at all. And this problem really came out of nowhere since the last update in early July. Seriously what is wrong?
    I have same problem. I a.m. told it could be in the antenna section internal problem. To fix take back cover off. You will need a very small Phillips screw driver. Take that cover off with care and inspect antenna area on left side. Could be just a matter of cleaning contact. If that does not resolve issue, sometimes the wire connection to antenna might need to be soldered back together. Do this if you are handy. If not you might have to send back to a repair shop.
    04-10-2016 11:24 AM
  3. yadgar bamerni's Avatar
    hey you shoud be install oficial rom to fix ut
    04-13-2016 09:27 PM
  4. David Eveque's Avatar
    hi dude u said that its a hardware problem???
    i dont understand what do u do......

    sorry, i know that my inglish its too bad..... if someone know spanish it will be better
    i had the same problem, oooh my gosh what is wrong with samsung galaxy s4 ?
    04-16-2016 11:34 AM
  5. Ian Freeman's Avatar
    Was there any other fixes you this problem?
    My mum is having the problem with the s4, taken battery or worn it still turned on, and turned off. Didn't work. Nor did the restarting or turning off then on.
    She hasn't rooted it.
    Only one I haven't tried is the apps she's downloaded
    05-02-2016 03:43 PM
  6. Pioter Misiuna's Avatar
    I tried renaming file, and cleaning all connectors, same effect. Switch goes to the right, text shows all the time "wifi is turning on" even when after few seconds switch goes back to off. It actually started gradually, sometimes cutting off connection. Now it doesn't work at all. Any ideas?
    05-16-2016 12:37 PM
  7. tg123z's Avatar
    I'm having the same issue and followed the instructions. The wifi still will not activate and the file was not regenerated. Any suggestions or thoughts?
    07-31-2016 01:00 AM
  8. Ravi Shankar15's Avatar
    Thank you so much for your help!
    but there is one concern Please help me i can't find a way to rename it! I had rooted my galaxy S4 by king root.
    i downloaded an application Called "Elixir 2" then i can veiw the files in "data/misc/wifi/wpa_supplicant.conf" but there is not a single option to remove or rename it.

    I am facing this issue from last 6 months, I need to solve it!

    PLEASE HELP ME! :-
    08-09-2016 08:18 AM
  9. Dickson Fernando Warnakulasooriya's Avatar
    I have the same issue on my android tablet. I can't remove the battery because this is a tablet. I can't even find the suggested file on the sd card. What can I do?
    08-16-2016 03:50 AM
  10. fubeca12's Avatar
    I read this whole thread and tried everything except rooting. I'm not ready to root this s4 yet.

    Immediate fix was to go to my app manager and on all apps that had the "uninstall updates" option I selected that.

    Once that was fin done I restarted my phone and Wi-Fi and Bluetooth have worked as normal.

    I figured that deleting all apps with Wi-Fi or BT access was harder and longer so the uninstall updates was my quick fix try.

    Also I reconfirmed that i turned off auto-update apps. Hope this resurrects this dead thread and gives someone a simpler fix than rooting, file deletions and renaming, dialing that code to access the Wi-Fi power switch and such, it was looking too detailed.
    08-29-2016 11:26 PM
  11. ev1ltruth's Avatar
    I had this same problem on my S4 GT-I9505 for a few days, booted into safe mode and bluetooth and wifi work just fine so it is a problem with an app/apps.

    For my phone it was Chrome browser app that was causing the issue (actually it was an update to chrome).

    I would try booting into safe mode, go to settings/application manager and disable/uninstall updates for chrome and any other software you cant delete and see if that works. At the very least you'll save 100Mb or so of space.

    Hope this helps
    09-15-2016 07:13 PM
  12. asgaransari's Avatar
    Hi ...

    Had the same issue. Tried the battery trick.. Got a lead from that internal memory card path thing.

    Removed the battery while phone was running and also the SD card.. WIFI started up right away !!

    Thanks
    Asgar
    09-26-2016 01:27 AM
  13. kiiwii's Avatar
    I've tried almost everything but the best solution so far is to install a newer firmware with odin
    09-30-2016 04:10 PM
  14. Ster Ling Psg's Avatar
    Original Post by Kilva:

    Hi,

    Thanks!!
    1. Root your phone
    2. Download Root Explorer.apk, put it on your phone via USB, install it
    3. navigate to either /data/misc/wifi or /system/etc/wifi
    4. rename or delete wpa_supplicant.conf
    4.5. reboot
    5. ???
    6. PROFIT!
    ------------------------------------

    Kilva, you're my life saver, thanks!

    I just renamed /data/misc/wifi/wpa_supplicant.conf, then my WIFI works! I have tried restarting my cell several times, no problems. No factory reset, so lucky! Mine is Galaxy Note I (N7000 or I717), Android 4.1.2.

    This is my first time to root a phone. I installed Kingo Android Root on my Windows 7, then downloaded Root Browsers from Play Store. So easy to enable / disable rooting.

    Thanks again!
    Guys this is innovative it works for those who have wifi problems by this I mean it's something like "when you swipe down the notification bar and try to toggle wifi om as quickly as possible, it would sometimes give you a faint green light instead of pure green to show wifi is on " here is the solution >>>>>> download kingo root .apk. go to security settings scroll down to "unknown sources " enable it then install kingo root . After that click on "one click root" your phone will be rooted now step2. Download Root explorer from Google apps install then try locate a file named
    wifi/wpa_supplicant.conf delete it then restart your device .your wifi turning on problems shall be solved 100% now back to life you can thank me through my number +254705047487 God bless y'all.
    10-01-2016 04:17 AM
  15. alex bale's Avatar
    If you Think that it's a software problem just say and i'll be happy to help
    10-15-2016 08:28 AM
  16. rohinn's Avatar
    Put it in safe mode, if you don't know how to do that heres how:
    Turn off your phone, after u turn it off turn it on, and hold the power key until you see the Galaxy s4 logo, when you see that hold down the volume button until it turns on!
    10-31-2016 03:54 AM
  17. rohinn's Avatar
    Guys this is innovative it works for those who have wifi problems by this I mean it's something like "when you swipe down the notification bar and try to toggle wifi om as quickly as possible, it would sometimes give you a faint green light instead of pure green to show wifi is on " here is the solution >>>>>> download kingo root .apk. go to security settings scroll down to "unknown sources " enable it then install kingo root . After that click on "one click root" your phone will be rooted now step2. Download Root explorer from Google apps install then try locate a file named
    wifi/wpa_supplicant.conf delete it then restart your device .your wifi turning on problems shall be solved 100% now back to life you can thank me through my number +254705047487 God bless y'all.
    I also did that but it didnt work for my galaxy s4, I watched like a ton of videos and re did it but it didnt work but turning on safe mode did ^_^
    10-31-2016 03:56 AM
  18. Growterz A's Avatar
    Internal SD Memory the Path /data/misc/wifi/ the File named wpa_supplicant.conf is having issue.
    Not going to guess what what was done on your side only that wifi cannot read that file so it just shuts off.
    you need root to view this file, I suggest renaming it, reboot then enable wifi again and it will create a new one.
    you will lose all saved passwords from the beginning of time but will be able to use wifi again.
    Yeah so just you know i tried every method to root my s4 but it wont work
    11-11-2016 09:54 PM
  19. anon(10081092)'s Avatar
    11-12-2016 11:42 AM
  20. Mahendrar's Avatar
    Strangest fault, can't enable Wi-Fi, Wi-Fi Hotspot or Bluetooth... When I pull down the screen from the top to bring up the quick select enable menu Wi-Fi will not turn on, it is preselected and a very light green colour instead of a grey for disabled or bright green when it is enabled... Holding the Wi-Fi button down and entering the option doesn't help either as it says "turning on" but does nothing... the toggle switch to turn Wi-Fi on also does nothing.
    I have reset the device several times and have also now tried a factory reset... which I really didn't want to do and it still hasn't helped. I have searched forums and google for any sign of this same fault and found nothing. I also can't enable portable Wi-Fi hotspot or Bluetooth... Can someone please advise?
    I tried this and it works but again after sleeping next day wakeup I have to re do this process...

    This does not need any factory reset, restart the phone . Just simple

    1. Switch your phone mode to aeroplane mode.
    2. Now say ok to enable the flight mode.
    3. Now enable try enable the wifi, it will get enabled.
    4. Now switch of the flight mode.
    5. Now you van see your wifi if enabled.

    Do this simple trick when ever wifi gets automatically disabled.

    Thanks
    Mahendra
    11-15-2016 09:05 AM
  21. majoret's Avatar
    I had the same issue for several days.
    Turning Airplane mode ON/OFF fixed the issue.

    I hope it helps some of you as well. Good luck!
    Jay Burleigh likes this.
    11-15-2016 12:57 PM
  22. am50em's Avatar
    After returning home after OS flight my wifi would not switch on. It worked perfectly OS. I did use flight mode on flight. I discovered the turning wifi on while in in flight mode or turning on Mobile hotspot then turning on wifi (which switched mobile hotspot off) I could get wifi running. Hardly ideal.
    Just discovered under Advanced settings for wifi, that turning off "Always allow scanning" has fixed the problem and wifi switches off and on normally. This is for Galaxy S4 running Android 5.0.1
    11-16-2016 09:50 PM
  23. Jay Burleigh's Avatar
    I had the same issue for several days.
    Turning Airplane mode ON/OFF fixed the issue.

    I hope it helps some of you as well. Good luck!
    That worked. Thank you.
    11-19-2016 06:36 PM
  24. tripbyte Tjeerd's Avatar
    Thanks ! My problem was a defect micro SD card...Remove it and restart! ! Excellent because sombody tell here!
    11-22-2016 03:47 PM
  25. Lucas Chen Alba's Avatar
    Hi everyone. I had this problem after returning to official rom, used Odin v3.185. My problem was solved when i reinstalled the OS using Odin v3.09, not really sure why that happened. If any of you r still having problems with this, u can try it.
    12-17-2016 05:49 PM
303 ... 10111213

Similar Threads

  1. Replies: 19
    Last Post: 10-11-2015, 06:26 PM
  2. Speed up the galaxy S4 and enable the developer mode
    By MallyMall88 in forum Samsung Galaxy S4
    Replies: 21
    Last Post: 11-09-2014, 03:28 PM
  3. DNS not available on Wi-Fi settings on Nexus 10
    By regalhawk in forum Google Nexus 10 Tablet
    Replies: 3
    Last Post: 11-08-2013, 08:32 AM
  4. In-app Videos only playing on Wi-Fi
    By ajbrickyard in forum HTC One M7
    Replies: 6
    Last Post: 07-01-2013, 05:57 PM
  5. [Q] Wi-fi problems.
    By tomy22783 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 06-25-2013, 11:26 AM
LINK TO POST COPIED TO CLIPBOARD