06-04-2018 08:43 PM
308 12345 ...
tools
  1. DudeyMuffin's Avatar
    Internal SD Memory the Path /data/misc/wifi/ the File named wpa_supplicant.conf is having issue.
    Not going to guess what what was done on your side only that wifi cannot read that file so it just shuts off.
    you need root to view this file, I suggest renaming it, reboot then enable wifi again and it will create a new one.
    you will lose all saved passwords from the beginning of time but will be able to use wifi again.
    I don't even have that file! Mine comes up with softap.conf and the wpa_supplicant is a folder! Any suggestions?
    Alextodd1 likes this.
    01-04-2014 05:29 AM
  2. ANDiTKO's Avatar
    Internal SD Memory the Path /data/misc/wifi/ the File named wpa_supplicant.conf is having issue.
    Not going to guess what what was done on your side only that wifi cannot read that file so it just shuts off.
    you need root to view this file, I suggest renaming it, reboot then enable wifi again and it will create a new one.
    you will lose all saved passwords from the beginning of time but will be able to use wifi again.
    This WORKED perfectly!!! Thank you so much. I just registered to this forum to post here and say thank you.
    I Recently flashed a custom kernel to my Galaxy s4 and i was playing with it when the wifi stopped working. So i tried a lot of things, removing battery and other non-sence. But deleting the /data/misc/wifi/wpa_supplicant.conf file fixed my problem. I backed up the file before deleting it. Then re-booted and my wifi turned on imminently ! Thanks again.
    01-08-2014 03:29 AM
  3. Charles Lee2's Avatar
    JUST Turn off your S4 and take the battery off.
    Then put the battery back and turn on.
    It works.
    01-12-2014 01:47 AM
  4. Alextodd1's Avatar
    I don't even have that file! Mine comes up with softap.conf and the wpa_supplicant is a folder! Any suggestions?
    Thanks a lot, it surely helped me out and i have also shared your solution on other forums too to the people that were facing similar issue.
    01-19-2014 07:06 AM
  5. illinidave99's Avatar
    I did the battery pull out suggestion and it worked. Just bought the phone yesterday, though, and I HATE having stuff that looks it could be a hardware issue rear its ugly head this early on
    01-19-2014 08:37 AM
  6. Gary Best's Avatar
    For those that have this problem. I had the same thing so I removed the battery and after I put it back in and turned it on I could get my Wi-Fi to turn back on.
    Thanks this worked
    01-19-2014 05:58 PM
  7. tech_head's Avatar
    Deleting the /data/misc/wifi/ File named wpa_supplicant.conf worked for me.
    Deleted then rebooted.
    01-20-2014 11:55 AM
  8. manouila's Avatar
    This WORKED perfectly!!! Thank you so much. I just registered to this forum to post here and say thank you.
    I Recently flashed a custom kernel to my Galaxy s4 and i was playing with it when the wifi stopped working. So i tried a lot of things, removing battery and other non-sence. But deleting the /data/misc/wifi/wpa_supplicant.conf file fixed my problem. I backed up the file before deleting it. Then re-booted and my wifi turned on imminently ! Thanks again.
    Please, can you tell me how to acces internal SD card!!!!
    01-21-2014 01:44 PM
  9. fixxxer7's Avatar
    Please, can you tell me how to acces internal SD card!!!!
    root my friend
    01-22-2014 11:14 AM
  10. metle_geek's Avatar
    Did you root ? And flash a new rom??

    from my wonderfully rooted gs4 woot
    01-25-2014 02:02 AM
  11. Sanchayan Sukumaran's Avatar
    I too had the exactly same issue and tried the method that you mentioned. Able to got solve it. Thanks
    01-27-2014 06:15 PM
  12. metle_geek's Avatar
    Internal SD Memory the Path /data/misc/wifi/ the File named wpa_supplicant.conf is having issue.
    Not going to guess what what was done on your side only that wifi cannot read that file so it just shuts off.
    you need root to view this file, I suggest renaming it, reboot then enable wifi again and it will create a new one.
    you will lose all saved passwords from the beginning of time but will be able to use wifi again.
    Yea sounds like the ota had rewritten that file and corrupted it seems like it basically broke the kernel had the same when I flashed deadly venom re flashed my kernel moduels bingo

    Sent from my SAMSUNG-SGH-I337 using AC Forums mobile app
    01-29-2014 02:02 PM
  13. metle_geek's Avatar
    I'm having the same problem, but I don't understand that response about the path???? Can you translate into layman's terms? I do seem to get some wifi though, even though it says it's not on. Just takes FOREVER if at all!
    Your going to have to root it and use a file explorer you must root because that's a system file and without super users access you cannot rewrite system files

    Sent from my SAMSUNG-SGH-I337 using AC Forums mobile app
    01-29-2014 02:04 PM
  14. metle_geek's Avatar
    I'm having the exact same problem. Tried the battery trick, searched other forums, nothing. Anyone found a solution to this? It's driving me crazy.
    OK two options.... root and fix it yourself
    Send it in for warranty or find a samsung experience professional at a best buy to reset your device (you need a clean kernel flash for the radios to work properly

    Sent from my SAMSUNG-SGH-I337 using AC Forums mobile app
    01-29-2014 02:11 PM
  15. qzal's Avatar
    Hi metle_geek,

    could you please tell me how can i acces the internal memory AFTER the root ??? my problem right now is that i cant download any app to my android, because of the same Wi-Fi issue.
    Any suggestions?

    Thanks
    01-30-2014 11:58 AM
  16. qzal's Avatar
    Ok, I found out the way of getting Root Explorer in my android, and changed the File named: "wpa_supplicant.conf" as described, then turned off and on the phone, but wouldnt work.... unfortunately the symbol of "Wi-Fi" still stays with the message :"Turning on..." and does nothing more.... do anybody has any hint to fix this?
    01-30-2014 12:39 PM
  17. Bobby Marinov's Avatar
    Try to do this: Restart your phone and while restarting plug out the battery and after that plug in the battery.
    02-02-2014 08:56 AM
  18. Commoditiess's Avatar
    Hey Guys

    I tried taking out my batt and put it bacjk again and it works!!

    thanks for the advise!
    02-08-2014 08:34 PM
  19. rigelias's Avatar
    This is the best solution and not only for S4 but for every samsung device with similar WiFi problem.

    Stephen Griffiths
    Internal SD Memory the Path /data/misc/wifi/ the File named wpa_supplicant.conf is having issue.
    Not going to guess what what was done on your side only that wifi cannot read that file so it just shuts off.
    you need root to view this file, I suggest renaming it, reboot then enable wifi again and it will create a new one.
    you will lose all saved passwords from the beginning of time but will be able to use wifi again.

    THANK YOU
    02-09-2014 04:30 AM
  20. Bashar Athamneh's Avatar
    Hi Guys and very good morning
    I hope you doing well and this problem was solved if not this what I have done to solve my problem
    Please follow the steps below
    1. go to recovery mode by pressing power+middle key (home key+ and the High volume for few second until recovery mode appear
    2. go to option wipe cache and press on it
    3. go to option refractory and press on it
    4. switch your mobile off
    5. take your sim card and SD card
    6. download the firmwire that you want from Firmwares | SamMobile then select appropriate firmwire for you
    7. download Odin if you don't have one from here Download Odin 3.09
    8. flash your mobile as normal if you don't know how...please let me know and I will help
    9. on completion of flashing turn your mobile on and start the initial steps to setup your mobile
    10 don't insert your card or sim card until you finish your setup
    switch your mobile off and insert sim and SD CARD
    WIfi is working now?

    please let me know

    good luck
    BA
    Wizardking26 likes this.
    02-12-2014 02:25 AM
  21. Kilva's Avatar
    Internal SD Memory the Path /data/misc/wifi/ the File named wpa_supplicant.conf is having issue.
    Not going to guess what what was done on your side only that wifi cannot read that file so it just shuts off.
    you need root to view this file, I suggest renaming it, reboot then enable wifi again and it will create a new one.
    you will lose all saved passwords from the beginning of time but will be able to use wifi again.
    For those that have this problem. I had the same thing so I removed the battery and after I put it back in and turned it on I could get my Wi-Fi to turn back on.
    I have tried both of these solutions, on two different roms: 4.2 Jellybean and 4.4.2 KitKat, where previously Wi-Fi had worked fine on the stock rom and my first Cyanogen mod. That mod is actually what caused all of this, an OTA update went wonky and soft bricked my phone, so I went through painstakingly figuring out how to restore it through download mode and I did it. I have custom roms I can go to now and such, but this was my one problem. Wi-Fi just wouldn't turn on. wpa_supplicant.conf is in both /data/misc/wifi and /system/etc/wifi. there's even a wpa.supplicant overlay file along with it.

    Turns out all I had to do was rename it, because indeed, the file needed to be rewritten. Thanks Stephen.

    My phone is a Bell Canadian Galaxy S4 SGH_i337M.
    02-24-2014 10:04 PM
  22. Solari13's Avatar
    I have tried both of these solutions, on two different roms: 4.2 Jellybean and 4.4.2 KitKat, where previously Wi-Fi had worked fine on the stock rom and my first Cyanogen mod. That mod is actually what caused all of this, an OTA update went wonky and soft bricked my phone, so I went through painstakingly figuring out how to restore it through download mode and I did it. I have custom roms I can go to now and such, but this was my one problem. Wi-Fi just wouldn't turn on. wpa_supplicant.conf is in both /data/misc/wifi and /system/etc/wifi. there's even a wpa.supplicant overlay file along with it.

    Turns out all I had to do was rename it, because indeed, the file needed to be rewritten. Thanks Stephen.

    My phone is a Bell Canadian Galaxy S4 SGH_i337M.
    Hi,

    Please someone explain how to access that file to rename it. I am not able to use my wi-fi on my GT-19505 s4 galaxy.

    Thanks!!
    02-26-2014 05:56 AM
  23. Solari13's Avatar
    Anyone ????
    02-28-2014 12:45 AM
  24. Kilva's Avatar
    Hi,

    Please someone explain how to access that file to rename it. I am not able to use my wi-fi on my GT-19505 s4 galaxy.

    Thanks!!
    1. Root your phone
    2. Download Root Explorer.apk, put it on your phone via USB, install it
    3. navigate to either /data/misc/wifi or /system/etc/wifi
    4. rename or delete wpa_supplicant.conf
    4.5. reboot
    5. ???
    6. PROFIT!
    03-01-2014 01:41 AM
  25. percyabass's Avatar
    Internal SD Memory the Path /data/misc/wifi/ the File named wpa_supplicant.conf is having issue.
    Not going to guess what what was done on your side only that wifi cannot read that file so it just shuts off.
    you need root to view this file, I suggest renaming it, reboot then enable wifi again and it will create a new one.
    you will lose all saved passwords from the beginning of time but will be able to use wifi again.
    I had same issue and tried the method that you mentioned. I am able to got solve it. Thanks
    03-01-2014 05:38 AM
308 12345 ...

Similar Threads

  1. Replies: 19
    Last Post: 10-11-2015, 05:26 PM
  2. Speed up the galaxy S4 and enable the developer mode
    By MallyMall88 in forum Samsung Galaxy S4
    Replies: 21
    Last Post: 11-09-2014, 02:28 PM
  3. DNS not available on Wi-Fi settings on Nexus 10
    By regalhawk in forum Google Nexus 10 Tablet
    Replies: 3
    Last Post: 11-08-2013, 07:32 AM
  4. In-app Videos only playing on Wi-Fi
    By ajbrickyard in forum HTC One M7
    Replies: 6
    Last Post: 07-01-2013, 04:57 PM
  5. [Q] Wi-fi problems.
    By tomy22783 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 06-25-2013, 10:26 AM
LINK TO POST COPIED TO CLIPBOARD