02-20-2017 03:21 PM
303 ... 7891011 ...
tools
  1. Hanin Alhassan's Avatar
    Instead of restarting the phone, turn it off then on.
    10-10-2014 05:37 PM
  2. Erica Brehm's Avatar
    Thanks for the help. I had restarted several times, but removing battery and then booting up worked.
    Golfdriver97 likes this.
    10-12-2014 09:34 AM
  3. justink111's Avatar
    I have rooted my phone with phoenix rom and the wifi won't turn on ...
    Since wifi won't turn on, I can't reroot it again with Towelroot

    PLEASE HELP !!!!
    10-16-2014 12:53 AM
  4. justink111's Avatar
    i did the following

    1. rooted and removed the wpa_supplicant.conf file
    2. reboot
    3.It will create new wpa_supplicant.conf file

    This will work and we can see that wifi-button is enabled but when you reboot it seems the phone can not again access the file(wpa_supplicant.conf) and the button is disabled again
    So do we need to change the file permission so that button is enabled permanently?
    How did you root it without wifi or 4G? I have tried towelroot, motochopper and the other root using odin,,, None of them work
    10-16-2014 01:54 AM
  5. gadgetmk's Avatar
    Taking out the battery and then placing it had solved the problem with wifi.
    rkohlin likes this.
    10-16-2014 06:54 AM
  6. CairoTime's Avatar
    Hi there,
    I am having the same problem with my Samsung Galaxy Tab 4 7.0 inch, neither Wifi nor Bluetooth would turn on. My Bluetooth icon in the upper part of the screen keeps blinking but won't turn on, My Wifi won't work as well.
    I've tried deleting the file named "wpa_...etc" but it won't get deleted.
    I wanted to try the battery unplugging trick, but I don't know how to disassemble this device (Screen face disassembly or side part disassembly)
    Could anyone please help me with that ??????

    Thanks
    10-16-2014 08:38 AM
  7. leo615's Avatar
    i did a factory restore and now it works like new. thank if you agree.
    10-17-2014 07:02 PM
  8. DarkLordSauron's Avatar
    Hi!

    I just want to share with you my solution.
    I tried EVERYTHING I found, not only in this forum, also in others and nothing worked:
    • Remove battery
    • Modify build.prop
    • Modify wpa_supplicant
    • Flash modem firmware
    • Flash Stock ROM
    • Factory Reset
    • And any weird or even no sense solution I could find.

    And then I found out what was going on. I flashed my phone (i9195 in my case) with a stock ROM for my country (Spain) but... it was unbranded (PHE) and my phone is locked for Vodafone. I really didn't expect could be any hardware difference between unbranded and branded phones, but seem like must be something, otherwise, both firmwares should work. I think it was the modem partition, but I didn't check it and right now I really need the Wi-Fi since I'm traveling abroad, so I'm not going to risk it again.
    Once I flashed with Odin the correct firmware, the problem was gone.

    So guys, be sure you're flashing exactly the stock firmware of your country and the operator of your phone.
    11-07-2014 03:35 AM
  9. BurtSherry's Avatar
    Thanks Stephen Griffiths, this worked for me!!!

    Internal SD Memory the Path /data/misc/wifi/ the File named wpa_supplicant.conf is having issue.
    Not going to guess what what was done on your side only that wifi cannot read that file so it just shuts off.
    you need root to view this file, I suggest renaming it, reboot then enable wifi again and it will create a new one.
    you will lose all saved passwords from the beginning of time but will be able to use wifi again.
    11-21-2014 11:48 AM
  10. net4uall's Avatar
    Finally... thank god...
    Been having issues with wifi not tirning on for longer than 6 months now on my s4 i9500. Gave up, almost cried, even been depressed for a bit, having bought it when it just came out, my first android and an expensive one at that.

    Tried everything on the forums. Nothing helped. Even became somewhat a noob expert at rooting, installing different roms, none of which helped.

    Than I thaught, aw hell with it, will use it sometimes with 4g(really expensive in these parts)also no samsung servece center to invoke warranty, hence playing doctor myself. Installed an omega rom, an a few weeks in it started working by it self.
    U wouldn't believe my happiness. Than in just 4 days, same issue. Whole cycle from sad to giving up again. This happened two or three times.
    Got to think must be hardware issue, sought info, couole olaces said might be fixed for a couple 100$. I wasn't going to do that, would think myself to be dumb to do that.

    5-6 days back I decided to go back to stock rom, and use the device unrooted. I didn't last 30 min. With no wifi, there was no fun to be had, so rooted, and for the heck of it deleted the wpa suppl.file, rebooted and to my eye poppin surprise, wifi was lit full green. Lasted for 12 hours.

    Tried the same, deleting wpa.supl, but it never gets restored. This is what happened also the previous times, the wpa suppl never got restored.
    I even made a nandroid backup of when it was working. Still restoring the nandroid never got the wifi working. Makes you wonder, must be a setting nandroid does not cover.

    Depressed as hell started searching the forums for new solutions, none came across that I hadn't already tried.

    Came across i9500xxufnc1 stock rom for my s4, thought, what the hell. Flashed that rom. Rootes, deleted the wpa.sup file, and (knock on wood) it has been working till now, sending this message with it now )).
    So in short Installed stock rom xxufnc1
    Rooted-philz touch- super su
    Installed Es filexplorer Deleted wpa supplicant
    Reboot
    Voila!!

    A couple a questions for the pro's:
    Why doesn't nandroid backup the /data/misc/wifi folder?
    Is there a way to back that up?(just copying it with es file explorer misses a few files,even with root acces)
    Is it on a specific partition, that i can maybe make an image of, and restore it if it acts up again?
    Can anyone deduct from what ive written what the exact cause of the problem might be?

    Again mine is workinh fine now, but these things might help future me's.
    11-26-2014 10:59 PM
  11. Ali Imran5's Avatar
    i delete my wpa_supplicant.conf file when i reboot no again they create wpa_supplicant.conf file for me . and my problem is still there , what can i do plz someone help
    11-27-2014 12:40 PM
  12. net4uall's Avatar
    The same was happening to me. My solution: Install new stock rom through Odin. Root, install es file explorer, remmber to give es file explorer root rights in the settings of es itself. Delete wpa.supp file.
    Should work now, see my previos post above yours.
    11-27-2014 12:50 PM
  13. franck527's Avatar
    hi! i don't know if you solved your problem but i finally got the answer . i had the same problem since last update from samsung. I just solved the problem on my galaxy s4 model SGH-I337M. you need to install stock firmware that you can on the internet . i download it you need to install with odin. after reboot the wi-fi was working for me .

    hope it will help you. have a nice day
    11-30-2014 09:38 AM
  14. andyrockstar's Avatar
    ::::::SOLVED::::::

    Ok people, I had the same problem today for a couple of hours and a friend of mine had this problem for a month.

    Problem Description:
    When I click on the wifi option in the pull down menu, it turns to light green and stays the way for a long time before turning gray. At this point, I cannot scan available networks. Mobile data works option fine.
    I tried the following solutions available on forums
    1. Pull out the battery and turn the phone on -- DID NOT WORK
    2. Turn the phone off and turn back on -- DID NOT WORK
    3. Reset the phone to factory and delete all user data -- DID NOT WORK

    Solution That Worked (for me):
    I observed that when I was resetting the phone (for the 4th time) and in the second step when it asks for wifi networks, it was able to scan the networks and connect to a network. Then after following the rest of the steps in configuration(viz. samsung account login, google account login, etc.) the same issues starts back up.
    If this is the case with you, reset your device to factory settings and when it asks for logging into samsung and google accounts be sure to uncheck restore from server option in both of them(but I think the main problem is mainly with samsung).
    The wifi option turns on fine now. Then not go to settings>accounts and turn on backup and restore manually for both google and samsung one by one. The problem did not rise back up when I followed this process.

    Environment Information:
    Samsung S4
    Kitkat 4.4.2
    GT-I9505

    Hope it helps.......
    I had this exact same problem, but with an unlocked AT&T S4 (SGH-I337, 4.4.2). And none of the other non-rooted fixes had worked, and I was unable to root the phone as I wanted to as I'm currently on another GSM carrier (so no cell data access, which may mean this could all be for naught). And after not checking the "restore from server" option from Google, the WIFI now stays on!

    I suspect this does a similar fix action to the wifi_supplicant file edit/delete thing, but I don't know why this would've worked.
    12-02-2014 02:50 PM
  15. Beatrice Poggi's Avatar
    you're a big man !!! that worked perfectly! I love you now hahahahaha
    12-04-2014 03:54 PM
  16. anonimovbg's Avatar
    Hello everyone
    i had the same problem and find the answer in xda. All who dont have success with other methods try this

    1.root device
    2.Install root explorer
    3.with root explorer edit "system/build.prop" (text editor)
    4-serch this line ro.securestorage.support=true change ro.securestorage.support=false

    What a shame for samsung they have hardware problem and wont fix it
    Good luck to all
    12-13-2014 04:19 AM
  17. dterrab's Avatar
    Hey, I am having the same problem. I did same things but problem is still there. Was your problem solved? It would be veary helpfull. Thks!
    12-23-2014 10:33 PM
  18. you are not going to believe this's Avatar
    Well, you are not going to believe this... I had the same issue with my S4 Wifi connectivity as most everyone here and got an idea from one of the posts that I read, after trying virtually everything else.

    I have two replacement batteries, but I had starting using the original Samsung battery when the trouble started. I switched to one of the after market replacement batteries (available on Ebay, for example, for like $3 - 4 dollars,) and that was all there was to it!! Problem solved.

    I will leave it to one of you that know more about this than I do to explain why, but trust me, it worked!
    12-29-2014 06:01 PM
  19. Gustavo Pimenta's Avatar
    That's save the day. Fantastic! Straight to the point
    01-03-2015 06:21 AM
  20. mob1965's Avatar
    that worked well thank you
    01-09-2015 10:52 AM
  21. Wael Zorik's Avatar
    01-14-2015 07:21 PM
  22. Zain Sheikh's Avatar
    hi there i have the problem as most of my have had here...i just cant turn on wifi on my galaxy s4!! i have rebooted the phone a couple of times done many things but i still hav'nt came up a proper solution..plzz if possible i need some help
    02-19-2015 07:07 AM
  23. SFCStewart's Avatar
    Clear the RAM. Long press the home button. Select the pie icon. Select RAM tab at the top. Clear the memory. If you less than 85 MB of RAM available wi-fi will not work.
    03-12-2015 06:26 AM
  24. Wizardking26's Avatar
    I absolutely need your help... you are the only one posting on here that seems to know what, and mainly WHY things need to be done the way they are done. The first post said to delete the file, not just rename it... then i realized most other posts say just rename it and it will create a new one, but it isn't doing that. I need HELP!!!!!
    03-13-2015 09:29 PM
  25. Wizardking26's Avatar
    The first pos i foundt said to delete the file, not just rename it... then i realized most other posts say just rename it and it will create a new one, but it isn't showing up. I need HELP!!!!!
    03-13-2015 09:30 PM
303 ... 7891011 ...

Similar Threads

  1. Replies: 19
    Last Post: 10-11-2015, 06:26 PM
  2. Speed up the galaxy S4 and enable the developer mode
    By MallyMall88 in forum Samsung Galaxy S4
    Replies: 21
    Last Post: 11-09-2014, 03:28 PM
  3. DNS not available on Wi-Fi settings on Nexus 10
    By regalhawk in forum Google Nexus 10 Tablet
    Replies: 3
    Last Post: 11-08-2013, 08:32 AM
  4. In-app Videos only playing on Wi-Fi
    By ajbrickyard in forum HTC One M7
    Replies: 6
    Last Post: 07-01-2013, 05:57 PM
  5. [Q] Wi-fi problems.
    By tomy22783 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 06-25-2013, 11:26 AM
LINK TO POST COPIED TO CLIPBOARD