11-24-2015 10:05 PM
58 123
tools
  1. dkettel's Avatar
    The problem with calling apple is that they now want to be paid for you to get this fixed. Screw you Apple!!!
    Robinrmj likes this.
    11-07-2013 09:43 AM
  2. colt10axle's Avatar
    Thank you , thank you, thankyou for solving this problem!!!! We were at verizone yesterday and they had no solutions except have all your friends delete and redo the contact. THIS SOLUTION WORKED! I went into settings, messaging, then turned to green the SMS button on my iphone and suddenly my husband was getting my texts!!! I had already deleted the iphone from the apple site but still didn't work. Obviously the IOs7 update is turning off the SMS button on iphones....simple solution that worked!
    11-07-2013 06:13 PM
  3. colt10axle's Avatar
    the IOs7 update is turning off the sms messaging in iphones so they can't text android. Ask you iphone friends to go into settings, then messaging (on their phones) and turn ON the SMS button (it should be green) they can then text android
    11-07-2013 06:18 PM
  4. alexlam24's Avatar
    Apple wants to be isolated like a psychopath. Doing the same things over and over again...

    Sent from Samsung Z1 GPE on T-Mobile
    11-07-2013 06:49 PM
  5. Dwight Kuhl's Avatar
    I found a fix that worked for me.

    I went into the iphone "Settings" (dont worry, I was wearing gloves so I didnt get poo on my hands)...
    Once in settings, go to "messages" and switch to "SMS"...
    I started receivibg txt from that iphone immediately. ..

    Posted via Android Central App
    Cary Jordan likes this.
    11-08-2013 10:41 PM
  6. ebeck82's Avatar
    My problem is similar, since my mum changed from her iphone to a samsung a few weeks ago my iphone now won't call her number, fine calling everyone else and I can text her but calls ring once and go through to voicemail but she doesn't get any notification. Checked both phones and carriers and not blocked - help!!!!
    11-10-2013 03:45 PM
  7. cypherx23's Avatar
    EASY FIX! Call AppleCare (1-800-694-7466) and give them the serial number or IMEI of a new iPhone or of an iPhone with AppleCare (to avoid $29 service call fee). Tell them that you no longer have an iPhone are not receiving text messages from iPhones. They will de-register your number from the iMessage system and you will now receive text messages from iPhones again.
    11-17-2013 01:12 PM
  8. chris_cam's Avatar
    Ok so ive finally figured it out. the txt fails from iphones can now be fixed. All you have to do is go log into icloud.com click on contacts and delete all of it! Or whover had an iphone on your contacts. I know it works because I am now able to receive iphone messages!
    11-18-2013 05:10 PM
  9. chris_cam's Avatar
    Ok so ive finally figured it out. the txt fails from iphones can now be fixed. All you have to do is go log into icloud.com click on contacts and delete all of it! Or whover had an iphone on your contacts. I know it works because I am now able to receive iphone messages!
    Jehan16 likes this.
    11-18-2013 05:14 PM
  10. Jehan16's Avatar
    Thank you thank you thank you chris_cam!! THIS WORKED!! Finally texts from iPhone users!
    Initially I tried the deauthorizing my Apple ID but that didnt work so this was the last straw & I'm so happy that you gave this advice.

    **everyone delete the contacts from iCloud & bam you're getting text messages again**
    11-19-2013 11:24 AM
  11. Bradley Prater's Avatar
    The problem with deleting everything from my iCloud is the fact that my girlfriend and I share the same iTunes account, and therefore also share the same iCloud. I recently switched to a Galaxy S4, and so if I delete my iCloud account I would also be deleting all of the contacts in my Gfriends phone as well. Apple makes it so hard to switch. If I ever turn on my iPad, I start receiving iMessages immediately from all iPhone users, and in turn don't receive them on my Galaxy S4. This system should not be set up this way, and it shouldnt be so complicated. I should just be able to simply use whatever device I want to, and not have to worry about whether I am going to receive messages on one device or another. Apple is slacking, and doing anything they can to keep customers around. Each and every person I talk to who has switched from Apple to Android has told me the same thing, "I don't regret it, and I don't think Im ever going back." I have been an iPhone user for years, and with all previous versions of iOS software (previous to iOS7) have had an auto-detect feature which sent texts as either an "SMS" (regular text to users who can't recieve iMessages) or sent as an "iMessage" to those who are iPhone users in range of accepting iMessages. The "SMS" would illuminate green, while the "iMessage" would illuminate with a blue box. Since iOS7 debued, this feature seems to have been lost, and once a single iMessage is sent to any device linked to your phone number, each and every message after is also sent via "iMessage". Why should I have to delete everything I have ever had associated with Apple just to recieve a test message on my new phone that so happens to not be an Apple product? Why does Apple have such an "All or Nothing" attitude concerning all of their products while the company continues to trail behind all others? I am sick of Apple... so fed up.
    Robinrmj likes this.
    11-20-2013 11:48 AM
  12. Bradley Prater's Avatar
    Yes this is an easy fix, but also a permanent one. I still have an iPad, and would like to receive iMessages on it while still being able to use my Android device. If I remove my # from iMessage I will no longer be able to use my iPad to receive those messages. What happened to the auto detect feature where iPhones were able to detect whether an iMessage could be accepted, and then send it via SMS if not? Once I close my iPad or disable WiFi, messages should automatically be reaching my Android device... but they don't. This has become convoluted and irritating to say the least.
    11-20-2013 12:04 PM
  13. Cary Jordan's Avatar
    when you update the ios 7 it will turn your sms texting off you just have to go back into your setting and turn it back on
    kperra likes this.
    11-20-2013 10:45 PM
  14. Cary Jordan's Avatar
    this is the best way to fix the problem
    I found a fix that worked for me.

    I went into the iphone "Settings" (dont worry, I was wearing gloves so I didnt get poo on my hands)...
    Once in settings, go to "messages" and switch to "SMS"...
    I started receivibg txt from that iphone immediately. ..

    Posted via Android Central App
    11-20-2013 10:48 PM
  15. LuvHTC's Avatar
    Okay this might be lengthy since I need to paint the whole picture of what happened.

    About 3 weeks ago, I switched to the Galaxy S4 active from an iPhone 5. Immediately after the switch, I realized I wasn't getting text messages sent to me from people with iPhones. This was because I have an iPad, and the iMessages on my iPad was turned on, so those messages went straight to my iPad instead of my S4. After I turned off iMessages on my iPad, the problem was solved....

    ...... until iOS 7 came out. Over this weekend, I realized I wasn't getting more than half the messages sent to me. And it turns out, all of my friends with iOS 7 are sending me text messages as iMessages again, even though iMessages is turned OFF on my iPad. The only solution I've figured out for now is to turn my iMessages back on on my iPad and message iOS 7 users from my iPad.

    Has anyone ran into this problem or know how to solve this?? I've loved this phone so much except for the fact that I'm so much less connected to everyone with an iPhone!
    Had the same problem with my daughter's switch from iPhone to HTC One. These are the steps I took: 1) went into iTunes and deleted the phone from their registry; 2) Called Apple and had them delete her number from their registry.

    The person at Apple said it might take 24 to 48 hours to completely flush from their system. He didn't seem surprised so I'm guessing that this is becoming common since the iOS7 update. It does have to do with iMessages. People do not have to delete you from their phones. The 2 steps above worked and she is now getting her texts.
    11-27-2013 08:24 AM
  16. Carlos Navarro1's Avatar
    THANK YOU! I read a LOT of posts and tried a lot of suggestions but your advice finally did the trick. You're absolutely right, SMS is switched off as a default setting for iOS 7.
    kperra likes this.
    11-28-2013 04:09 PM
  17. jiu jitsu's Avatar
    To fix text problem cause apple are a bunch if sneaky c@!nts just change password on your apple account shame on you apple
    12-04-2013 09:44 AM
  18. kperra's Avatar
    thanks Cary....this fix worked great for me....VZ didn't know how to fix it...
    12-04-2013 02:58 PM
  19. erickbn00's Avatar
    I was having the same problem with my iMessages... I unregistered my phone on my 4S and still didn't do anything. I turned off iMessage on the phone and still nothing... Instead, I found that they were going to my Macbook Pro in an application I didn't know existed. I was getting all of the texts to my laptop even when it was off! I went into Preferences and unselected both my phone and email from the application. That seems to have taken care of the problem. You have to figure out any item that would be tied to your phone number and deselect your phone number from that device. If not, it will always find that place to deliver your messages.
    12-13-2013 11:03 PM
  20. Andrew Battistella's Avatar
    This definately worked for me....just now

    Thank you

    GO to Settings>Messaging>and CLICK the Send as SMS button ON (make the button green).

    Terzogenito likes this.
    12-16-2013 09:49 PM
  21. Terzogenito's Avatar
    The turning on of SMS works, but is not practical. Now we need to contact every iPhone user we know and have them enable this setting?
    12-22-2013 12:51 PM
  22. Janis Netherland's Avatar
    I just got off the phone with Apple - and he had a new suggestion that I had not read yet. Tell your friends to delete all old messages & try to message you with a new thread. When you use an existing stream of messages, it tries to continue sending how the thread stated. I just did this and my daughter is finally receiving messages from my IPHONE! Hurray.
    On top of this - I also made sure that the phone number was totally disassociated from apple - by going online & confirming it by phone, and I changed my apple account & password.
    it's working for me now. Good luck.
    12-27-2013 05:25 PM
  23. Terrance McDuffie's Avatar
    I recectly purchased a s4 and was unable to recieve text from any Iphone using iOS7. I tried lots of so called fixes with no success, until I read your solution. Thanks
    12-28-2013 09:40 AM
  24. Samuel Knutson's Avatar
    I was also having the same problems as everyone else, obviously since I'm here posting something. I found this post to be really helpful. I switched to the Galaxy S4 and wasn't receiving texts from certain people; my mother actually freaked out on me because I didn't get back with her after she sent me a half a dozen texts that I never received. I tried a few different things but nothing really made a difference.

    - I unregistered my apple id (said it would take a couple of hours to take affect).

    - I changed my apple id password

    - Asked my family and friends with iPhones to check their phones (go to Settings>Messaging>and click the Send as SMS button ON).

    - Asked my family and friends with iPhones to add my number again since I used to have an iPhone.

    Somewhere in one of these 4 steps something worked and I started receiving texts. It's still relatively early so I don't know if it worked for everyone, but I got texts from one person. It seems like a lot of trouble to do this and I'm rather dissatisfied with iPhones and the Galaxy series after this. I don't know who is at fault but I know that this is a rather tedious problem.
    01-08-2014 07:51 AM
  25. liquid29's Avatar
    THANK YOU! This thread helped me solve this issue without having to call support and wait 3 hours to talk to someone. Much appreciated!
    01-16-2014 12:20 PM
58 123

Similar Threads

  1. I love life after ridding myself from the GNEX
    By enomix in forum Verizon LG G2
    Replies: 32
    Last Post: 10-17-2013, 08:59 PM
  2. Display cracked while in my pocket
    By fit4ever#AC in forum Samsung Galaxy S4
    Replies: 9
    Last Post: 09-25-2013, 03:37 PM
  3. Where is countdown timer?
    By RHS in forum Droid RAZR MAXX HD
    Replies: 4
    Last Post: 09-24-2013, 08:58 PM
LINK TO POST COPIED TO CLIPBOARD