1. carolineelise3's Avatar
    I've had my phone since August and it's kind of rough around the edges from being used so much, but it still runs properly except for today. Well I didn't charge it last night so I brought the charger to school and the charger worked and continued to charge the phone like normal. Then half way through the day my phone died so I plugged it in and left it for about 2 hours without touching or looking at it. Two hours later I came back and the phone is stuck on the screen I left it on. The screen is black, but is turned on like it's charging and has a battery on the front, but the battery isn't turning green like it usually does. In the middle of the battery is a loading circle that's frozen. I've plugged the same charger into different outlets and changed chargers and put them in different outlets, but the phone won't charge. Every time i unplug it it dies but every time I plug it in the phone goes to the same screen and won't change. Please Help
    02-03-2014 04:49 PM
  2. UJ95x's Avatar
    Welcome to Android Central
    Can you boot into download mode? You can do that by pressing volume down + home + power.
    If that doesn't work, you can try a different battery and see if that is what was causing the issue. Otherwise it might be sudden death syndrome

    Posted via Android Central App
    02-03-2014 04:54 PM
  3. Juliette Roy's Avatar
    Did you fix the issue? My phone is doing the same thing.
    07-18-2014 06:11 PM
  4. stevans117's Avatar
    I am having the same problem. I got into download mode however when I tried doing the reset it didn't fix anything. When I go into actual download mode however the computer recognizes the usb as plugged in and it can charge, this and the fact that it recognizes it before the boot launcher has time to activate but not once the phone is actually turned on leads me to believe that it is a software issue. It will charge fully if left on for about 5 hours in the off position because whenever the phone boots is when it doesn't recognize it, causing the issue when the phone is on or even putting power into it's OS. Should I try to download a new OS because I know if I do that it will work, my current update is 4.4.2 but I don't think it was the update that caused this. Any further suggestions?

    I have also already done a reformat on my phone but it just takes it back to it's last updated version and does not fix the issue.
    11-04-2014 01:10 AM
  5. carl scott1's Avatar
    Can I use s4 charger on an s5?
    03-28-2015 08:43 PM

Similar Threads

  1. Nexus 4: Will it last. The big conundrum!
    By doncoop in forum Google Nexus 4
    Replies: 4
    Last Post: 02-07-2014, 08:44 AM
  2. Beats control with S4
    By CarlyRehm in forum Samsung Galaxy S4 Accessories
    Replies: 1
    Last Post: 02-06-2014, 01:38 AM
  3. Samsung Galaxy Note 8.0 vs LG G Pad 8.3 Google Play ed.
    By rorobynbyn in forum Samsung Galaxy Note 8.0 Tablet
    Replies: 1
    Last Post: 02-04-2014, 06:45 AM
  4. Storage Galaxy Xcover 2
    By Matic Kepa in forum General Help and How To
    Replies: 3
    Last Post: 02-03-2014, 05:00 PM