1. maximusjack's Avatar
    Hi
    I'm using a at&t unlocked samsung galaxy s4 active in t mobile, but some of the features which were working in the at&t is not working with
    tmobile, one main feature is is the tethering, when i try to enable tethering i'm getting an error as "mobile data is not available or invalid sim"
    i tried searching the entire forum and tried a lot of ways but nothing could fix it, one main problem is, i'm not even able to root this phone, so
    i'm failing to install any other apk files.

    can anyone please give me a solution for both rooting and enabling the tethering again, below are my device details

    Device: Samsung galaxy s4 active
    Model number" SAMSUNG-SGH-I537
    Android version: 4.4.2
    Baseband Version: I537UCUCNH3
    Kernel Version: 3.4.0-2638177

    Please let me know if you need any details.

    what I tried?
    1) Tried to install superuser, after installing superuser, its asking for binary files, which i'm not able to find anywhere
    2) Then i tried downloading "UPDATE-SuperSU-v2.16.zip" to my
    external storage and tried fastboot, but that one also didnt work, this way, the mobile kind of went into factory reset and the entire software
    got re installed.

    so without rooting it seems like my tethering issue cannot be resolved, any help will be much appreciated.

    thanks
    MJ
    12-06-2014 01:51 PM
  2. Rukbat's Avatar
    You and everyone else. Keep reading Samsung Galaxy S 4 Active - XDA Forums and/or AT&T, Canadian Bell, Rogers, Telus, Virgin Samsung Galaxy S 4 - XDA Forums until someone solves the problem.

    Superuser allows apps to get root access only if you've approved them. It doesn't root the phone, it's an app that runs on a rooted phone. SuperSU is just a different way of doing the same thing.

    To root a phone, you have to copy the su binary to the /system folder - and you have to be rooted to do that. Kind of a catch 22 situation. So rooting consists of some exploit you can take advantage of (a hole or bug in the system) that allows you to temporarily achieve root - just long enough to copy su to the phone. Someone has to find one that will work on the S4 Active. (It took Geohot about a year to come up with Towel Root - but the exploit he used was patched in the kernel around June 3, 2014, so any kernel after that can't be rooted with Towel Root.)

    (TMobil may block tethered connections unless you have a tethering account.)

    I just took another look and, based on your kernel version, Towel Root might be able to root the phone. (If it can't, it'll just tell you nicely, it won't cause any problem.)
    12-06-2014 02:07 PM
  3. maximusjack's Avatar
    Hi Rukbat
    Thanks for responding, I tried towel root as well, it says it doesn't support this device...

    thanks
    MJ
    12-06-2014 06:29 PM

Similar Threads

  1. My Samsung Galaxy s5 battery drains quickly !!
    By n88enw in forum Samsung Galaxy S5
    Replies: 9
    Last Post: 09-19-2015, 06:28 PM
  2. Replies: 3
    Last Post: 12-07-2014, 03:20 AM
  3. Why does my Lg Volt screen stick when turned and doesn't revert?
    By Clara Borisov in forum Ask a Question
    Replies: 0
    Last Post: 12-06-2014, 01:45 PM
  4. Fujitsu hdmi to mhl adapter
    By weezy99 in forum Ask a Question
    Replies: 0
    Last Post: 12-06-2014, 01:21 PM
LINK TO POST COPIED TO CLIPBOARD