1. Guudoo's Avatar
    Hi eveyrone,

    After updating my S4 to android 5.0.1, my wifi randomly stopped working after a few days. Things I have tried to fix the issue:

    • Rebooting phone after leaving battery out for 30 minutes
    • Rooting phone > deleting wpa_supplicant
    • Restoring phone to factory settings
    • Downloading wifi model fix for rooted phones
    • Cleared cache partition

    After doing these things I managed to get my Bluetooth and WiFi hotspot working again, but wifi is unfortunately not working yet..

    Please help!
    07-08-2015 11:21 AM
  2. Richard Cheung X's Avatar
    I'm sure the problem is as basic as just trying to connect to the Wi-Fi by getting the WPS key. Hopefully that should work. I can't think of anything else.
    I also feel sorry for you, that you had to reset your phone and lose everything.
    07-08-2015 12:19 PM
  3. B. Diddy's Avatar
    Welcome to Android Central! Have you also tried rebooting the router, by unplugging its power for 10 seconds, then plugging back in again? See this guide for more tips: http://forums.androidcentral.com/amb...-problems.html
    07-08-2015 12:30 PM
  4. Guudoo's Avatar
    I can't even see the networks in range. If I try to switch on wifi, it just goes back to grey immediately. I've tried putting on wifi in other locations aswell, didnt work.
    07-08-2015 02:37 PM
  5. B. Diddy's Avatar
    Oh, so the switch actually turns off by itself? Try wiping the cache partition, which can be helpful after system updates: http://support.t-mobile.com/docs/DOC-5744
    07-08-2015 04:39 PM
  6. Guudoo's Avatar
    Hi B. Diddy, didnt work unfortunately. Any other suggestions?
    07-08-2015 06:41 PM
  7. B. Diddy's Avatar
    Try using Kies to reinstall the firmware.
    07-09-2015 12:09 AM
  8. Guudoo's Avatar
    I tried going back to android 4.4.2 where eveyrthing worked fine, didnt work either..
    07-09-2015 04:34 PM
  9. B. Diddy's Avatar
    Not sure what to do next, sorry. I wonder if there's an issue with the wi-fi radio/antenna.
    07-09-2015 05:35 PM
  10. Guudoo's Avatar
    Finally managed to fix it! problem started when upgrading to 5.0.1, rooting 5.0.1 didnt work. I then tried goin back to stock 4.4.2 which didnt work either. Rooting the 4.4.2 somehow fixed my issue. Thanks for the help anyway!
    B. Diddy likes this.
    07-11-2015 07:20 AM
  11. rattyster's Avatar
    Hello,

    I have a similar problem.
    Allow me to share some background of it so that its clear.

    I stay in Mumbai, India. I recently bought a new Samsung Galaxy S4 (Model no. SHV-E300S) while returning from South Korea.

    I have been using the phone for a week and it worked fine until a few days ago.
    I'm unable to "enable" WiFi on my phone. Whenever I try to turn it on, it gets turned off automatically within a few seconds. Below are the things I tried but none of them seemed to work.

    1. Restarted my phone over 10 times. - No success
    2. Pulled out the battery while the phone was ON - No success
    3. Pressed *#0011# and clicked WiFi in the Menu section and turned off the "Wifi power saving mode" - Worked for 2 days and then again not working
    4. Hard Reset my phone - no success (after hard reset, the andoid version still remains as 5.0.0 - may be thats how it was delivered to me)
    5. I did not try rooting my phone as I'm unable to do so. Tried Kings Root (through Mobile and through PC) and many other applications but rooting failed everytime.
    6. Reset the Wifi settings in the Wifi section of settings - No success
    7. Kept Wifi on on during sleep as "Never" - no success

    The Wifi button doesnt let me switch it on, and I'm unable to do anything. Please help me with your expertise if anyone has a solution. Please find the details of my phone below:

    Samsung Galaxy S4 LTE
    Model no. SHV-E300S
    Android version: - 5.0.1

    Please help......
    11-09-2015 06:02 AM
  12. drywater's Avatar
    I know this is an old post, but I ran into this problem today and discovered this fix over at FreedomPop forum: forums.freedompop.com/discussion/11710/how-to-upgrade-to-lollipop-5-0-1-fix-wifi-after-upgrade

    Sorry, I can't add links, but that's the address.

    Hope it helps some of you!
    -Stephen
    12-21-2015 05:01 PM
  13. NikolaSi's Avatar
    I find the way. First go to the WiFi options, then press you'r network until menu pop up, then press modify network, then press ipv4 settings and chose static and Write you'r informations, and press save. Hope i'll help you. Sorry for my bad english.
    01-08-2016 01:10 PM
  14. JasonH1972's Avatar
    I have the same problem. Every WiFi network is suddenly "not in range," even if I am right next to the router. My computer and other devices are connecting to networks just fine. It's not just at home. My phone will not connect to any network anywhere. I'm running 5.0.1 on an unlocked AT&T phone. Factory reset did not help, nor scouring these threads and reading the trouble-shooting guide. Also tried changing DHCP to "static."

    Have never tried rooting a phone but am open to that if there's a simple walkthrough. Between this and multiple "SIM not found" errors, my relationship with Samsung is at a low point. can anyone help? thanks!
    03-14-2016 11:51 AM
  15. sadalla mohamed's Avatar
    Hi eveyrone,

    After updating my S4 to android 5.0.1, my wifi randomly stopped working after a few days. Things I have tried to fix the issue:

    • Rebooting phone after leaving battery out for 30 minutes
    • Rooting phone > deleting wpa_supplicant
    • Restoring phone to factory settings
    • Downloading wifi model fix for rooted phones
    • Cleared cache partition

    After doing these things I managed to get my Bluetooth and WiFi hotspot working again, but wifi is unfortunately not working yet..

    Please help!
    05-28-2016 03:26 PM
  16. sulemanq's Avatar
    does wiping the chache partion delete my android upgrade
    07-13-2016 11:23 PM
  17. W3apon of mass willo's Avatar
    I'm sure the problem is as basic as just trying to connect to the Wi-Fi by getting the WPS key. Hopefully that should work. I can't think of anything else.
    I also feel sorry for you, that you had to reset your phone and lose everything.
    01-28-2017 10:32 AM
  18. W3apon of mass willo's Avatar
    does wiping the chache partion delete my android upgrade
    01-28-2017 10:33 AM
  19. W3apon of mass willo's Avatar
    Just turn on plane mode with the right button wait a second turn it off real quick turn on WiFi icon in notification bar it will start if not do it again 100%accurate
    01-28-2017 10:38 AM

Similar Threads

  1. Not receiving Snapchat notifications.....anyone else?
    By skipreid45 in forum Samsung Galaxy S6
    Replies: 7
    Last Post: 12-25-2016, 07:05 PM
  2. How do I shrink my screen back to normal size?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 07-08-2015, 01:45 PM
  3. How do I use handwriting keyboard with LG G4 phone after downloading language?
    By Danny Feinstein in forum General Help and How To
    Replies: 1
    Last Post: 07-08-2015, 12:38 PM
  4. Replies: 1
    Last Post: 07-08-2015, 12:35 PM
  5. Replies: 1
    Last Post: 07-08-2015, 11:42 AM
LINK TO POST COPIED TO CLIPBOARD