1. kingzee's Avatar
    I purchased the BlueAnt Q3 last week and have been having inconsistent issues with it since day one. Using it during calls is fine. It is the use of the command button that is the problem. When pressed, it is supposed to say "say a command," and then you tell it what you want it to do. Well, the problem is that when you press the command button, the Q3 does not always say "say a command." At times it says nothing. Any button functions at that time will also not work, except for the volume toggle. If you make a call using your phone, it will allow you to talk to your party, but other than that nothing else works. To get it to work again, you have to turn it off, connect it to a power source via the mini usb for no more than a second, then turn it back on - and it will work.

    This behavior is sporadic and makes me very disappointed that I spent $100 on this thing. I even upgraded the firmware via the BlueAnt website, but to no avail.

    I'm thinking there may be a conflict with the software and the phones software perhaps.

    Any ideas? Anyone else have this problem and found a solution?

    Thanks.
    06-18-2013 04:21 PM
  2. S_C_B's Avatar
    Wrong thread. You might try posting this in the Samsung Galaxy S4 thread. This thread is for the Samsung Galaxy S4 Google Edition phone. It doesn't come out until 6/26/2013.
    06-25-2013 11:22 AM
  3. dcleingang's Avatar
    I have had exact same problem. I actually returned one and got new one with same issue. I plug it into charger and remove and the problem goes away.
    With Samsung S3 and S4 I also have many problems with blue tooth and no voice coming in and/or going out.
    07-14-2013 01:31 AM
  4. Trevsticle's Avatar
    I have the same issue too. I'm using a Galaxy Note 2 but also get the same issue on my daughter's S4 and My wife's S5.
    I'm on My 3rd Q3 and they all behave the same way. The previous two were sent back under warranty
    To compound the problem I have issues with the power switch. The Q3 will not turn off even after flicking the power switch. all buttons become unresponsive regardless of switch position, but I can still use the earpiece if calls and volume are controlled from the phone.. The problem is sporadic and seems to happen more so when the battery is low.
    Plugging into the charger for one second fixes the issue, but the Q3 will re-fault in anywhere from 1 to 8 hours time.

    A colleague has a iphone 4s and reports similar issues.
    Blueant don't have a solution yet, other than to keep on sending replacements, all with the same firmware glitch (even with the most recent Firmware) It behaves the same way with Blueant Q3 firmware 1.41 for iphone and 1.42 for android.

    Common Blueant, please release an updated firmware to fix this issue. I'm sure there are many other people with the same issue! Word will quickly spread if your product quality begins to slip. Please don't disappoint me.
    07-14-2014 02:11 AM

Similar Threads

  1. My impressions - HTC One, Samsung Galaxy S4, and HTC First
    By return_0 in forum General News & Discussion
    Replies: 7
    Last Post: 05-22-2013, 06:54 PM
  2. Samsung Galaxy S4 and iPhoto/iTunes
    By jakepgreen in forum Samsung Galaxy S4
    Replies: 6
    Last Post: 04-26-2013, 06:53 AM
  3. Replies: 47
    Last Post: 04-12-2013, 09:14 PM
  4. Replies: 47
    Last Post: 04-12-2013, 09:14 PM
  5. Replies: 14
    Last Post: 12-03-2012, 08:19 PM
LINK TO POST COPIED TO CLIPBOARD