08-09-2013 08:57 AM
54 123
tools
  1. evperry's Avatar
    I am actually interested in this phone because of the potential of tmobile LTE.

    It seems to penetrate a bit better than hspa+.

    Has anyone noticed this on the Google edition s4?

    Sent from my Nexus 4 using AC Forums mobile app
    07-11-2013 09:45 AM
  2. snowdogging's Avatar
    I am not getting lte on t-mobile anywhere in manhattan. Talked to tech support for an hour at a t-mobile store with no luck. Have a ticket into engineering to see if they can fix the problem.

    Will update if the situation changes but this could be an easy phone to return at this point.

    Anyone else on t-mobile getting lte?
    07-11-2013 01:18 PM
  3. HNNNNNGHHH's Avatar
    I don't have LTE on my Galaxy S4, since it's the international variant with the octacore Exynos but my HTC One from T-Mobile gets LTE within Houston only. Once I go farther out, it switches back to 3G. (I'm pretty skeptical whether this phone can actually use T-Mobile's HSPA+ as it has great reception in most areas still lacking LTE.)
    07-11-2013 02:06 PM
  4. mattopotamus's Avatar
    I don't have LTE on my Galaxy S4, since it's the international variant with the octacore Exynos but my HTC One from T-Mobile gets LTE within Houston only. Once I go farther out, it switches back to 3G. (I'm pretty skeptical whether this phone can actually use T-Mobile's HSPA+ as it has great reception in most areas still lacking LTE.)
    I think they are talking about the GE s4......
    chitnblr71 likes this.
    07-11-2013 02:15 PM
  5. spridell's Avatar
    You are using the Google edition S4 right?

    This is concerning.

    How is the AWS band? working ok?

    thanks
    07-11-2013 02:35 PM
  6. snowdogging's Avatar
    Thanks for re-railing the thread matt.

    Yes I have a google edition S4 arrive and activated yesterday. As I said LTE (AWS) is not working on the phone. I am only getting hspa and at a pitiful 380k.

    Engineering has done something because now I can't connect at all and registering on the network fails.

    Anyone else using this on t-mobile $30 plan?
    07-11-2013 03:02 PM
  7. jsabo's Avatar
    FWIW, a few of us had a similar issue with AT&T-- what it seems to boil down to is that the system doesn't recognize that your device is capable of doing LTE. They've had to basically lie to their system and say that the phone was an AT&T phone, not a Google phone, at which point things magically work.

    If you can con them into it, have them set your phone up with the serial/ IMEI of one of their S4s and see if it works.
    07-11-2013 03:08 PM
  8. spridell's Avatar
    Yes is there anyone else on T-mobile using this phone that can shed some more light?
    07-11-2013 04:11 PM
  9. evperry's Avatar
    How about tmobile, any issue?

    Sent from my Nexus 4 using AC Forums mobile app
    07-11-2013 04:53 PM
  10. qnet's Avatar
    I just ordered the GE S4 today and wondered about this also. When I had the Touchwiz version, LTE was just coming on in my city and it worked well were I could get it.
    07-11-2013 08:48 PM
  11. snowdogging's Avatar
    As promised the update is here and it is good news! The solution required no calls to tech support and takes 2 minutes. I now have LTE.

    A possible LTE option missing, solution - xda-developers
    07-11-2013 09:56 PM
  12. qnet's Avatar
    As promised the update is here and it is good news! The solution required no calls to tech support and takes 2 minutes. I now have LTE.

    A possible LTE option missing, solution - xda-developers
    That's strange. I've had a Google edition rom for my HTC One that already had that setting. I'm eager to get my GE S4 to see if I'll have to use the app suggested in the thread.
    romero.richardv likes this.
    07-12-2013 08:33 PM
  13. jtshaw's Avatar
    I'm using T-mobile LTE in Seattle with the GPE S4. Comparing this to my Nexus 4, I have fewer problems with general connectivity, the network speeds are WAY faster (as expected), and the battery life is way better so far as well.
    qnet likes this.
    07-15-2013 09:56 PM
  14. evperry's Avatar
    In terms of building penetration, are you seeing a difference?

    Essentially, are there any dead spots that are no longer dead?

    I'm using T-mobile LTE in Seattle with the GPE S4. Comparing this to my Nexus 4, I have fewer problems with general connectivity, the network speeds are WAY faster (as expected), and the battery life is way better so far as well.
    07-16-2013 12:55 AM
  15. shanesaccount's Avatar
    I am actually interested in this phone because of the potential of tmobile LTE.

    It seems to penetrate a bit better than hspa+.

    Has anyone noticed this on the Google edition s4?

    Sent from my Nexus 4 using AC Forums mobile app
    I've got the S4GE on Tmobile, and I've got great penetration into my condo, which is otherwise a steel trap. (In Los Angeles). 1-2 Bars, with speets of 14Mbps Down and 4.2Mbps Up.
    07-16-2013 01:48 AM
  16. evperry's Avatar
    I've got the S4GE on Tmobile, and I've got great penetration into my condo, which is otherwise a steel trap. (In Los Angeles). 1-2 Bars, with speets of 14Mbps Down and 4.2Mbps Up.
    Have you had hspa or hspa+ in the same condo? If so, do you have better penetration with LTE?

    Sent from my Nexus 4 using AC Forums mobile app
    07-16-2013 09:05 AM
  17. shanesaccount's Avatar
    I have. Penetrating seems to be pretty equivalent between the two. But the LTE is faster. Truth told I typically just turn on WiFi.

    Sent from my GT-I9505G using Tapatalk 4 Beta
    07-16-2013 12:46 PM
  18. irishrally's Avatar
    T-Mobile LTE is working great on my GES4 in Dublin, California.
    07-17-2013 11:36 PM
  19. milan03's Avatar
    T-Mobile LTE all over NYC, tested in 4 boroughs.
    Signal is solid, T-Mobile is live with 5Mhz FDD LTE in NYC, maxing at about 35Mbps.

    07-21-2013 06:40 PM
  20. evperry's Avatar
    I got mine.

    My signal is live in every place I have been in nyc.

    I am working on determining if the penetration is any better.

    Highest I've gotten so far is 30mbs down.


    Sent from my GT-I9505G using AC Forums mobile app
    07-21-2013 07:18 PM
  21. milan03's Avatar
    I got mine.

    My signal is live in every place I have been in nyc.

    I am working on determining if the penetration is any better.

    Highest I've gotten so far is 30mbs down.


    Sent from my GT-I9505G using AC Forums mobile app
    They've removed that annoying soft cap of 30Mbps a few days ago, and now it's more "natural" and closer to the maximum peak rate of 37.5Mbps.
    As far as propagation, keep in mind that LTE equipment isn't reporting RSSI or RSCP like 3G tech, it's actually reporting RSRP and RSRQ and the value is always about ~23dBm lower than RSSI RSCP coming from the same cell site for instance. That said, even with what appears to be a low signal level, you are still able to get much better experience than on HSPA+, and achieve respectable data rates. 2x2 MIMO setup is the differentiator.

    Also, don't forget that LTE is data only, so your voice is still going over UMTS.
    07-21-2013 09:36 PM
  22. evperry's Avatar
    A bit too engineery for me. Does Lte penetrator better than hspa? Runs 1700 V's 1900?

    They've removed that annoying soft cap of 30Mbps a few days ago, and now it's more "natural" and closer to the maximum peak rate of 37.5Mbps.
    As far as propagation, keep in mind that LTE equipment isn't reporting RSSI or RSCP like 3G tech, it's actually reporting RSRP and RSRQ and the value is always about ~23dBm lower than RSSI RSCP coming from the same cell site for instance. That said, even with what appears to be a low signal level, you are still able to get much better experience than on HSPA+, and achieve respectable data rates. 2x2 MIMO setup is the differentiator.

    Also, don't forget that LTE is data only, so your voice is still going over UMTS.


    Sent from my GT-I9505G using AC Forums mobile app
    07-21-2013 09:53 PM
  23. milan03's Avatar
    A bit too engineery for me.
    Sorry to hear that.
    07-21-2013 10:04 PM
  24. milan03's Avatar
    10Mhz LTE is being tested in NYC finally!

    07-23-2013 09:32 PM
  25. evperry's Avatar
    10Mhz LTE is being tested in NYC finally!

    http://i.imgur.com/yKMynV8.png
    Where are you getting those speeds?

    Sent from my GT-I9505G using AC Forums mobile app
    07-23-2013 09:50 PM
54 123

Similar Threads

  1. Replies: 10
    Last Post: 10-26-2013, 08:10 PM
  2. AT&T LTE
    By James Cortez in forum Samsung Galaxy S4 Google Edition
    Replies: 59
    Last Post: 08-22-2013, 11:52 AM
  3. How to enable LTE only?
    By sterandroids in forum Samsung Galaxy Note 2
    Replies: 5
    Last Post: 07-13-2013, 07:35 AM
  4. HTC One or wait for Tri-band LTE
    By No Cover in forum Sprint HTC One
    Replies: 3
    Last Post: 07-11-2013, 04:52 PM
  5. HTC One 4G Lte sim card
    By faze1337 in forum Sprint HTC One
    Replies: 0
    Last Post: 07-10-2013, 08:04 PM
LINK TO POST COPIED TO CLIPBOARD