1. cdd543's Avatar
    I just wanted to post about an issue I ran into with the S4GE(This also affects other straight google devices as I had the same issue with my nexus 4 for the brief time I had it.) The device would not connect to enterprise wifi Peap using dynamic IP. Stock sense 5 and other skinned android/ios devices have worked fine for me. The solution for me was downloading the wifi advanced configuration editor from the play store as it gave me access to the enterprise configuration/phase 2 option where I was able to select mschapv2 as an option. This allowed me to connect immediately and now I'm set. It took a bit of googling to get some ideas of how to deal with it, but this is working for me and might save someone else the same headache.
    07-12-2013 10:06 AM
  2. kjnangre's Avatar
    I just connected using mschapv2 on my S4 GPE straight out of the box
    07-22-2013 07:36 PM
  3. cdd543's Avatar
    I just connected using mschapv2 on my S4 GPE straight out of the box
    Good glad it worked for you. Maybe my configuration was slightly different.
    07-23-2013 12:16 AM
  4. Genetic White Wolf's Avatar
    unfortunately, the issue has not been adressed yet.
    this is an intermitent problem. connecting to the enterprise wifi sometime work, sometime it doesn't. (same wifi)

    I got 2 x Samsung Galaxy S3, they both experience the same problem in my enterprise network.

    if someone want to investigate, here my finding:

    a) Open enterprise network (no password) doesn't experience the problem
    b) Enterprise network using only alphanumeric password doesn't experience the problem.
    c) Enterprise network using special caracter password like $ does experience intermitent connection problem.

    The intermitent connection problem is as follow:
    step 1. the device (in my case both Galaxy S3) might or might not connect automatiquely when the wifi is in reach.
    step 2. if they connect, it seem to work fine until you move too much (losing connection handshake ?)
    step 3. in that case we're back to step 1

    if the device is unable to connect, pressing the connect to wifi button on the S3 result in "Invalid Password" message
    you then have the option to "connect" or "change config" or "forget network"

    "connect" has a low success rate (1 out of 15)
    "forget network" has a high success (1 out of 5) rate but you'll have to enter back all your credential (painfull if you have a complicated password)
    shutting down wifi completely, waiting a few second and opening back wifi has a medium success rate (1 out of 10) you're back to step 1

    I also found a web site describing the problem and explaining how to fix it but you have to root the phone to install another Wifi module.
    sorry folk, I didn't kept the link as I don't want to root my phone,

    I called Samsung technical support, I gave them the link... they completely ignored it and told me the problem WAS NOT the phone. They had this reasoning:
    "if the problem would have been the phone, we would have hear about it"
    way to go samsung, if you refuse to hear about it, how can you come to this conclusion ?!
    I asked to talk to a level 1 tech, they said I was talking to the more experienced tech. I told him the problem only occur to Enterprise network and he asked me what that was....
    ??? after more then an hour trying to explain to him how to reproduce the problem, I asked to talk to another tech. He said to me (convinced) "if you think that would ease your mind I got no objection but nobody else will be able to help you more them me... then he said he would put me on hold but instead, he hang up...
    last time I buy a Samsung device.
    Of course I understand how relunctant a compagny could be to acknowledge a flaw in a sowftware when they sold many million of the unit...
    but at least recognize there might be something worth investigating....
    08-14-2013 10:12 AM
  5. styx_phoenix's Avatar
    For what it's worth, I have a Galaxy S4 and a Nexus 7 (both running Jelly Bean, though the Nexus 7 tablet is now on 4.4) and the Nexus 7 has zero trouble with connecting to 802.1x EAP / PEAP network. However, the Galaxy S4 experiences problems remaining connected to the same network. Today I happened to find a solution to keep it connected, though the notification about the internet connection being slow or unstable continues to pop up -- despite the fact that it's fine when browsing. If you use the menu button while in the WiFi networks list and choose Advanced, you will be presented with the following menu. The option "Auto network switch" is enabled by default. If you disable it, the wireless network will stay connected. As I said, the message about the unstable or slow internet pops up periodically, but the connection remains intact. (If someone knows how to disable that notification, we'd be golden!)

    Anyway, here is the screen I am talking about:
    Wifi 8021x Peap MSCHAPV2 enterprise connection issue-wireless_adv.jpg
    12-04-2013 02:23 PM

Similar Threads

  1. HTC One Touchscreen issues
    By dubmess in forum HTC One M7
    Replies: 11
    Last Post: 06-19-2014, 11:25 AM
  2. Camera Issue After Update
    By coreyacole in forum Samsung Galaxy S4
    Replies: 9
    Last Post: 07-19-2013, 11:51 PM
  3. Having a bizarre battery/charging issue...
    By eightbitheroics in forum Google / Samsung Galaxy Nexus
    Replies: 4
    Last Post: 07-18-2013, 04:59 PM
  4. Hotel chain WIFI
    By mclip in forum Google Nexus 10 Tablet
    Replies: 6
    Last Post: 07-15-2013, 10:42 AM
  5. Google Voice Search Issue
    By Ray Josephs in forum Verizon Samsung Galaxy S4
    Replies: 9
    Last Post: 07-14-2013, 12:29 PM