1. Richard Lao's Avatar
    I recently purchased a S4 GE and it was working fine. Received Lte here in Honolulu HI perfectly fine. I used to use the Tmobile Version of the S4 that also connected to Lte just fine. The other day, i accidentally clicked on "Use only 2G networks" and when i unchecked it, I am unable to receive Lte anymore. Currently it says H (3.5g). I am unable to get it back on Lte no mater what I tried. All the access point names and address are correct.
    T-Mobile US LTE fast.t-mobile.com

    I tried turning off network re-enabling network. restarting the phone, turning on 2G networks only again and off. I can get my Lte working again. Has anyone else run into this problem and maybe found a fix? I would hate to have to do a factory reset just to get Lte back.

    Phone is unrooted.
    07-19-2013 10:26 PM
  2. Sasazuka's Avatar
    The most commonly suggested thing is to get an app and change the radio band.
    07-20-2013 12:02 AM
  3. Richard Lao's Avatar
    Thanks so much. It worked!
    07-20-2013 06:08 AM

Similar Threads

  1. Unable to receive MMS Messages (Pictures) using Straight Talk on GT-N7105
    By kennethsnyder in forum T-Mobile Galaxy Note 2
    Replies: 6
    Last Post: 08-04-2014, 08:00 AM
  2. TV app not working in India
    By shambains in forum HTC One M7
    Replies: 2
    Last Post: 11-18-2013, 08:06 PM
  3. Is it safe to use the car charger?
    By Nabooy in forum General News & Discussion
    Replies: 18
    Last Post: 07-24-2013, 09:32 AM
  4. Nexus 4 ROM and root and how to???????????????
    By roberto1811 in forum Google Nexus 4
    Replies: 3
    Last Post: 07-21-2013, 02:09 PM
  5. How to keep the led on while using phone (GTI9300)
    By Castro Bevans in forum Samsung Galaxy S3
    Replies: 4
    Last Post: 07-20-2013, 03:43 PM
LINK TO POST COPIED TO CLIPBOARD