10-06-2013 11:34 PM
61 123
tools
  1. SamuriHL's Avatar
    Right so your recovery partition is from an i9505 and not from our i9505g. I'm not at my laptop right now so I don't have the link to the stock 4.2.2 odin flashable tar md5 I made, but I'll post it for you soon. Pda flash it in odin with just auto-reboot checked and it'll restore a proper recovery and you'll be able to apply the update.

    Sent from my Xoom using Tapatalk 4
    Sasazuka likes this.
    08-10-2013 09:13 AM
  2. SamuriHL's Avatar
    http://www.mediafire.com/download/30...covery.tar.md5

    As promised the odin flashable stock 4.2.2 recovery img. This will allow you to install the OTA update.
    Sasazuka likes this.
    08-10-2013 10:42 AM
  3. Sasazuka's Avatar
    Will I lose any data this way?

    I've been checking for OTA updates, but it seems I can't download it anymore. Should I flash the stock then check or just wait until I can get the OTA update then flash the stock image?

    I've seen people post about clearing the cache to get the update, is that something I should do as well?

    Thanks for all your help!
    08-10-2013 05:45 PM
  4. SamuriHL's Avatar
    No loss of data. You should flash this before you get the ota update. It won't install without it. Yes, wipe the cache... It may help. You can test this stock recovery image once you flash it by going in and wipe the cache from there.

    Sent from my Xoom using Tapatalk 4
    Sasazuka likes this.
    08-11-2013 08:30 AM
  5. Sasazuka's Avatar
    Did flash to stock, wiped cache, got the OTA, rebooted, installed, and now I'm stuck at boot animation?

    Did I miss a step?

    EDIT: Right now, I don't mind data loss if I can get things working again...
    08-11-2013 09:26 PM
  6. SamuriHL's Avatar
    Yikes. You can try going back into recovery and performing a factory reset. That will wipe the data partition so you'll lose everything. I don't get what happened at all. It should have booted up fine. Any errors during the ota install?

    Sent from my Xoom using Tapatalk 4
    08-11-2013 11:55 PM
  7. Sasazuka's Avatar
    None that I could see. I go into recovery (power + vol up), does an installation, errors out, reboots, and is stuck. I think it succeeded the first couple of times but it always became stuck at booting up.

    I'm OK with whatever data loss that might occur but I can't seem to factory reset it. I did power+vol up+vol down and I didn't see that as an option.
    EDIT: I get recovery mode, restart bootloader, power off, and start. I see bootloader version I9505GUEUAMFD.
    EDIT: Perhaps, there's some key combination to do a reset on this screen?
    EDIT: Whenever, I do recovery mode, it would say "installing system update" followed by error, and then endless boot animation.
    EDIT: As far as I can remember, there weren't any errors during OTA update but I could be wrong.
    08-11-2013 11:58 PM
  8. SamuriHL's Avatar
    It's not finishing the update and is continually trying to install it. I can't even begin to comprehend what went wrong here. I know how I'd try to fix it but it's ugly. I'm also extremely tired so I don't want to detail steps right now and screw something up. However I'd try to odin flash twrp recovery and boot into that. Then wipe the cache (not a factory reset as that isn't necessary). That should get it booting again. Again I can't give the exact steps right now but if you're still stuck in the morning I'll help you. Very strange situation!

    Sent from my Xoom using Tapatalk 4
    Sasazuka likes this.
    08-12-2013 12:16 AM
  9. Sasazuka's Avatar
    Well, I seem to be hitting all the speed bumps. I tried this first but they didn't have the TAR so I tried this which seems to work. I boot into recovery and see TWRP then I go Wipe > Advanced Wipe > select Cache > then wiped. I had something like this show up:
    E:unable to find partition size for '/data'
    Updating partition details...
    E:unable to mount '/preload'
    Running boot script...

    Finished running boot script.
    Formatting Cache using make_ext4fs
    Done.
    Updating partiion details.
    It complained about root permissions being wrong and if I wanted to fix it - first time I said no and it's still stuck at boot animations. I re-did the wipe and this time said "yes" to fix permissions - same results.

    Thanks for all your help so far, don't worry if you can't post right now. Maybe the best thing is to just start all over? Would the factory reset get me back to how I first got my phone?
    08-12-2013 01:28 AM
  10. SamuriHL's Avatar
    VERY VERY bad. DO NOT use things that aren't designed for our phones. You can really screw things up. The i9505 is NOT the same as our phone and the partitions are all different. So if you use stuff for the i9505 and it applies things to the wrong partition it can really mess up your phone. Enough lecturing, let's get this thing fixed.

    [ODIN][TAR] I9505GUEUAMFD 4.2.2 Full Rooted Restore - xda-developers

    Flash that. It'll reset your world back to 4.2.2. Once that's done, you can let the OTA upgrade take place again.
    08-12-2013 09:22 AM
  11. Sasazuka's Avatar
    I'll be sure to pay attention to the versions more carefully in the future, thanks for the warning.

    I never unlocked my bootloader, will that still work for me?
    EDIT: Did the restore, unlocked bootloader, re-downloading 4.3 OTA. Hopefully this time it'll install just fine. I'm going to hold rooting/installing anything for now.
    EDIT: 4.3 updated successfully, re-installing apps seems to be going alright (need to look into restoring settings)
    08-12-2013 11:49 AM
  12. SamuriHL's Avatar
    Sounds like you're on the right path now. I've never unlocked my bootloader either. So far haven't needed to. If you need any further help, let me know.
    08-12-2013 06:10 PM
  13. Sasazuka's Avatar
    Many thanks for getting me back on the right track. I'm on 4.3 now without root and I've been looking more carefully this time for a I9509G root solution and found the following:

    • This seems like a safe approach with no data loss albeit a bit overkill
    • This is what is mentioned in this thread and probably the wrong approach since it's not for I9505G
    • This seems like a good solution but would result in data loss
    • This looks like another easy solution but it ended up pointing to the above thread that would result in data loss
    • This looks OK, but it's pointing to a I9505 instead of a I9505G but people says it works


    Any suggestions for which path I should go? Or maybe an alternative?
    08-12-2013 11:55 PM
  14. SamuriHL's Avatar
    The easiest solution by far is to install twrp recovery, boot into it, and flash the su zip. Done. But that does overwrite the recovery partition which isn't all bad. Twrp is rather useful. Alternatively you could temp boot twrp using fastboot and then flash the su zip. That's a fair bit more work. I'll see if I can put something together later to help male this easier.

    Sent from my Xoom using Tapatalk 4
    08-13-2013 08:22 AM
  15. SamuriHL's Avatar
    Anyone looking to root the S4 GPE can follow along here:

    xda-developers - View Single Post - [HOWTO] Root Stock i9505G 4.3 (Google edition)

    I automated the process outlined in the OP of that thread.
    Sasazuka, planoman and kjnangre like this.
    08-13-2013 10:26 AM
  16. Sasazuka's Avatar
    This works perfectly - I ran into a minor problem which I just want to let others know about:

    After booting into Clockwork's recovery, I was no longer able to sideload due to USB drivers issue. I just kept going the first time and said "no" to the extra prompt about fixing root. I just needed to re-install USB drivers in Clockwork's recovery before sideloading and everything went smoothly afterwards.
    SamuriHL likes this.
    08-13-2013 12:40 PM
  17. SamuriHL's Avatar
    So now you are on 4.3, rooted, with stock recovery for when the next update comes. How awesome is that?
    08-13-2013 01:24 PM
  18. mixgenio's Avatar
    I recently purchased the S4 GE myself and am looking to try out your automated method. Should I be on 4.2.2 before attempting it? Or will it not matter if update to 4.3? Also, does the method temporarily boot twrp using fastboot and then flash the su zip or does it overwrite the recovery partition permanently with twrp?

    Anyone looking to root the S4 GPE can follow along here:

    xda-developers - View Single Post - [HOWTO] Root Stock i9505G 4.3 (Google edition)

    I automated the process outlined in the OP of that thread.
    08-27-2013 11:25 PM
  19. SamuriHL's Avatar
    Doesn't matter what version you're on.
    Uses cwm, not twrp.
    Doesn't overwrite recovery... Only temporarily boots cwm in memory.

    Sent from my Xoom using Tapatalk 4
    mixgenio likes this.
    08-28-2013 08:07 AM
  20. mixgenio's Avatar
    yeah. not long after asking you I figured out that my questions had already been answered by you/others in your linked thread. And so, because I was anxious to root, I pushed forward with the process and rooted while still on 4.2.2. UNFORTUNATELY, I didn't pay attention to the warnings that said to remove root prior to taking the 4.3 update and proceeded to get stuck in a boot loop at 2AM. Thankfully I was able to follow the instructions you provided to Sasazuka and am now safely on 4.3 with root.

    So with that said: Thank you. Your easy to follow root executable was perfect and the instructions on how to get back to 4.2.2 were a savior to me and my brand new phone. lol
    SamuriHL likes this.
    08-28-2013 09:29 AM
  21. SamuriHL's Avatar
    Glad you got it sorted out!
    08-28-2013 11:15 PM
  22. kjnangre's Avatar
    Thanks SamuriHL! Couldn't get the drivers to work on my Windows 7 64-bit computer, but I switched to a 32-bit Windows 7 PC and was rooted in minutes!
    SamuriHL likes this.
    08-29-2013 02:24 PM
  23. argold's Avatar
    I am still really hoping this won't be necessary, but in the event - could someone clear up a couple of points:

    1) What is the difference between the UniversalAdbDriverSetup6.msi in the ZIP (9,208,320 bytes) and the UniversalAdbDriverSetup.msi (9,215,488 bytes) I see on the GitHub koush page?

    2) If RUN.bat achieves root, what is the process to unroot - for after I have fixed that one missing line in platform.xml?

    Thanks.
    08-29-2013 05:35 PM
  24. SamuriHL's Avatar
    He may have updated it on git since I put that package together. Use whichever version you would like. Latest is best. I only included it as a convenience.

    Supersu has a clean up full unroot function.

    Sent from my Xoom using Tapatalk 4
    08-29-2013 11:49 PM
  25. argold's Avatar
    Many thanks.
    08-30-2013 06:17 AM
61 123

Similar Threads

  1. I have an LG Optimus Zone Vs410PP need help rooting
    By Jamesgillaspy in forum General Help and How To
    Replies: 16
    Last Post: 12-05-2015, 08:26 AM
  2. Correct steps to get root back after OTA Update?
    By ryanf in forum Nexus 4 Rooting, ROMs, & Hacks
    Replies: 11
    Last Post: 04-10-2015, 04:37 AM
  3. Do I need root to use VZW S4 on ATT/Tmo?
    By project.in.process in forum Verizon Samsung Galaxy S4
    Replies: 11
    Last Post: 06-24-2014, 11:51 PM
  4. Google Play Music All Access vs. Root/ROM
    By TJH132 in forum Verizon Galaxy Nexus
    Replies: 4
    Last Post: 10-01-2013, 10:10 PM
  5. Rooted
    By s4ondeck in forum Samsung Galaxy S4 Rooting, ROMs & Hacks
    Replies: 1
    Last Post: 07-20-2013, 09:30 PM
LINK TO POST COPIED TO CLIPBOARD