1. jwrileyiv's Avatar
    First post, I will do my best to cover this issue in detail.
    GT-19505G
    Android 4.3
    Google Play 3.2.25
    Maps 7.0.1

    I am having a consistent issue with Maps (7.0.1) not finding my location regardless if I am on wifi or not. I have even waited 15+ minutes driving or stationary to see if a fix would happen, nothing. The only workaround I have been able to figure out with getting directions on Maps to work is if I put in an address as my location, select destination and then hit navigate. Otherwise Waiting for Location is persistent.

    Some settings I have are as follows - Location Access On, GPS checked, Wifi, checked. Under Wifi - Advanced, Scanning is off, avoid poor connections, checked, wifi optimization, checked. I have also done a few tests by turning on/off wifi, going into Location Settings in Maps to ensure Access Location is checked and rebooting to see if another setting or service is conflicting with Maps since my GPS fix is strong (fixed with 18).

    So the only quick fix I have found is to uninstall updates on maps from 7.1.0 to 6.14.4 and bingo, location works perfect and I can navigate in seconds. I have also successfully uninstalled updates on Google Play 3.2.25 to 3.1.58 and bingo Maps 7.0.1 works perfect. Hum....Maps 6.14.4 works with Google Play 3.2.25 and Maps 7.1.0 works with Google Play 3.1.58.

    Anyone else having this issue? If so have you tried different settings or configurations and found a right combination? Thanks for listening, otherwise an amazing phone.

    How would I escalate this to Google, call them? or is there a support website?

    Maps 7.1.0 - Waiting for Location-gps.jpgMaps 7.1.0 - Waiting for Location-address-waiting.jpg
    08-26-2013 10:39 AM
LINK TO POST COPIED TO CLIPBOARD