09-17-2014 09:10 PM
31 12
tools
  1. mjolsen74's Avatar
    Looking for some help and ideas here..

    I have a GPE S4 on the AT&T network.. I also have a spare GS4 (ATT branded).

    GPE S4 - running Android 4.3 stock - MMS while connected to wifi will not send. turn off Wifi and they send fine
    ATT S4 - running Android 4.2.2 MF3 stock - MMS while connected to wifi send fine.

    I have checked and matched the GPE S4 to use the identical APN settings as the ATT S4. I have tried in the stock messaging app. I prefer textra and tried textra on both, setting "Activate Mobile Data when sending/receiving an MMS" is checked on both devices and it doesn't make the GPE get an MMS while connected to wifi.

    I have scoured the internet and there are TONS of threads about this very same topic on many carriers... a lot point to APN settings. I have validated that APN is proper and the fact that it works while NOT on Wifi proves this.

    The ONLY thing I can think of is 4.3 or stock android doesn't make the MMS app(s) use the mobile data and tries to send it out the wifi connection which will not work.

    Anyone with GPE on ATT network able to test this for me?

    Thanks,
    Mike
    09-09-2013 06:48 PM
  2. Almeuit's Avatar
    Is mobile data staying toggled on when on the GPE?

    Sent from my T-Mobile HTC One using AC Forums.
    09-09-2013 07:00 PM
  3. planoman's Avatar
    Looking for some help and ideas here..

    I have a GPE S4 on the AT&T network.. I also have a spare GS4 (ATT branded).

    GPE S4 - running Android 4.3 stock - MMS while connected to wifi will not send. turn off Wifi and they send fine
    ATT S4 - running Android 4.2.2 MF3 stock - MMS while connected to wifi send fine.

    I have checked and matched the GPE S4 to use the identical APN settings as the ATT S4. I have tried in the stock messaging app. I prefer textra and tried textra on both, setting "Activate Mobile Data when sending/receiving an MMS" is checked on both devices and it doesn't make the GPE get an MMS while connected to wifi.

    I have scoured the internet and there are TONS of threads about this very same topic on many carriers... a lot point to APN settings. I have validated that APN is proper and the fact that it works while NOT on Wifi proves this.

    The ONLY thing I can think of is 4.3 or stock android doesn't make the MMS app(s) use the mobile data and tries to send it out the wifi connection which will not work.

    Anyone with GPE on ATT network able to test this for me?

    Thanks,
    Mike
    I have the same two phones. I just tried to send a MMS (picture) to my work phone while on WiFi and it works fine.

    Does this happen on all WiFi? At home only? It think it is more likely the WiFi. Does the WiFi act the same way for both devices? You can make calls while on WiFi correct?

    Sent from my Nexus 7
    09-09-2013 07:04 PM
  4. mjolsen74's Avatar
    Yes.. My test was in the same environment... I can make calls while on wifi... Are you running 4.3 on the GPE?
    09-09-2013 07:13 PM
  5. planoman's Avatar
    Yes.. My test was in the same environment... I can make calls while on wifi... Are you running 4.3 on the GPE?
    Yes, 4.3.

    Sent from my Nexus 7
    09-09-2013 07:14 PM
  6. Jensen's Avatar
    I have the exact same problem so you're not alone.

    Planoman are you in an area with LTE when you successfully sent an MMS on WiFi? i.e. if you shut off WiFi on your GPe does it connect to the LTE network?
    09-09-2013 07:22 PM
  7. mjolsen74's Avatar
    ATT? If so, can you share your APN settings? I don't believe this to be the cause.. because the APN settings are identical on both phones.

    Not sure how anything on my wifi could be causing this.... I did try an entirely different wifi router too just for the sake of trying..
    09-09-2013 07:23 PM
  8. planoman's Avatar
    I have the exact same problem so you're not alone.

    Planoman are you in an area with LTE when you successfully sent an MMS on WiFi? i.e. if you shut off WiFi on your GPe does it connect to the LTE network?
    Yes strong LTE.

    Sent from my Nexus 7
    09-09-2013 07:45 PM
  9. mjolsen74's Avatar
    so.. here is the STRANGE thing.. at work on wifi, they send fine.. One thing different I do have a MicroCell at home... Now I did try turning it off last night and use the poor signal.. but same experience. May have to leave the microcell off for an extended period so the phone doesn't recognize it.

    such a strange issue..
    09-10-2013 08:20 AM
  10. Jensen's Avatar
    Interesting. It won't work for me at home or on work wifi.

    Have you tried experimenting to see if it matters whether or not you are connected to a 5 or 2.4ghz network?
    09-10-2013 09:35 AM
  11. mjolsen74's Avatar
    yes, I have tried both 2.4 and 5ghz wifi at home.

    next step this week is an entirely different router. I currently have an Asus RT-N66U flashed with DD-WRT... I have used DD-WRT for years with great luck... so I will try a different router without it just to rule it out.

    I ruled the MicroCell out tonight.. I turned it off a few hours ago, left phone off for a bit and connected to the local cell tower. same issue.

    The freaking crazy part is the AT&T S4 with TouchWiz works just fine.

    I swear it seems like the OS (4.3) isn't switching to mobile data like it should... I have Textra which has an additional check box to enable it too and that doesn't work. and yes.. I did try the stock messaging app too.. same results
    09-10-2013 07:47 PM
  12. Jensen's Avatar
    yes, I have tried both 2.4 and 5ghz wifi at home.

    next step this week is an entirely different router. I currently have an Asus RT-N66U flashed with DD-WRT... I have used DD-WRT for years with great luck... so I will try a different router without it just to rule it out.

    I ruled the MicroCell out tonight.. I turned it off a few hours ago, left phone off for a bit and connected to the local cell tower. same issue.

    The freaking crazy part is the AT&T S4 with TouchWiz works just fine.

    I swear it seems like the OS (4.3) isn't switching to mobile data like it should... I have Textra which has an additional check box to enable it too and that doesn't work. and yes.. I did try the stock messaging app too.. same results
    I actually thought the problem was with LTE specifically. Here's why: when I first got the GS4 GPe I was using it on Net10 which was HSPA+ only. On Net10 I could send receive MMS just fine on wifi.

    I then got a new SIM on ATT's LTE network and that's when I started to have the problem. You might want to try and replicate by setting your data connection to 2G only for a bit to see if that will allow you to send while on Wifi.

    The fact that it worked for you on work wifi and works for Planoman is throwing me off though. I guess there must be some router setting it's having a problem with.

    Can you and Plano tell me what options are you using in the advanced section of the wifi settings in Android?

    I have keep wifi on during sleep: always
    scanning always available: off
    Avoid poor connections: on
    Wi-fi frequency band: auto
    wifi optimization: on
    09-10-2013 08:08 PM
  13. planoman's Avatar
    I have the same wifi settings except the avoid poor connections is off.

    Posted from my bada$$ GT-I9505G
    09-11-2013 06:32 AM
  14. Almeuit's Avatar
    Very odd issue indeed. No sure what would be preventing the GPE from sending while on wifi.

    Sent from my T-Mobile HTC One using AC Forums.
    09-11-2013 07:03 AM
  15. mjolsen74's Avatar
    So, It seems it is something with DD-WRT open source router software... not sure what is going on here but when I connect to my wifi router that is DD-WRT, it does this (only on Android 4.3). I have tried the following routers that have dd-wrt installed (Linksys E4200, Asus RTN-12, Asus RT-N66U). So, it is common across DD-WRT.

    Asus RT-N12 with stock asus firmware everything works fine.....

    Strange huh?
    09-12-2013 12:13 PM
  16. Jensen's Avatar
    So, It seems it is something with DD-WRT open source router software... not sure what is going on here but when I connect to my wifi router that is DD-WRT, it does this (only on Android 4.3). I have tried the following routers that have dd-wrt installed (Linksys E4200, Asus RTN-12, Asus RT-N66U). So, it is common across DD-WRT.

    Asus RT-N12 with stock asus firmware everything works fine.....

    Strange huh?
    Well I'm having the same issue with a stock netgear router... and the router at work is most certainly stock as well. I think it's deeper than DD-WRT.
    09-13-2013 12:57 PM
  17. mjolsen74's Avatar
    So.. I continue to have this problem... replaced my wifi router with a new ASUS with stock firmware.

    Not sure where to go next but a factory reset.. and see if it fixes the problem.
    09-30-2013 07:44 PM
  18. planoman's Avatar
    I am using a belkin AC router and have always used belkin and had no issues.

    I just tried it again using my S4 GPe over wifi and it works fine. I would reset to see if that works.
    09-30-2013 09:59 PM
  19. jolt_man's Avatar
    I had been having the same issue with my wife's Google Edition Galaxy S4 behind a pfSense 2.0.3 and 2.1 firewall. Here is my thread (from xda) on how I fixed it:

    SOLVED!

    I have finally solved the issue. I'm so happy it's fixed. For those that happen upon this thread, here's what I did:

    Since I had nothing blocked in the firewall rules, and I had Outbound Manual NAT enabled, that wasn't the issue. I was in the #pfsense channel, and someone happened to come in complaining about a ping not resolving. Specifically, he was trying to ping:

    Code:
    ping some_DNS_name_on_internet
    It was supposed to resolve to a PRIVATE IP address, in his case, 10.0.0.1. I could get it to resolve from my work connection (not behind pfSense). So I began pinging the MMSC and MMS addresses in the APNs I listed earlier. All of them resolved and/or responded, except one:

    Code:
    proxy.mobile.att.net
    Behind the pfSense 2.1 firewall, it wouldn't resolve. From anywhere else (from the phone disconnected from WiFi, from my office network) that address would resolve:

    Code:
    $ ping proxy.mobile.att.net
    PING proxy.mobile.att.net (172.26.39.1) 56(84) bytes of data.
    ^C
    --- proxy.mobile.att.net ping statistics ---
    2 packets transmitted, 0 received, 100% packet loss, time 1007ms
    But look at the address it was resolving to! I thought that since I had disabled blocking RFC1918 on my WAN port and LAN port, the address would have resolved. It didn't. The user in #pfsense said that it's not a bug, but a feature of dnsmasq and that pfSense was "protecting us from ourselves". Very strange I thought. But what's even stranger, was the fact that AT&T was deliberately resolving a DNS name to an RFC 1918 address on the PUBLIC internet. My only guess is that the phone will try the WiFi first, find that this address resolves to 172.26.39.1 address, then use it's LTE radio to connect to the address since it's all on AT&T's network anyway. Probably a static route on the LTE radio? No idea.

    Since it was clear that pfSense wasn't resolving this address correctly, I decided to put a "Host Over Ride" in the Services: DNS Forwarder. I added this:

    Code:
    proxy 	 mobile.att.net 	 172.26.39.1 	 AT&T MMS Proxy
    Once I did that, everything worked as expected. She can send and receive MMS. It was amazing. I've been struggling with this for a week, and now it's working. That also means I can go buy _me_ the same phone

    I really hope that my struggles can help someone in the future.
    10-03-2013 07:19 PM
  20. Jensen's Avatar
    Nice sleuthing.

    This seems to be the crux of my issue as well. proxy.mobile.att.net resolves on my wifi network but all the requests time out. I'm not using pfsense or any firewall really so I'm not sure how to go about correcting this in my Netgear WNDR3700 router. I'll keep looking though.
    10-04-2013 07:35 AM
  21. jolt_man's Avatar
    Nice sleuthing.

    This seems to be the crux of my issue as well. proxy.mobile.att.net resolves on my wifi network but all the requests time out. I'm not using pfsense or any firewall really so I'm not sure how to go about correcting this in my Netgear WNDR3700 router. I'll keep looking though.
    My issue was that when I was connected behind my pfSense router and ran the ping, it wouldn't resolve at all. Once I tried the address from my work machine, proxy.mobile.att.net would resolve (172.26.39.1) but remain un-pingable. This is to be expected as the address is in a private address range that is unroutable across a public network.

    If you're on your home network and your phone can ping and resolve but get no responses from the address above, then maybe you have a different problem. Try pinging the other addresses in your MMS APNs. Are you still using DD-WRT or are you using your ASUS router?

    Sent from my Galaxy Nexus using Tapatalk 2
    10-04-2013 08:52 AM
  22. Jensen's Avatar
    My issue was that when I was connected behind my pfSense router and ran the ping, it wouldn't resolve at all. Once I tried the address from my work machine, proxy.mobile.att.net would resolve (172.26.39.1) but remain un-pingable. This is to be expected as the address is in a private address range that is unroutable across a public network.

    If you're on your home network and your phone can ping and resolve but get no responses from the address above, then maybe you have a different problem. Try pinging the other addresses in your MMS APNs. Are you still using DD-WRT or are you using your ASUS router?

    Sent from my Galaxy Nexus using Tapatalk 2
    What Android app are you using to ping from the phone with?

    I haven't tried from my phone yet. From my PC on my home network and my PC on my work network they both can resolve proxy.mobile.att.net to 172.26.39.1 without issue. However, neither receives any ping responses back.

    Not using DD-WRT... The Netgear router is running stock firmware at home.
    10-04-2013 09:49 AM
  23. jolt_man's Avatar
    You won't receive a ping reply from that address on your computer. The public internet cannot route those private internet addresses.

    The app I use on the phone is called Android Terminal Emulator.

    If your computer can successfully resolve that address then your phone on the same network via WiFi will most likely be able to resolve it as well.

    Sent from my Galaxy Nexus using Tapatalk 2
    10-04-2013 09:55 AM
  24. Jensen's Avatar
    You won't receive a ping reply from that address on your computer. The public internet cannot route those private internet addresses.

    The app I use on the phone is called Android Terminal Emulator.

    If your computer can successfully resolve that address then your phone on the same network via WiFi will most likely be able to resolve it as well.

    Sent from my Galaxy Nexus using Tapatalk 2
    OK, well I downloaded a PING app from the play store to my GS4 GPe and ran a few tests. The 172 IP resolves just fine on WiFi on the phone - just as it does on my PCs. It doesn't respond to pings, obviously.

    On LTE, however, the phone resolves proxy.mobile.att.net to a different (internal) IP this time (192.168.something) and it also responds to the ping requests just fine. So obviously ATT is expecting all MMS messages to go over the cellular radio and not WiFi.

    My theory is that this is a bug in stock Android. I think Android is setup to try and send MMS over WiFi first and then fall back to the cell radio. That fallback code is failing though and not firing up the LTE radio as it should - so eventually the MMS just times out. This is also an issue with Nexus 4's as well - again stock Android.

    I'm curious why it works for some people though... notably you and Planoman.

    Could you post your APN?
    10-04-2013 11:02 AM
  25. jolt_man's Avatar
    This is the link I've followed for the APNs specifically for my wife's GS4 GE. It seems to work for her.

    I'm not sure what is causing the issue for you. My issue was that I couldn't even resolve proxy.mobile.att.net. I think that what's happening is that because there is no route to the host over the WiFi, the query falls back to LTE. Then it sees a new address and resolves. Not sure why it's setup like that. I can't believe we're the only 2 people in the country to run into this issue. Take a look at the APN link I sent. Try to ping the IPs from within your WiFi network. I'd be curious what's going on.

    You're having the MMS issue with the stock Netgear and DD-WRT? What about the Asus?
    10-04-2013 03:12 PM
31 12

Similar Threads

  1. Samsung Galaxy S4 Stolen - wipe out
    By Giu Rcchia in forum Samsung Galaxy S4
    Replies: 5
    Last Post: 12-15-2013, 04:42 AM
  2. Updated tablet to 4.3, now external keyboard doesn't work HELP
    By Lauranar in forum Google Nexus 7 Tablet (2012)
    Replies: 12
    Last Post: 09-30-2013, 12:30 AM
  3. Opinions on when to charge the phone
    By skatergirl in forum Motorola Droid MAXX
    Replies: 14
    Last Post: 09-11-2013, 12:35 PM
  4. Bluetooth keboard connection problems
    By Eric Samayoa in forum Samsung Galaxy Note 8.0 Tablet
    Replies: 1
    Last Post: 09-10-2013, 03:58 AM
  5. usb connection installer mode
    By geoffropuff in forum Samsung Galaxy S4
    Replies: 2
    Last Post: 09-09-2013, 05:12 PM
LINK TO POST COPIED TO CLIPBOARD