1. iceb3rg's Avatar
    After going to the diagnostic menu (*#0*#) and going to "sensors", I found that my new s4 doesn't have a working magnetic sensor and gyroscope sensor. I can't even do the selftests on any of the sensors. No compass applications work on my phone. I tried calibrating it with the GPS Status and Toolbox app, but that didn't work. The CPU-Z application also doesn't show a mangetometer sensor, only an accelerometer, proximity sensor, and a light sensor.

    Please help.
    04-26-2014 09:36 PM
  2. mobilecrackers's Avatar
    go to recovery and clear cache then data .
    if the problem still exist then reflash with odin
    do not downgrade your phone
    Dave Sssss likes this.
    05-02-2014 01:19 PM
  3. AlecClaire's Avatar

    I've got identical problem as in this topic for this other Samsung's phone where the user deleted config file for device's magnetometer guess S4 has a different sensor's vendor, so my question is what file should be deleted?

    At present, I'm not in possession of S4, so I anyone would be so kind and check it on their rooted device that would be nice.

    1. Doest it still work when the phone is:

    - touched with a little magnet like in a standard vertical flip-case (with little magnet) or
    - travelling by car/bus/train or
    - plugged in headphones

    In the one I had (I don't have it any more) while plugging in headphones, or travelling by car/bus/train, or putting it in an flip-case with a little magnet the arrow In Google Maps pointing the direction which a device is currently facing simply freezes. Compass app also freezes at the same time. The app called Android Sensor Box in the scale for magnetometer reaches its maximum level. While moving the little magnet, from mentioned before filp-case, around a phone the arrow travels with it. Move it away and it freezes. It simply won't move. While sticking S4 to the metal part of laptop table the arrow immediately points opposite direction. Only making 8s in the air helps but only for a bit. Neither S3 9305 nor S5 have this problem. Even when stuck with a magnet their arrows in GM works just fine.

    2. Does deleting the file fixes the GM's arrow issue also permanently even when a phone is in the flip-case with a little magnet?
    08-26-2014 07:52 PM
  4. Joao Lucas1's Avatar
    I have the same problem, the magnetic sensor always show a value of 1500uT, when I move a magnet closer it gets a bit higher or lower depending on the polarity of the magnet, which sucks because my compass doesn't work, is there any fix for this?
    10-03-2014 10:09 AM
  5. Usama Abrar's Avatar
    If you have problems with your Samsung Galaxy S4 and that the smartphone isn't working properly, a good solution to this is to wipe the system cache of the phone. You don't even need to do a hard reset. In fact, doing a system cache will NOT delete any of your personal info, but only the background and application cache. Cache is stored data on the phone which allows apps to load quicker, it's like the data is on standby until you need it again. Wiping it simply means that the app will have to reload the data.

    Here's how it's done:

    Turn off phone
    Remove the battery and reinsert.
    Hold down the Home and Volume Up keys
    Press and hold the Power button while still holding the other keys.
    As soon as you see the Samsung logo, release all keys/buttons.
    Press on the Volume Down to scroll down to Wipe Cache Partition.
    Press the Power button to select it.
    Press the Volume down button to highlight "Yes" and press the Power Button to select it.
    Wait for a few minutes for the phone to clear the data.
    Then press the Power button to select reboot system now.
    Wait for your phone to reboot.
    Vicky01 likes this.
    04-06-2015 12:34 PM
  6. kian19's Avatar
    Hi all,

    First post on here. I've got the exact same issue as the original post. My compass doesn't work. I tried calibrating. I went into the diagnostic menu and I saw that the magnetic sensor value is 3 and all other values are 0. I also tried clearing the cache partition by following the instructions on this discussion. I really hope the sensor isn't broken.

    Any thoughts on other causes and how I may fix it?
    07-22-2015 06:04 PM
  7. Alexa Jovicic's Avatar
    Same here dont tell me i have to buy a new sensor

    Posted via the Android Central App
    12-24-2015 08:50 AM
  8. Vicky01's Avatar
    Great. . Thanks it worked
    01-05-2016 11:00 PM
  9. hlsathaven's Avatar

    Thanks for the info re emptying the cache on a Galaxy S4; it solved my problem of the compass not working on any of the apps which used the magnetometer. Your instructions were very precise.

    I've had this problem of the compass not working a couple of times recently - the last time I managed to get it working again, but I don't know how!!

    Incidentally, is there a good help reference on accessing all the system root(?) settings, including the one you described? Obviously, messing around with these settings unless you know what you are doing is potentially dangerous!!

    Thanks again for your help.

    04-04-2016 08:42 PM
  10. Faried Nurachman's Avatar
    still not working on my J5 Prime
    03-11-2017 07:47 PM

Similar Threads

  1. camera button is not pressable!
    By preppystud in forum Google Nexus 7 Tablet (2013)
    Replies: 2
    Last Post: 05-03-2014, 10:47 PM
  2. Samsung Galaxy S3 Screen Not Working
    By JimCav in forum Samsung Galaxy S3
    Replies: 3
    Last Post: 04-27-2014, 03:22 AM
  3. Not recieving messages
    By Killfer8 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 04-26-2014, 07:51 PM
  4. Replies: 0
    Last Post: 04-26-2014, 07:01 PM