1. theragtopman's Avatar
    Hello,

    I just purchased a new to me/refurbished Galaxy S4 GPE and upgraded it to Android 5.0 right out of the box and I'm loving it so far! I have noticed one oddity that I'm wondering if anyone else has noticed or if it's just mine. I'm using my S4 on a T-Mobile pre-paid plan and cellular data is working great, but when I go to Data Usage under the settings, the toggle is showing it's set to off. I can toggle it to on, but when I come right back into the settings again, it's set to off again. And again, cellular data is working just fine! I've been using it around town the past few days and it's been mostly LTE and very reliable. Maybe it's a bug with that settings page? I've been reading the forums and I tried booting into safe mode and also booting into recovery mode to clear the cache, but no help with either of those. Anyone else noticing this on their phone? Any suggestions? Thanks for the great info about the phone on this forum and thanks in advance!

    Brandon
    12-30-2014 09:28 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! How are you toggling mobile data on, since you're clearly not doing it in the Data Usage menu? Are you using a 3rd party toggle widget? Since you have a GPE, I'm assuming your Quick Settings swipedown menu is the same as the Nexus 5's, which doesn't have a mobile data toggle there.
    12-31-2014 02:55 AM
  3. theragtopman's Avatar
    Good Morning and thanks for the reply! I am trying to toggle the cellular data from the stock Android settings under Data Usage. Each time I open that settings control panel, cellular data is toggled off. I can toggle it on and the screen changes to show the limits I have set, but as soon as I close that panel and come back in, it's toggled off again. I've also noticed it's showing off from the notification shade when pressing on the cellular strength icon. I've attached a couple screenshots, if that helps.

    Cellular Data Toggle Not Staying On-screenshot_2015-01-01-09-32-18w.jpgCellular Data Toggle Not Staying On-screenshot_2015-01-01-09-32-39w.jpg
    01-01-2015 12:38 PM
  4. B. Diddy's Avatar
    I might be misunderstanding. You said that cellular data is working just fine--does that mean that regardless of the cellular data toggle position, you're still getting access to the web? Or does it get access briefly when the toggle is on, only to lose it when it automatically toggles back off?
    01-02-2015 01:47 AM
  5. theragtopman's Avatar
    Problem solved! I had some time yesterday and just decided to do a factory reset. The cellular data toggle switch is staying on now! And yes, even though the toggle showed off previously, the phone was working over cellular data just fine. And now the toggle switch works too. I'm surprised as it was a freshly refurbished phone and had never been used/logged into previously, so I thought all the OS files would be good. I did have to apply several Android updates from 4.2 all the way up to 5.0, so maybe a file got corrupted on one of the updates.

    All is good now and I really love the phone! I actually "downgraded" from a T-Mobile Galaxy S5. The screen sizes are nearly identical, but the S4 feel so much more svelte and lighter in the hand. Plus, I don't have to tolerate all the TouchWiz bloat and slowness! I really like the look of Android 5 and the OS is so much quicker. Thanks again!
    B. Diddy likes this.
    01-03-2015 11:01 AM

Similar Threads

  1. Why does it take 25 minutes to wipe cache partition on my phone?
    By angryshadowdrummer in forum Motorola Droid Turbo
    Replies: 15
    Last Post: 01-27-2017, 07:21 AM
  2. Anyone else have WeMo installed on their Droid Turbo?
    By Moo Cow in forum Motorola Droid Turbo
    Replies: 1
    Last Post: 03-31-2015, 09:42 AM
  3. Replies: 4
    Last Post: 01-09-2015, 01:49 AM
  4. Replies: 4
    Last Post: 12-31-2014, 02:14 PM
  5. Replies: 4
    Last Post: 12-31-2014, 06:37 AM
LINK TO POST COPIED TO CLIPBOARD