1. AC Question's Avatar
    I have a Galaxy S4 Mini with Verizon and Comcast as my ISP. When I try to manually sync, I may or may not be successful, but as soon as I drive out of range of my router (Netgear R6100) the Hangout and Gmail notifications start pouring in. I have found some forum posts that say to disable the IPv6 on my router and/or phone. I have tried this on the router with no love, but cannot find how to turn it off on the phone. I find it odd that after turning off the IPv6 on the router, my phone still shows an IPv6 address in the phone status. I am missing messages and audio/video chats through my phone, but they come through just fine on my PC.

    I would appreciate any help in resolving this.
    01-15-2016 11:33 AM
  2. srkmagnus's Avatar
    Have you tried rebooting the router after disabling IPv6? You can do this by unplugging the router for a minute then plugging it back in. Hopefully that helps.
    01-15-2016 11:47 AM
  3. gwinter6's Avatar
    Yes, I had IPv6 disabled on my router for a few weeks, including over the course of a firmware update and reboot. I have just disabled it again and rebooted my router manually. I also restarted my phone to make sure that it reconnected through the recently booted router. I still have an IPv6 address on my phone, so where is that being generated? If I read the forums correctly, the IPv6 address is not maintaining the connection in Android through no fault of the operating system but the carrier/ISP. Unfortunately, there are too many parties involved and opportunities for finger pointing.

    It may take a while to confirm that the notifications are not being received correctly. Any other ideas if this doesn't work?
    01-15-2016 07:50 PM
  4. gwinter6's Avatar
    I contacted Comcast to get some assistance with this problem, since it only occurs on my phone at home and not my PCs. After exhausting all troubleshooting with first level support, it was referred to level 2. However, I have not been contacted by anyone there yet.

    I believe I have found the solution to my problem, however. I noticed that my cable modem was set up to enable DHCP and was configured for IPv6 Only Mode. I still do not know whether this means that it was assigning only IPv6 addresses, or what. With that in mind, I changed the IPv6 configuration in my Netgear R6100 router so that it was Internet Connection Type = AutoDetect and IP Address Assignment = AutoConfig. I immediately received a WAN IPv6 address for the router when I did this.

    The other thing I did was to use test-ipv6 on my PC, and Push Notification Tester on my phone. My PC was not getting an IPv6 address, even though I could see one when I ran IPCONFIG. When connected to my WIFI, I never received the pushed notifications, but as soon as I disconnected from WIFI they came through as mobile data. After making the changes to my router, the PC tests through IPv6 test were successful, and my phone received notifications through Push Notification Tester just fine.

    As I type this, I am getting notifications on my phone, so it appears to be working as expected. I still want to understand the interaction between my modem and router better, and hope that Comcast will contact me and answer those questions. I was very close to renting their modem and router to put them on the hook to resolve this issue, but it looks like I have avoided that.

    If this solution did not solve the problem, I'll be back...
    01-22-2016 10:33 AM

Similar Threads

  1. Why are my emails coming to my phone?
    By AC Question in forum General Help and How To
    Replies: 2
    Last Post: 01-15-2016, 12:28 PM
  2. Why does my LG G4 beat have no space for apps?
    By AC Question in forum LG G4
    Replies: 2
    Last Post: 01-15-2016, 12:15 PM
  3. Replies: 0
    Last Post: 01-15-2016, 11:06 AM
  4. Replies: 0
    Last Post: 01-15-2016, 10:51 AM
  5. Why when I try to download uber app it stops at 94%?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 01-15-2016, 09:41 AM
LINK TO POST COPIED TO CLIPBOARD