1. AC Question's Avatar
    My s4mini had some problems reinstalling Facebook so i deleted the newest version of Google Play Store. Now it won't install, download or update any app (tried several).
    The 'build option' mode for manually updating the Play Store doesn't work and i even tried some ('official') APK's but those files won't install either (yup, had the safety function 'not downloading from not official places' off)
    I'm also trying to update the Samsung Store, but that one isn't installing as well.

    Does anyone know how I can get my phone to install apps again?
    I already tried the clear cache, wipe memory, reboot phone options and my wifi is working.

    Thanks for your help.
    01-17-2016 04:34 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Does this happen on both wi-fi and mobile data?

    Try going to the App Manager, select Google Play Store, and Clear Cache/Clear Data, then Force Stop. Do the same for Download Manager. Now try again.

    If that doesn't work, try going to Settings>Accounts-Google, select your Google account, and remove it completely from the phone. Then add it back again, and see if that helps.
    01-17-2016 10:23 PM
  3. Mirrorriver's Avatar
    The first option didn't work for me unfortunately, the download for google play services got stuck (again) at 55% and kept 'downloading nothing'. Same with Facebook on 95%.
    Sometimes, after a couple of minutes, it sais 'installing' out of the blue, but than it keeps 'installing' for hours until it stops without saying anything, no errors or anything.

    My gmail-account actually said that there was a synchronisation problem, so after logging out and in again I manually let it synchronize.
    At least my account is synchronized again, but I still can't download or update anything...

    Tried to download it on mobile data once, but same problems occured

    So still nothing solved
    01-18-2016 05:34 AM
  4. Mirrorriver's Avatar
    Okay, I think one of those options DID work, but just after a while. Had given all hopes up, so I was preparing my phone for a reinstall, when suddenly my Play Services and other apps were updating again. And when I checked, Google Play Store was up to date again!

    Thanks so much!

    Edit: Or not. It uploaded several apps, but after about half an hour it stopped working again. I really don't know what to do anymore.
    01-18-2016 06:27 AM
  5. virtualtechie18's Avatar
    Just try to reset your phone bro.
    01-18-2016 07:08 AM
  6. Mirrorriver's Avatar
    No didn't want to lose everything. Found the problem though, my SD card was blocking it or something? I can download everything if my SD card is not in my phone or just not connected. Have no idea why but it works.
    B. Diddy likes this.
    01-18-2016 07:28 AM
  7. B. Diddy's Avatar
    That probably means your SD card is corrupt. Unmount the card (in Settings>Storage), remove it, and insert it into your computer. Run chkdsk to look for bad sectors: http://forums.androidcentral.com/amb...d-sd-card.html.

    Also check to see if the card is counterfeit, using SD Insight.

    Certain apps will automatically install some data to the SD card during the installation process, so if the card is faulty or counterfeit, that might cause it to hang up. You may have to use a different card.
    Laura Knotek likes this.
    01-18-2016 12:24 PM

Similar Threads

  1. Lenovo A588t Android phone with hardware keyboard, can I get some help?
    By AC Question in forum General Help and How To
    Replies: 2
    Last Post: 06-23-2016, 08:10 AM
  2. [App][2.1+] Spidey's Piano Tiles
    By Vexomg in forum Android Apps
    Replies: 3
    Last Post: 01-22-2016, 11:57 AM
  3. How do I upoad pictures from my Galaxy 6S to my HP laptop?
    By AC Question in forum Samsung Galaxy S6
    Replies: 5
    Last Post: 01-18-2016, 10:38 AM
  4. Replies: 1
    Last Post: 01-17-2016, 10:24 PM
  5. Replies: 1
    Last Post: 01-17-2016, 04:50 PM
LINK TO POST COPIED TO CLIPBOARD