1. apel69's Avatar
    Looks like I got myself in a pickle. I have a R970 GS4 on US Cellular running 4.2.2. I picked up my phone today and successfully rooted it with the following method [http://droidviews.com/2013/how-to-ro...y-s4-sch-r970/]. I then installed CWM recovery with ROM Manager and backed up my ROM with it. I decided to replace chainfires SU with the one fom CWM like I had on my S3. After rebooting from recovery mode I noticed I had lost root so I used the same method to root it again. On reboot the error Firmware upgrade encountered an issue along with a cone and a couple of other pics. Before the reboot occurred there was option to prevent the possibility of the ROM flashing itself to stock. I went to select the Yes option but bumped the power button which selected No.

    I have tried to get into recovery mode several times but repeatedly get this error. I can get into download mode and have tried to flash the stock ROM for this phone but it fails in Odin 3.0.7. Odin sees my phone and verifies the md5 but fails very quickly upon clicking start. I tried this with KiesPDLR running in the background and disabled. I have not tried anything else out of concern for messing it up further.

    Attached are screenshots and log from ODIN along with the text that is being displayed in download mode. (I will have to post these later as the attachments option will not work properly on my wife's S3).
    ghalib ghanem likes this.
    08-13-2013 03:07 AM
  2. arav24's Avatar
    Try to flash a different stock ROM. It happened to me once and it fixed it. Let me know if it worked

    Sent from my GT-I9300 using Tapatalk 4
    ghalib ghanem likes this.
    08-13-2013 05:27 AM
  3. apel69's Avatar
    Can you be real specific or even point me to a file as I am a bit nervous about messing this up further? Do you mean another Android version like 4.1.2 or something completely different like CM 10? I have ROM backups of both of these from my old S3. I have stock and rooted versions of 4.1.2 that I have successfully used before.
    08-13-2013 09:32 AM
  4. apel69's Avatar
    Attachments have been uploaded as mentioned from my first post.

    Two other things I forgot to mention. The first is a message that appeared on the phone when I tried to reroot the phone and failed. It read "Invalid percent of drawing download progress bar." It never did anything after a long while so I reluctantly disconnected the phone and tried to restart the phone.

    The second is that I used ODIN 1.85 to root as that was what was included in the chainfire download. But I used ODIN 3.0.7 to try and unroot because that's what the DroidView directions said. Would it make any difference to use ODIN 1.85 to try and flash the stock firmware? It sees my phone as well but the F. Reset Time option is unchecked and grayed out and the directions says it needs to be checked. Don't know if that really makes a difference.
    Attached Thumbnails Firmware upgrade encountered an issue-screenhunter_01-aug.-13-00.38.jpg   Firmware upgrade encountered an issue-screenhunter_02-aug.-13-00.39.jpg   Firmware upgrade encountered an issue-screenhunter_03-aug.-13-00.39.jpg  
    Attached Files
    08-13-2013 10:11 AM
  5. arav24's Avatar
    Head over to sammobile.com and go into the the firmware section and then find your device and then download any stock samsung 4.2.2 build ( get the most recent build as possible) and then flash it via Odin and you are good to go

    Sent from my GT-I9300 using Tapatalk 4
    08-14-2013 01:41 AM
  6. apel69's Avatar
    I am back in business. I have my phone and home internet back now. Yeah. I used the same stock ROM I had since it was the same as sammobile and I already had it on my system. I just used Odin 1.85 instead. I guess I could have done this earlier and prevented a near stoke but everything else I had done seemed to get me deeper in a hole. So two follow up questions. Why would it flash with Odin 1.85 and not with 3.0.7? Is CWM's SU not compatible with the S4? Everything was working fine until I switched this from chainfire to CWM using ROM Manager.
    08-14-2013 02:31 PM
  7. Android_S4's Avatar
    download the stock firmware at samfirmware.com and flash it. I had the same issue on mine, and thats how I fixed it
    08-19-2013 08:10 AM
  8. Android_S4's Avatar
    Oh you fixed it already. It wouldnt flash via Odin 3.07 probably cuz the firmware you had is older than the Odin version... I downloaded a firmware released in july 23rd and it wouldnt flash via Odin 1.85, as I tried with odin 3.07 it flashed like there would be no tomorrow, quick and smooth.
    08-19-2013 08:14 AM
  9. strateg's Avatar
    hi i have same problem but i have Samsung Galaxy S4 GT-i9500 which firmware i need to download and which odin ?
    09-04-2013 08:18 AM
  10. strateg's Avatar
    are into this link firmware if it is which i need to download Samsung Updates Latest Firmware - LIVE! ?
    09-04-2013 08:24 AM
  11. apel69's Avatar
    I would go to either sammobile.com or samsung-updates.com and download the version that matches your model and country of the phone. It's imperative to get the firmware that matches your phone or else things could go wrong. I would use odin 1.85 since the newer version failed for me. Whatever you do follow the flashing directions to the letter.
    09-04-2013 08:51 AM
  12. strateg's Avatar
    how can i setup firmware with android 4.2.3 ?
    09-05-2013 04:21 PM
  13. apel69's Avatar
    Sorry I haven't got back sooner. I've been a bit indisposed. I don't know where you are currently at but I would only flash official updates from either of the sites previously mentioned and make sure it matches your phone identically. If you try and flash a firmware that is not compatible with your phone, different carrier or country, you run a higher risk of bricking it (turning it into a paperweight). The only way to fix it then is to send it out for JTAG repair. I know others flash pre-releases and leaked versions but I am Mr Cautious and don't want to take the risk. I have read that 4.3 is coming out in October or November so keep that in mind.

    To flash stock firmware you can follow these instructions to unroot a phone and restore the stock firmware.

    You can follow these instructions if you choose to root your phone again. The root package is by chainfire who definitely knows what he is doing. You will also want to install a custom recovery in case you need/want to restore a nandroid backup. The two options for this are CWM or TWRP. I use CWM but it really is a personal preference. Download links are included in the instructions. Chainfire has his own thread to rooting your model if you want to check it out.

    Other useful notes:
    1) If your new to this read all instructions at least twice before proceeding and follow them to the letter.
    2) Use Odin 1.85 for rooting and unrooting. I've tried newer versions and they haven't always worked but 1.85 always has.
    3) Don't change out chainfires superuser with another one because that is what got me in my mess to begin with. I was used to another one that I installed on my old S3 but on my S4 it ended in failure. I recently replaced the superuser on my old i500 to chainfires because the apps and the phone would periodically freeze along with other weirdness. Flashed the superuser zip and all is right with the world. Now the kids can play their games and not pester me because it keeps locking up.
    4) Samsung is releasing new firmwares that have a bootloader that will not let you go back to a previous firmware. If that is important to you keep that in mind before installing OTA updates or flashing the latest release.
    5) Google is your friend. A lot of how-to's and resolved issues can be found by doing a simple search. The more you read the more you understand.
    09-09-2013 03:34 PM
  14. chardan06's Avatar
    Good morning, I am with T-Mobile on a SGS 4 M919 I rooted , installed clockwork Mod, then copied a zip of cmod 10.2 nightly onto my ext sd and then booted into recovery, wiped all my data after saving my setup, hit install zip from ext sd card and let it do its thing, then rebooted system and have had cmod 10.2 working great on my phone, I now am running the 9/10/2013 nightly of 10.2 with very few small problems. If you can get into recovery mode you should be able to do the above after wiping your system. Try clearing your cache prior to installing anything. I am totally new to this so have encountered lots of trial and error, read, read and read the forums pertaining to your phone and make a hard copy of the instructions prior to jumping in.
    09-11-2013 08:27 AM

Similar Threads

  1. Moving to external sd issue.
    By Di S in forum Samsung Galaxy Tab 2 10.1
    Replies: 2
    Last Post: 08-14-2013, 12:15 AM
  2. google play music app issue (read please)
    By Jeremy_Collinsworth in forum Samsung Galaxy S3
    Replies: 2
    Last Post: 08-13-2013, 07:36 PM
  3. "Please insert an SD card"... Help?
    By Alex Toole in forum General Help and How To
    Replies: 3
    Last Post: 08-13-2013, 11:27 AM
  4. Wallpaper issues, anyone experiencing this?
    By dt81 in forum Google Nexus 7 Tablet (2013)
    Replies: 1
    Last Post: 08-12-2013, 09:59 PM
LINK TO POST COPIED TO CLIPBOARD