1. steevaavoo's Avatar
    Just in case anyone might find this useful, I've put together the instructions I found whilst trying to do this.

    Finally I can take photos without accidentally bringing up the Menu or closing the Camera App!

    First time I've ever posted here, so be kind!

    This works in CM11 M6 on Samsung Galaxy S4 (jflte) i9505 - I have not tested with other versions or on other devices.

    Make copies of the files you will modify prior to doing this. I'm not responsible for any bricking or faults!

    Give File Manager Root Access.

    Open the File Manager App, then tap the Menu button (capacitative or onscreen), and tap Settings.

    Go to General Settings, scroll down to and tap Access Mode

    Switch to either "Prompt User Mode" or "Root Access Mode"


    To add Soft Keys:

    Open the build.prop file in ./system/

    Add the following line to the end:


    Close, saving changes

    To disable Capacitative Keys:

    Open the sec_touchkey.kl file in ./system/usr/keylayout/

    Put a # symbol before the both the following lines:

    key 139 MENU VIRTUAL
    key 158 BACK VIRTUAL

    Close, saving changes

    To turn off the Capacitative Key lights:

    Go to Settings, Buttons, Backlight

    Remove the tick from "Illuminate Buttons"

    Reboot and enjoy!
    bernatman and Pops alot like this.
    05-14-2014 09:14 AM
  2. Golfdriver97's Avatar
    Welcome to the forums.
    Nice write up.
    05-14-2014 09:30 AM
  3. steevaavoo's Avatar
    Hi there

    Thanks very much - I hope it proves useful :-)
    05-14-2014 12:16 PM
  4. bernatman's Avatar
    I always searched for this and never found A working Tutorial.
    Until you wrote this beautiful instruction.
    Thanks A Lot!! I it works like a charm!!
    Proved to be working with GT-S7560M / Galaxy Ace II x / Koodo
    03-09-2015 11:43 PM
  5. Ck_asdf's Avatar
    I've got a Verizon Galaxy S4 on rooted Hyperdrive ROM RLS20 (4.4.2). I tried adding the mainkeys line, but after restarting, every couple seconds, it complained the UI had closed. Removing the line and rebooting caused the errors to cease.

    I had tried out a ROM called KitPop, which had working soft keys, but it didn't work for some other things I needed. Suggestions on what to do, to enable the soft keys?
    03-19-2015 01:36 AM
  6. impaul007's Avatar
    This method is not working on Lenovo Vibe X3 (X3a40). Can you help please?
    06-07-2016 01:32 AM
  7. chrisody's Avatar
    if this doesn't work for you,
    try this one :
    same thing do this at the end of your build prop.


    (without the quotes)
    save changes, before you close.
    to disable, just type "no" in stead of yes.
    (without the quotes, again.)

    hope it works.

    or try this :
    install as apk. this will enable and disable your virtual keys, no build prop editing, this app will do it for you. always reboot after each time you use this app.
    hope that helps.
    07-13-2016 12:12 AM
  8. Kishore 4110's Avatar
    I have lenova 6000+ rooted to miui 8 and all were running smooth but I installed ultimate nav bar app and from it my power and volume down button not working.It works for switch on the phone but when phone power ons it does not work at all pls help
    11-24-2016 07:28 AM

Similar Threads

  1. Blue screens and shutdown after flashing a ROM
    By elmismodesi in forum Sony Xperia TL
    Replies: 1
    Last Post: 06-29-2014, 06:19 PM
  2. Camera problem since upgrading to 4.3
    By Gareth Jones2 in forum Legacy Android & Other OS's
    Replies: 0
    Last Post: 05-14-2014, 08:42 AM
  3. google and youtube
    By daddyd302 in forum HTC One M8
    Replies: 0
    Last Post: 05-14-2014, 06:11 AM