1. joey8787's Avatar
    I'm having problems rooting my Samsung Galaxy S4. I tried virtually every method kingo root, framaroot even old root versions like z4root.i tried motochopper and towel root nothing works. towel root said phone not supported. I'm running Android OS 4.4.2. My phone was originally with. verizon and had my phone unlocked now I use t-mobile's network please help Thank You

    Posted via the Android Central App
    12-15-2014 11:13 AM
  2. mike_mck2's Avatar
    Google "root galaxy s4 running 4.4.4".

    I used Odin to flash an earlier kernel, rooted with towelroot, then flashed the original kernel back to the phone. Worked like a charm.
    12-17-2014 04:58 PM

Similar Threads

  1. video player problems
    By Spinz Logo in forum Samsung Galaxy Tab 3
    Replies: 3
    Last Post: 02-16-2015, 04:46 PM
  2. Replies: 12
    Last Post: 12-16-2014, 01:04 PM
  3. Replies: 3
    Last Post: 12-15-2014, 12:54 PM
  4. Galaxy S3 Stuck on Samsung logo after factory reset.
    By Saqib Saleem in forum Ask a Question
    Replies: 0
    Last Post: 12-15-2014, 09:09 AM
  5. Why do my apps only work on wifi? Samsung S5
    By Lsand in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 12-15-2014, 08:29 AM
LINK TO POST COPIED TO CLIPBOARD