1. VeryHappySlug's Avatar
    Hi all,
    I've kind of backed myself into a corner here after a bit of "experimenting"

    I just purchased an S4 SGH-M919, came with stock 4.2.2 Jellybean.

    - Opened it up and rooted it via auto-root + Odin.
    No issues.

    Then instead of manually flashing a rom, I downloaded a play store app called 'Recovery Tools', and tried to flash TWRP onto the phone.
    -Stuck at Samsung screen with blue 'booting recovery...' forever.

    I then (stupidly?) tried to flash 4.4.2 onto the phone. *not sure if this is stupid because I read T-Mobile has an unlocked bootloader?

    So flashing 4.4 T-Mobile Galaxy S4 Stock Firmware (4.4.2 - M919UVUFNB4) PASSES with odin, but the phone is still 'messed up'.

    I can access recovery mode, but the phone will not boot past the 'Samsung' logo, and even after a factory data reset and deleting users.

    I've also tried flashing back to 4.2.2, and odin fails.

    Please help I can't afford another device and I'm now phoneless. Not sure where to go from here and could really use some direction..
    03-10-2015 10:20 PM
  2. VeryHappySlug's Avatar
    79 views, any suggestions? :\
    03-11-2015 12:04 AM
  3. Mach1juggalo1978's Avatar
    Leyte me be honest i think you done did ****ed your phone it was unlockable at 4.2.2 after 4.3 its locked Knox you need to do a custom rom and clock work mod you need to do research before you doing something like that i believe its un fixible i just bought that phone was i337 at&t variant have you had any luck ?

    Posted via the Android Central App
    03-13-2015 08:58 AM
  4. Mach1juggalo1978's Avatar
    And where did you purchase it ?

    Posted via the Android Central App
    03-13-2015 08:59 AM
  5. mikea5898's Avatar
    Flash custom recovery. Find a custom rom and flash it because stock won't boot. Plenty of stock rooted roms to choose from.
    06-12-2015 07:41 AM
  6. galahad6's Avatar
    Hi there,
    were you able to fix your galaxy S4 or are you still stuck at the recovery logo?

    regards,

    Victor
    06-28-2015 03:50 PM
  7. myu699's Avatar
    Hey. Download samsung kies and then click tools->update and initialization->fill out info(should be able to find it behind your battery)->boot into download mode->plug it in->run kies and wait. It should update and flash the original firmware. I experience some of the same stuff as you, odin flashing didn't work for me but kies did. I hope it fixes it for you. WARNING! doing the above will delete all your data.

    PS.
    if you are having trouble booting into download mode(you can find the button combination online) you can buy a usb jig that will force your phone into download mode.
    07-02-2016 02:18 AM
  8. Aenergy's Avatar
    Anyone has a bad S4 SGH-M919 with good screen? I broke my S4 SGH-M919 screen, but can't afford a replacement now. I can DIY the replacement if I find someone gracious enough to bless me with their bad device with good screen. Thanks
    03-17-2017 01:35 PM

Similar Threads

  1. Replies: 25
    Last Post: 10-20-2016, 01:12 AM
  2. Making a port version of my favorite game, is that legal?
    By tunguitvn in forum General News & Discussion
    Replies: 4
    Last Post: 03-20-2015, 07:48 AM
  3. Replies: 2
    Last Post: 03-20-2015, 06:41 AM
  4. Replies: 1
    Last Post: 03-10-2015, 10:26 PM
  5. Lollipop screwed up my clock/weather widgets
    By PsychDoc in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 03-10-2015, 09:10 PM
LINK TO POST COPIED TO CLIPBOARD