1. RdogMartin's Avatar
    Got my S4 yesterday and it's working well *except* when accessing the wi-fi connection in my home, which works for maybe 10-30 seconds and then can't connect any more, whether it be Chrome, Play Store, or any app that connects to the internet. If I turn off wi-fi and then re-enable it, things work again for another few seconds before locking up again. I went through this disable/enable routine 5 times in order to download the Facebook app. I spent 45 minutes with AT&T yesterday and tried various things, but without success.

    * I went to a cafe with an unsecured wi-fi and it worked fine.
    * My home wi-fi uses WPA-Personal and works fine for other devices. I just tested two laptops, a Nexus 7, and a Windows Phone. The router is a D-Link DIR-655 and has been running flawlessly for a few years.
    * I temporarily disabled security on my wi-fi router and changed a few other settings, but the lockup behavior remains.
    * AT&T had me completely reset the device, but the behavior remains.
    * The phone reports that the wi-fi connection is 'Connected', the signal is 'Very strong', link speed is 65Mbps, and security is WPA/WPA2 PSK
    * If I enable the mobile data option and turn off wi-fi, the internet works fine, but of course I'm eating up mobile data.

    Over the next few days I'll try connecting to a few more wi-fi networks to see what happens, but I wanted to throw up this post to see if anyone had any ideas or were having similar trouble.

    04-26-2013 09:50 AM
  2. oshogg's Avatar
    Is there a Wi-Fi setting that says "Keep connected during sleep" or something similar? If so you can try that. Also you could try disabling 802.11ac (if there is an option for it) or the 5GHz band (if there is an option for it).

    What Wi-Fi options are there in general?

    04-26-2013 09:55 AM
  3. RdogMartin's Avatar
    The option 'Keep Wi-Fi on during sleep' is already set to Always. See attached pic for other options, which are still at their default. My router doesn't offer 802.11ac or 5GHz, so there's nothing to change there.

    Attached Thumbnails Wi-Fi keeps locking up-s4_wi-fi_settings.png  
    04-26-2013 10:21 AM
  4. smooth4lyfe's Avatar
    Try forgetting the network and connecting again
    Also try resetting your router....that should be able to fix it
    04-26-2013 11:29 AM
  5. planoman's Avatar
    Did you restart you router?

    Sent from my Nexus 4
    04-26-2013 12:39 PM
  6. RdogMartin's Avatar
    I have "forgotten" my connection more than a dozen times, which is what I was doing until I learned that disabling/enabling the wi-fi could also temporarily get things working again. And I've cycled the power on my router *and* cable modem twice, with no change in behavior.
    04-26-2013 12:44 PM
  7. oshogg's Avatar
    I have "forgotten" my connection more than a dozen times, which is what I was doing until I learned that disabling/enabling the wi-fi could also temporarily get things working again. And I've cycled the power on my router *and* cable modem twice, with no change in behavior.
    I presume you already have the latest firmware for your router? If not, that would be the first thing to try.

    Next, configure your router in different modes 802.11b/g only or 802.11n only. And see if that changes anything.

    04-26-2013 02:03 PM
  8. Wilbur's Avatar
    Have you tried rebooting the phone? I'd even go so far as removing the battery for a minute or more letting all memory data drain and then starting the phone up again. Just a thought for trouble shooting the problem.
    04-26-2013 02:14 PM
  9. RdogMartin's Avatar
    Osho - I think I figured it out. I had previously tried setting 802.11n only and 802.11g/802.11n in addition to the default b/g/n. Nothing changed but based on your suggestion I decided to try every possible option. When I got to 802.11g only, things started working! I've spent about 15 minutes accessing the wi-fi without a single glitch, so things are looking good.

    I may need a new router long term if restricting it to 802.11g only has side effects, but at least I'm working today.

    Thanks Osho!
    04-26-2013 02:55 PM
  10. Nedla's Avatar
    I also have the same router and also had the same problem thanks for the Info guys, Glad to leave apple for the S4,
    04-27-2013 03:38 AM
  11. jwn66's Avatar
    Same exact thing happened to my Playbook, had to set it to just g, but last night I upgraded internet and got a new router and can safely leave it on all settings and not just g now. Them older routers don't like to play nice sometimes with newer tech. Good thing, will be getting s4 soon so pretty sure it won't have problems now, positive I would have after seeing this thread lol.
    04-27-2013 03:51 AM
  12. oshogg's Avatar
    I can report another (better imho) work-around. Enable 802.11n but make sure you only use TKIP for security (and not AES). This also works fine and you can get better 802.11n speed.

    05-02-2013 01:58 PM
  13. captain_tinker's Avatar
    Oh man, glad I'm not the only one seeing this! I thought I was going crazy! Both my new S4 and my wife's new S4 are seeing this same issue at home, only. We also have the DLink dir-655. I'm going to try the TKIP thing and see what happens. Other than that, maybe a new AC router? Hate to do that since this router is working pretty well.
    05-03-2013 12:17 AM
  14. Jens Karlsson's Avatar
    I have the exact same problem at home. Also on a DIR-655.

    A new router then, but great that there is a soullution here. Seems quite hard to find any when the phone is as new as it is.

    -- Edit --
    anyone who knows any D-link thats not to expencive that works?
    05-03-2013 05:51 AM
  15. kingb71's Avatar
    I had the same problem with the same router on my current phone that I'm leaving today for an S4. I just switched my router this morning from g only to n/g. Guess I will have to switch it back. Makes no sense to reduce the speed so much though. I was told it is because the version of N that this router uses is "draft" N, not final spec N, which apparently somehow makes a difference.
    05-03-2013 09:06 AM
  16. Alexander Ivanchev's Avatar
    Glad I found this! Same issue:

    Test case:

    1. My DLink router DIR-655 (latest firmware) configured in 802.11n mode only
    2. After about 10 mins of browsing the connection freezes - the AP is still connected but I have no connectivity to the net - can't even ping the AP's IP... - the easiest way to reproduce is to just run speedtest which hangs mid-way.
    3. When I disconnect from the AP and reconnect it works again - until next time it happens...

    Things I know:

    1. Not an issue on my wife's iPhone 4S
    2. When the AP is in 802.11b/g mode it works fine (but much slower)

    So, looks like a definite issue with the S4 (or 4.2.2) and the DIR-655 - did anyone report this to Samsung/Dlink?
    05-13-2013 11:36 AM
  17. Alexander Ivanchev's Avatar
    Mine (Rev. A) doesn't allow me to select TKIP only with 802.11n
    05-13-2013 11:49 AM
  18. jim302's Avatar
    Mine (Rev. A) doesn't allow me to select TKIP only with 802.11n
    TKIP and WEP are unsupported on 802.11n networks. Attempts to use these encryption types, if allowed in the first place, will result in slower speeds (802.11 g and a only). This isn't specific to any specific device. It is part of the 802.11n standards.

    802.11n works with unencrypted or AES encrypted connections.

    Sent from my Nexus 4 using Tapatalk 2
    05-13-2013 01:00 PM
  19. Alexander Ivanchev's Avatar
    Yep, so I guess 'g' it is... It's weird as I have 3 other 'n' devices which work just fine with the same router, but perhaps the S4 is using something in the final standard which isn't supported by the 'draft n' version of the DIR-655. Either that or there's a bug.

    [edit: I contacted both dlink and samsung - will update]
    05-13-2013 02:34 PM
  20. captain_tinker's Avatar
    I wrote down every setting on my router, then went and reset back to factory defaults. I at least put back all my security settings, mac address filtering, etc. Left it on N only, with AES only, and still had the issues. Then went to G only, and so far, no more issues. That is very strange. Its also quite upsetting, because I purchased this router several years ago specifically for N capability! Looking around now for other routers to replace this with, and I'm sorely disappointed by all the extremely poor reviews on every other supposedly "top level" router. I've looked at all the top brands, D-Link, Netgear, Linksys, Cisco, Belkin, and even a few no-name brands like Asus, and each and every one have reviews that say range is poor, or constant dropouts, or have to re-set or re-boot multiple times a day, or gets so hot it fails, or support stinks, etc. I cannot find anything that sounds promising. In fact, the only router I can find on the market right now that has good reviews, is the router I already have! I guess setting to G only isn't a huge deal, since the only computers in the house really affected by it will be my wife's laptop, and my tablet. The internet connection to the outside is slower than 54 mbps, so browsing won't be any different, just file transfers between machines, and she rarely does that on her box, same with my tablet. So I guess I'm staying put for now. Unless anyone has had a good experience with any other router that is not terribly expensive?


    PS: by the way, doesn't the S4 support wireless AC? Anyone tried it on any of the current AC routers?
    05-16-2013 10:50 AM
  21. oshogg's Avatar


    PS: by the way, doesn't the S4 support wireless AC? Anyone tried it on any of the current AC routers?
    Yes. It works great on 802.11ac. I am using Asus rt-ac66u.


    Sent from my SAMSUNG-SGH-I337 using Tapatalk 2
    05-18-2013 10:33 AM
  22. WyodroidGS4's Avatar
    I also have a GS4 for about a week and I have a Belkin N1 Vision that has DRAFT N and I have these random drop outs, the apps will say "unable to connect - RETRY" and sometimes I hit retry and nothing happens I have to turn off wireless and turn back on and it works. I have tried everything everyone has mentioned here and it seems to only happen when I have it set to use N, if I say B and G only then It works fine. I called Samsung to report this problem, I wish they could have legacy support for this but I guess since N is in it's final ratification then they just supported the full N version. I was told by advanced support to try using a static IP/mac/port for my device to connect and see if that works, I haven't had time to test that theory. I had hoped that there was some secret event log on the phone that would show the activity of my WiFi, I have also had a battery drain that I can't explain - but thinking about it I think the battery drain may be related to the fact that my WIFI keeps trying to reconnect and that may be draining my battery I have lost 10% battery overnight with just WIFI and mobile networks on. I don't really want to buy another router because my phone can't communicate on a draft N version, what is weird is I don't think it's every router with DRAFT N it may be certain ones, maybe earlier adopters. I have heard someone say that there phone is working with DRAFT AC, so I ask if it supports DRAFT AC why not DRAFT N? if it supports back to b it should support mine fully. My router hasn't had any firmware updates for awhile so I doubt that I'll be getting a update that will resolve from Belkin and I'm unsure about Samsung if they think it works then they might assume the people having the problems are a few minority. I'm thinking new router, I may static program my phone IP and eliminate DHCP if that is a cause and see how it works I hate to junk my perfectly running router to another router that isn't much faster. If anyone else has any more suggestions I'd like to hear them. Thanks for all the good info it helped me, I thought I was going crazy when my WIFI and battery were draining.
    05-20-2013 06:07 PM

Similar Threads

  1. Why does Wi-fi keep disconnecting/
    By Charmed Juan in forum Verizon Droid Incredible
    Replies: 9
    Last Post: 10-21-2016, 08:41 AM
  2. Driod X keeps locking up
    By Timdog in forum Motorola Droid X
    Replies: 25
    Last Post: 01-16-2012, 04:26 PM
  3. Wi-fi keeps turning itself on
    By haldroidx in forum General Help and How To
    Replies: 2
    Last Post: 06-03-2011, 11:53 AM
  4. Phone keeps locking up
    By SirGeorgeKillian in forum AT&T ATRIX
    Replies: 2
    Last Post: 03-30-2011, 05:35 PM
  5. Wifes phone keeps locking up and working slow.
    By Heath276 in forum Verizon Fascinate
    Replies: 7
    Last Post: 03-23-2011, 12:29 AM