1. netposer's Avatar
    I got my new S4 yesterday but used my existing iPhone 4S SIM. Wasn't getting the "4G LTE" icon.

    Today I activated the micro SIM that shipped with it and ran some speed tests.

    Getting on average 35 to 50 Mbit down and 18 to 20 Mbit up.

    Meanwhile my 15 Mbit down and 1 Mbit up Time Warner cable connection stutters at watching youtube videos.
    04-26-2013 08:12 PM
  2. Podunks's Avatar
    I got my new S4 yesterday but used my existing iPhone 4S SIM. Wasn't getting the "4G LTE" icon.

    Today I activated the micro SIM that shipped with it and ran some speed tests.

    Getting on average 35 to 50 Mbit down and 18 to 20 Mbit up.

    Meanwhile my 15 Mbit down and 1 Mbit up Time Warner cable connection stutters at watching youtube videos.
    May be cheaper to upgrade to 5GB and tether....
    04-26-2013 11:05 PM

Similar Threads

  1. curious what are your 3G speeds and LTE speees?
    By smileshappy in forum Samsung Galaxy S II Skyrocket
    Replies: 4
    Last Post: 02-01-2012, 11:55 AM
  2. Test your Froyo 2.2, Adobe Flash 10.1 and CPU speed
    By rfeineis in forum The Android Central Lounge
    Replies: 1
    Last Post: 09-05-2010, 07:29 PM
  3. Droid and 3G Speeds
    By appmy in forum Motorola Droid
    Replies: 7
    Last Post: 08-03-2010, 08:00 PM
  4. mp3 skips and tempo speeds up for no reason
    By jonathanlc2005 in forum HTC EVO 4G
    Replies: 1
    Last Post: 07-14-2010, 10:50 PM
  5. Adding music and phone speed
    By boddah in forum Motorola Droid
    Replies: 6
    Last Post: 12-31-2009, 02:49 PM
LINK TO POST COPIED TO CLIPBOARD