10-21-2016 09:46 PM
71 123
tools
  1. heavy diaper's Avatar
    I started looking at this thread because my phone has the annoying habit of turning off wifi on its own. When the wifi is turned off, I have to re-enter the password to reconnect to my AT&T U-verse modem/router. The password is ten characters long and all numeric - not something easy to remember, but something not easily broken into. My question, what do I do to keep the phone from turning wifi off. If that can't be, then is there a way to retain the password so I can more easily reconnect? The funny thing is, once I reconnect, it stays for sometimes as much as a day, but sooner or later, I lose the wifi and then I have to go through the whole reconnect routine again.

    Any clues?
    BUMP THIS! Having the same problem and have tried every "fix" I've found on any forum, to no avail. Yes I have tried checking all the right boxes and resetting modem/router, phone, forgetting the Wifi on the phone etc. If this phone doesn't start connecting to the internet (which my 4 year old iPhone 3G could still do quite well) very soon I am going to take it back and get an iPhone. Please don't let me go back to the dark side. I want to love Andriod...I really do....help me fix this!
    10-25-2013 01:36 AM
  2. Ricky Gani's Avatar
    THANK YOU youngchrisg, you saved me XD
    10-27-2013 10:47 AM
  3. Kimberly Taylor's Avatar
    nata_panya, Thank you!!! I have a Samsung Note 3 and I did exactly what you said and it finally worked. My router is a net gear. Everyone thought it had to do with the fact that I had Dish internet but after your fix, you proved them wrong! Thank you, Thank you, Thank you!
    11-06-2013 08:35 AM
  4. tony668567's Avatar
    Shows full power to wifi but shows lock symbol and gives me error message
    12-17-2013 02:28 PM
  5. Seren Esp's Avatar
    Not sure if this will help but I was running kasperski security on my S4. I had been using it for a while but 2 weeks ago I uninstalled it temporarily because my phones proxy settings kept changing from none to manual, preventing me from connecting to the Internet and after some research, I suspected the kasperski software was at fault. I reinstalled it again yesterday to see if it happened again, it didn't, BUT today my S4 wouldn't connect to my wifi because apparently the connection was too slow. After reading this message thread I've uninstalled kasperski again on a hunch and l can now connect again with no problems.
    Check if you've installed any new apps recently that may be affecting your connections.
    12-21-2013 04:17 AM
  6. galfaqih's Avatar
    nata_panya is on the right track.

    I have a Verizon S4 and connected to a new open network. I then got a network unstable message and was asked if I wanted to enable "auto network switch" to which I replied yes. From that point forward I got the same "Network disabled because internet connection is slow" message. I followed nata_panya's advice but had different options, one of which was "auto network switch" which I disabled and all was well again. Thanks nata_panya.
    01-22-2014 09:03 AM
  7. electricplectrum's Avatar
    I just got my Samsung Galaxy S4, and kept getting the "Network disabled because internet connection is slow" or "Failed to obtain IP address" errors. I tried manually entering settings, using WPS with a pin, using WPS with a push button, nothing seemed to work - and all of our other laptops, tablets, and old phones were working just fine on the same wireless network.

    I have a D-Link router. I had to log into the router (from a computer on the network), under the advanced wireless settings I had to disable "Short GI". This may not be the same issue for everyone, but now my phone has been working flawlessly on the WiFi.

    This might be a different setting on different brand routers, but look for something similar - here's what D-Link says it is: "Using a short (400ns) guard interval can increase throughput. However, it can also increase error rate in some installations, due to increased sensitivity to radio-frequency reflections. Select the option that works best for your installation."
    Works! Thanks a bunch!
    03-09-2014 08:11 PM
  8. Vonbare's Avatar
    I had this problem with my Galaxy and I struggled to find a solution for months. But today, I upgraded the firmware on my ROUTER (nothing to do with my phone) and voila! My phone connected straight away to my wifi.

    Might be worth checking your router firmware.

    Goodluck
    05-09-2014 05:01 AM
  9. ipb76's Avatar
    anyone know a solution yet.. ?

    Hi,
    Before everyone moans, i have seached extensively and tried many of the suggested solutions for this and none of them work.

    Samsung S4 GTI9505 Andriod 4.4.2
    (It owkrs on all other wifi networks fine - my iphone works fine on all including this work one in question)

    Initally i connected to WIFI at work.
    It redirects me to my comapny login /authentication page - i register and it works fine.

    I had to send my phone away to be fixed (screen - for the second time - another gripe )

    Upon getting my phone back i connect to the WIFI
    I show full connection but the internet doesn't work at all.

    ( it does not go to the authentication page)
    Last time after a number of weeks/moths it randomly asked me to login again and then it works fine.
    So assume after a period of time, my phone has forgotten this network or has been forgotten.

    I need to be able to do this manually.
    I have tried factpry reset, clear cache, forgeting networks, along with so many other things, date correction, using on flight mode, changing to manual proxy etc....

    Does anyone have a solution - how to completly forget the wifi network?

    Any help appreciated, as I spent another 3 hours going over the same sites and forums wityh nothing new, makes me want to throw this f*%king s4 against the wall

    Thanks
    Ian
    05-16-2014 06:23 AM
  10. Muhammad Rais Isze's Avatar
    Simple. Just check your router/internet ip address that you want to connect ..
    How to check router/internet ip address . the easy way is ask your friends who can connect the wifi/router to open wifi setting from mobile phone.. follow these step :
    go to setting --->wireless and network ---> long press the wifi that connected ---> modify network ---> copy the ip address

    Then go to your smart phone , go to setting --->wireless and network ---> long press the wifi that you want to connect ---> enter wifi password ---> thick advanced setting ----> go to ip setting , change from DHCP to static -----> enter your router/internet ip address .. Done ...but u need to repeat the steps every time you want to connect to the wifi.. You must reset to factory setting in future to permanently fixed the error... Good Luck
    08-19-2014 08:03 AM
  11. Maria Gallardo's Avatar
    Jake Bowman: I LOVE YOU! ;-) Great instructions, great troubleshooting and worked immediatelly 'like a charm' BIG Thank you!!
    08-19-2014 09:36 PM
  12. Naruto 86's Avatar
    My s4 has sprint and 3g but no matter what I try from the reviews it simply won't work. I can still connect to my wifi and it says that it has a perfect signal but it isn't working at all. The day that my new neighbors moved in this started. So is this because of them or is it what you guys are experiencing? If so please help me.
    11-11-2014 07:43 PM
  13. William Duke's Avatar
    my mobile had the same problem before....I just wait a few days...then, it works now....so wield.
    11-15-2014 01:28 AM
  14. Deeo12's Avatar
    Thanks it worked!
    12-07-2014 01:28 AM
  15. Deeo12's Avatar
    Thanks it worked!
    12-07-2014 01:29 AM
  16. pletevl's Avatar
    I've just been given an S4 and I'm having the same problem connecting to wifi.

    permanantely "Obtainig IP address"

    I've not yet tried any of the "fixed IP" solutions found here because I need it to connect automatically, i go from one wifi connection to others a few times a day.

    My Iphone can do it no probleme, why can't this S4 do it ????
    12-30-2014 04:25 AM
  17. deedubaya's Avatar
    THANKS!!! I used this to connect to a DLink Wireless Range Extender when the Galaxy s4 was the only thing not connecting. So happy.
    02-23-2015 10:55 PM
  18. Karim Sleiman's Avatar
    I had the same problem on Galaxy S6 Active. It said "Failed to obtain IP address" everytime it tried to connect to the wifi network at work (which I have no control of). IT people had tried to solve my problem to no avail.
    Anyway, I went to the Advanced wifi settings and switched off "Network notification" option. Now it automatically connects and works just fine.
    10-08-2015 04:35 PM
  19. lfitz83's Avatar
    yes i did that and i got connected and was so excited but the internet doesnt work ugh
    11-25-2015 01:57 AM
  20. skynnermcgee's Avatar
    Irregardless, none of this helps neither the OP or me. We picked the S4 becuase we liked it and thought it was the phone that would suite our needs. It would he appreciated that if you donot have valid sudgestions on a possible sollution to our problem, please refrain from posting.
    Stewie Griffin loves your use of "irregardless". On another note, I work at the Home Depot, and recently have had problems connecting with HD wifi. It says "connected" but actually isn't unless a pop up window appears with an orange connect button. I used up half my gigs in one night because I thought I was connected. I used to be able to turn my wifi off, get on the web and go to a HD site that links to the connection window, turn my wifi back on then hit the button, with great success. Now, that site is gone. I don't get the connect window until my last break, and it's useless to me by then.
    08-05-2016 12:50 AM
  21. CherylCCR's Avatar
    I just got my Samsung Galaxy S4, and kept getting the "Network disabled because internet connection is slow" or "Failed to obtain IP address" errors. I tried manually entering settings, using WPS with a pin, using WPS with a push button, nothing seemed to work - and all of our other laptops, tablets, and old phones were working just fine on the same wireless network.

    I have a D-Link router. I had to log into the router (from a computer on the network), under the advanced wireless settings I had to disable "Short GI". This may not be the same issue for everyone, but now my phone has been working flawlessly on the WiFi.

    This might be a different setting on different brand routers, but look for something similar - here's what D-Link says it is: "Using a short (400ns) guard interval can increase throughput. However, it can also increase error rate in some installations, due to increased sensitivity to radio-frequency reflections. Select the option that works best for your installation."
    Looks like this is an old thread but this is the suggestion that worked for me. Thanks ryantollefson.
    10-21-2016 09:46 PM
71 123

Similar Threads

  1. HP Touchpad/Android won't connect to Wifi
    By ZTharakan in forum HP Touchpad
    Replies: 17
    Last Post: 12-30-2013, 06:46 AM
  2. Won't connect to wifi?
    By KyleB4real in forum HTC EVO 4G LTE
    Replies: 14
    Last Post: 11-10-2013, 07:16 PM
  3. My phone won't connect to wifi... [IMPORTANT]
    By Perseveranze in forum General Help and How To
    Replies: 1
    Last Post: 11-08-2012, 10:03 AM
  4. My phone won't connect to wifi... [IMPORTANT]
    By Perseveranze in forum Samsung Galaxy S3
    Replies: 3
    Last Post: 11-07-2012, 05:37 PM
  5. Phone won't connect to wifi or 3g network
    By palmer0700 in forum Samsung Replenish
    Replies: 3
    Last Post: 04-25-2012, 01:39 PM
LINK TO POST COPIED TO CLIPBOARD