10-21-2016 09:46 PM
71 123
tools
  1. iifetap's Avatar
    Just switched to the S4 from my HTC Evo 4G. Every time I try to connect to my home Wifi network I keep getting a failure message saying "Network disabled because internet connection is slow". I have never once got this error on my Evo and my friends that come over can connect to my network without any issues. I know the password is correct, I've tried restarting the phone and router, but nothing is working. Anyone have any ideas?
    04-27-2013 01:53 PM
  2. YoungChrisG's Avatar
    I have the exact same issue! It will connect at my neighbor's house, my mom's, and even an AT&T wifi hotspot at the Home Depot. But I get the exact same error message and it says "Failed to obtain IP address". Any help at all would be much appreciated! I have scoured the net in hopes of finding a solution and can't find anything. AT&T coustumer support said that I should exchange the phone, but I'm willing to bet that that won't solve the problem.
    04-28-2013 04:58 PM
  3. Cattails_r_Edible's Avatar
    My brothers had WiFi problems too, he got the same error as the op! He took his back and got the HTC 1! Sammy is known for it's horrible radios!

    Sent from my HTCONE using Tapatalk 2
    04-28-2013 05:29 PM
  4. areyes163's Avatar
    My brothers had WiFi problems too, he got the same error as the op! He took his back and got the HTC 1! Sammy is known for it's horrible radios!

    Sent from my HTCONE using Tapatalk 2
    Dude your sweet. I'm not even on here that much and don't have the s4 but have seen you a few times in different threads already posting negative on a phone you don't even have. Must be nice to have that much spare time to continue to post on things you don't own. Wish I also had apparently nothing to do.
    fantom305 and myIphone4s like this.
    04-28-2013 05:38 PM
  5. Cattails_r_Edible's Avatar
    Dude your sweet. I'm not even on here that much and don't have the s4 but have seen you a few times in different threads already posting negative on a phone you don't even have. Must be nice to have that much spare time to continue to post on things you don't own. Wish I also had apparently nothing to do.
    My brother owned it, and I played with it for a couple of hours! Just stating facts sweetie!

    Sent from my HTCONE using Tapatalk 2
    04-28-2013 06:12 PM
  6. areyes163's Avatar
    My brother owned it, and I played with it for a couple of hours! Just stating facts sweetie!

    Sent from my HTCONE using Tapatalk 2
    Sure
    04-28-2013 06:29 PM
  7. YoungChrisG's Avatar
    Irregardless, none of this helps neither the OP or me. We picked the S4 becuase we liked it and thought it was the phone that would suite our needs. It would he appreciated that if you donot have valid sudgestions on a possible sollution to our problem, please refrain from posting.
    04-28-2013 06:53 PM
  8. KeboPR's Avatar
    Search in other forums to see if they have a fix. I've had no problems at all.

    Sent from my Samsung Galaxy S4 using Android Central Forums
    04-28-2013 07:39 PM
  9. YoungChrisG's Avatar
    Ok, so I have a solution. The first thing to do is to log into your router configuration by entering you IP address into your internet browser's address bar. If you don't know how to find your IP address and you're using Windows, open up a command prompt and type ipconfig and press enter. It should say something like IPv4 ..............192.168.0.1. Type this into your browser, and you should be prompted to enter your id and password which should be admin for both. Somewhere (it's different depending on what type of router you have) it should have an option for enabling Static DHCP IP. Select this and create an IP address you wish to use for your phone. I used 192.168.0.105. If it requires you to enter the MAC address as well, there should be a page in your router settings that shows what the router's IP address, Subnet Mask, Default Gateway, Primary and Secondary DNS and your MAC address. Simply enter your MAC address and click Add. Also take note of your Primary and Secondary DNS and Default Gateway addresses, as you will need them when adding your static IP on your device.

    Once that is done, open your Galaxy S4's options and tap the Connections tab. Tap Wifi, and long press the wireless network you wish to use. It will open an options menu. Select "Modify Network Config".
    The first option is to set a password. By default it says (unchanged). If your password you previously entered hasn't been changed simply leave this blank. If it has been changed or you aren't sure, simply type the password in. Now tick the box next to "Show advanced options". Leave Proxy settings on None. Change IP settings from DHCP to Static. In the box labeled IP address, type the IP address you selected in your router configuration page. Under "Gateway" type the Default Gateway address you took note of earlier. Next, leave "Network prefix length" at 24. Lastly, Enter the Primary DNS address in "DNS 1" and the Secondary DNS address in "DNS 2". Then click Save.

    You should now connect automatically to your wireless network!
    Hope this helps and good luck!


    I apologize for the post as it may not work. It worked for me as far as connecting to my local network, but ended up not connecting to the actual internet. However, out of frustration, I went ahead and reset my router to factory defaults, and voila, connected immediately. So if the static IP option doesn't help, the router reset should.
    04-28-2013 08:49 PM
  10. iifetap's Avatar
    Thanks for the suggestions YoungChrisG but neither options have seemed to work for me =(
    04-29-2013 04:57 PM
  11. YoungChrisG's Avatar
    Thanks for the suggestions YoungChrisG but neither options have seemed to work for me =(
    Man, I'm sorry I couldnt help. I thought for sure one of those would do the trick. Well if all else fails you cold do what AT&T tech support sudgested and take phone and trade it in for a different one.

    Also on my router there was an option to reset the device which was basically like unplugging it. Then there was an option to reset to factory defaults. This will reset your password and all other settings. This is the setting I chose. So double check that on your router settings page.

    Sent from my SAMSUNG-SGH-I337 using Tapatalk 2
    04-29-2013 07:08 PM
  12. toujours_frais's Avatar
    Gotta rely on the 3G connection bro
    04-30-2013 01:42 AM
  13. YoungChrisG's Avatar
    Ok, so a weird thing just happend to me. My router was set on no protection or password required to connect to the router. So I changed it and enabled WPA pre-shared key and set a password. After that, my S4 started giving me the same "Failed to obtain IP address" again. So, I went back to my router and changed it back to no password required/open network, and now my S4 is connecting fine. If you're still having that problem, try that and get back to me if you don't mind. I am very curious now about this issue. If that indeed does solve your problem, I will try to notify Samsung about the issue and see if they can either help me to figure out how to use my wifi and keep my network locked, or if they can fix the issue in a future system update.

    So please give this a try so I can continue to look into the issue.
    05-05-2013 02:45 PM
  14. nata_panya's Avatar
    Hello

    The solution to your problems can be solved by adjusting your wifi settings on your s4.

    By way of explanation, the s4 has wifi settings /features to help get you a better connection. But it can lead to the s4 dropping a weak wifi signal and switch to 3g or 4g unnecessarily.

    Here's what you need to do (I've done it and tested it myself):

    1. Settings>Connections
    2. Long tap the "wifi" word. This will take you into the available wifi connections screen.
    3. Tap the haptic menu button (to left of the home button).
    4. Select "Advanced" from the options.
    5. UNcheck the following (in other words, switch off these three settings):
    a. "Network notification"
    b. "Check for Internet service"
    c. "Disconnect weak wifi"

    That's it.

    After you've switched off these three settings, your problems should go away. It did for me.

    Hope that helps.

    (Edited typo)
    05-05-2013 03:07 PM
  15. SpookDroid's Avatar
    You could also try changing your modem's channel to a less crowded one. That's what was causing mine to fail.
    05-05-2013 03:57 PM
  16. miatagrrl's Avatar
    Ok, so a weird thing just happend to me. My router was set on no protection or password required to connect to the router. So I changed it and enabled WPA pre-shared key and set a password. After that, my S4 started giving me the same "Failed to obtain IP address" again. So, I went back to my router and changed it back to no password required/open network, and now my S4 is connecting fine. If you're still having that problem, try that and get back to me if you don't mind. I am very curious now about this issue. If that indeed does solve your problem, I will try to notify Samsung about the issue and see if they can either help me to figure out how to use my wifi and keep my network locked, or if they can fix the issue in a future system update.

    So please give this a try so I can continue to look into the issue.
    I have a similar but not identical issue. I just tried most of the suggestions in this thread, but nothing has worked. Here is my issues: I just got a Samsung Galaxy S4. As I have always done with all of my devices that connect wirelessly, I went into my D-Link software and added my phone's MAC address to the network filter list. The security settings are WPA/WPA2. When I try to connect, the phone is able to see my Wi-Fi network, and it asks for my password, which I enter. It keeps trying to connect, but then it says an "authentication error occurred." I have checked and triple-checked the password, and it is correct. I have also checked and triple-checked the MAC address, and it is correct. I have rebooted the router and the phone several times each. Any suggestions on resolving this? I am an ordinary consumer, not a geek by any means :-) -- please state your response accordingly. Thank you!

    - Tina
    05-12-2013 06:56 PM
  17. ryantollefson's Avatar
    I just got my Samsung Galaxy S4, and kept getting the "Network disabled because internet connection is slow" or "Failed to obtain IP address" errors. I tried manually entering settings, using WPS with a pin, using WPS with a push button, nothing seemed to work - and all of our other laptops, tablets, and old phones were working just fine on the same wireless network.

    I have a D-Link router. I had to log into the router (from a computer on the network), under the advanced wireless settings I had to disable "Short GI". This may not be the same issue for everyone, but now my phone has been working flawlessly on the WiFi.

    This might be a different setting on different brand routers, but look for something similar - here's what D-Link says it is: "Using a short (400ns) guard interval can increase throughput. However, it can also increase error rate in some installations, due to increased sensitivity to radio-frequency reflections. Select the option that works best for your installation."
    05-18-2013 01:16 PM
  18. Aaron Watson's Avatar
    This worked on my s3, long press the desired wifi and tap forget then try again

    Posted via Android Central App from my Samsung Galaxy S3! GT-19300
    05-18-2013 06:59 PM
  19. mark5019's Avatar
    ive had no probs with my s4 wifi or data sorry your haveing probs
    05-18-2013 07:00 PM
  20. fantom305's Avatar
    I have a similar but not identical issue. I just tried most of the suggestions in this thread, but nothing has worked. Here is my issues: I just got a Samsung Galaxy S4. As I have always done with all of my devices that connect wirelessly, I went into my D-Link software and added my phone's MAC address to the network filter list. The security settings are WPA/WPA2. When I try to connect, the phone is able to see my Wi-Fi network, and it asks for my password, which I enter. It keeps trying to connect, but then it says an "authentication error occurred." I have checked and triple-checked the password, and it is correct. I have also checked and triple-checked the MAC address, and it is correct. I have rebooted the router and the phone several times each. Any suggestions on resolving this? I am an ordinary consumer, not a geek by any means :-) -- please state your response accordingly. Thank you!

    - Tina
    I answered to some one before on this same procedures...my question is why do you want to filter your mac address with your cell phone when the network that you use is at your house ???? All you have to do is activate your wifi, ...scan for networks.... I am sure your network will come up on the list, once is there choose connect to it. It will ask you to enter the information. Put in the password and make it default network....that is all you need...from now on every time you make wifi active in your house it will automatically connect to your network with out having to enter any further information..............why do you guys insist in complicating your life for something that it is not necessary ..........
    05-18-2013 07:52 PM
  21. fantom305's Avatar
    I just got my Samsung Galaxy S4, and kept getting the "Network disabled because internet connection is slow" or "Failed to obtain IP address" errors. I tried manually entering settings, using WPS with a pin, using WPS with a push button, nothing seemed to work - and all of our other laptops, tablets, and old phones were working just fine on the same wireless network.

    I have a D-Link router. I had to log into the router (from a computer on the network), under the advanced wireless settings I had to disable "Short GI". This may not be the same issue for everyone, but now my phone has been working flawlessly on the WiFi.

    This might be a different setting on different brand routers, but look for something similar - here's what D-Link says it is: "Using a short (400ns) guard interval can increase throughput. However, it can also increase error rate in some installations, due to increased sensitivity to radio-frequency reflections. Select the option that works best for your installation."
    Something I have noticed with this kind of a problem is that every one that has a problem, owns a D-Link router ........... perhaps that is the reason ......... I myself own a LINKSYS .......... much easier to use.
    05-18-2013 07:55 PM
  22. Juniper94's Avatar
    I do have a Linksys router, and have the problem with the Wifi at home. My Samsung Galaxy S4 connects to my wireless network with full strength, but the Internet on the phone does not work.
    05-19-2013 07:50 PM
  23. Etgen's Avatar
    I am also having a wifi issue. It will connect if I leave the network open but not when I have any encryption turned on. I've gotten it to connect using a static IP but then it is not able to use the internet. Does anyone have any suggestions on how to fix this?
    05-19-2013 09:58 PM
  24. fishepa's Avatar
    I am also having a wifi issue. It will connect if I leave the network open but not when I have any encryption turned on. I've gotten it to connect using a static IP but then it is not able to use the internet. Does anyone have any suggestions on how to fix this?
    What type of encryption are you using? I would recommend WPA2.
    05-19-2013 10:01 PM
  25. Etgen's Avatar
    What type of encryption are you using? I would recommend WPA2.
    I've tried WEP, WPA, and WPA2 and it didn't work with any of them.
    05-19-2013 10:07 PM
71 123

Similar Threads

  1. HP Touchpad/Android won't connect to Wifi
    By ZTharakan in forum HP Touchpad
    Replies: 17
    Last Post: 12-30-2013, 06:46 AM
  2. Won't connect to wifi?
    By KyleB4real in forum HTC EVO 4G LTE
    Replies: 14
    Last Post: 11-10-2013, 07:16 PM
  3. My phone won't connect to wifi... [IMPORTANT]
    By Perseveranze in forum General Help and How To
    Replies: 1
    Last Post: 11-08-2012, 10:03 AM
  4. My phone won't connect to wifi... [IMPORTANT]
    By Perseveranze in forum Samsung Galaxy S3
    Replies: 3
    Last Post: 11-07-2012, 05:37 PM
  5. Phone won't connect to wifi or 3g network
    By palmer0700 in forum Samsung Replenish
    Replies: 3
    Last Post: 04-25-2012, 01:39 PM
LINK TO POST COPIED TO CLIPBOARD