1. Dartiailh's Avatar
    Hi I am new to the Android world having a iPhone for years

    The problem I am having is getting to samsung to show my music when plugged in via usb in my car

    I have done some surfing to find that you need to somehow root the external memory card????

    Can any one advise me on what I need to do to play the music in my car - iPhone worked perfectly .... Other than that the iPhone is S**the in comparison

    Sent from my GT-I9505 using Android Central Forums
    05-09-2013 07:41 AM
  2. dwhitman's Avatar
    Not 100% sure I understand what you're trying to do, but be aware that Android handles music streaming differently than iOS.

    On iOS, you can send music data (streaming sound, plus track info) out the bottom connector thing, and many cars have a port wired to accept this. That connector is proprietary to Apple, so no other phone can implement it without paying a big royalty to Apple.

    Android phones DO have a USB port, but to the best of my knowledge, no (out of the box) Android phone supports sending music data out the USB port. Instead, you use Bluetooth and most recent car stereos will play the streamed music and display track info, album cover, etc. You need to pair your S4 with the car's stereo; this may be two different pairings: one for hands free phone, the other for audio. Once you have the audio paired, when you play music on the S4, it should come out of the car's speakers.

    If your car stereo doesn't support Bluetooth, your other option is to just connect the phone to an aux input on the stereo using an audio cable plugged in the headphone jack. That's what I did on my previous car; worked fine.

    Nit pick: if your stereo can play music off a flash drive plugged into a USB port, it seems like you should be able to mount your S4 as an external drive and see the tracks. But I don't think this is what you mean.
    05-09-2013 10:47 AM
  3. kingj41's Avatar
    I have this same issue. I have a 2011 Buick Regal. Bluetooth connects just fine. But when I connect my USB cable it doesn't recognize any MP3s. I never had this problem with either a GS2 or GSIII.
    Also, I originally had problems when connecting to a Windows 7 CPU. I removed my SD card, re-installed, switched between connection modes, and even rebooted the phone to finally have the CPU recognize my storage location.
    I really don't know what did the trick. It's bugging the hell out of me with a new GS4 not being able to share via USB in my car.
    05-09-2013 04:08 PM
  4. Est1957's Avatar
    Short answer = Android 4.2 aka Jelly Bean

    Long answer...
    Google, in their infinite wisdom, decided that 'We' didn't need USB Mass Storage Mode anymore!
    Instead, they have given us MTP (Media Transfer Protocol) and PTP (Photo Transfer Protocol), which have slower transfer rates and don't allow windows (or any USB connection for that matter) to recognize the microSD card the way USB MS does.

    The only way to get USB MS mode back is to root the phone which allows an app to use the microSD as a Mass Storage device.
    05-28-2013 11:56 AM

Similar Threads

  1. how do i enable mass storage mode?
    By mstr_pixel in forum Verizon Fascinate
    Replies: 6
    Last Post: 03-24-2013, 02:28 PM
  2. why wont my epic pop up on my pc in mass storage mode
    By Ostrich69 in forum Sprint Epic 4G
    Replies: 1
    Last Post: 10-13-2010, 06:37 AM
  3. USB Mass Storage Bug in Vibrant?
    By namyawon in forum T-Mobile Vibrant
    Replies: 14
    Last Post: 09-18-2010, 09:27 PM
  4. Mass Storage Help
    By tnfan in forum AT&T Captivate
    Replies: 5
    Last Post: 08-25-2010, 05:51 PM
  5. mass storage mode
    By mojonation1487 in forum AT&T Captivate
    Replies: 5
    Last Post: 08-22-2010, 12:55 AM
LINK TO POST COPIED TO CLIPBOARD