1. Ducky7's Avatar
    My house is in an area where the digital signal (3G or 4G) is very marginal, one or sometimes 2 bars. The analog signal, however is pretty good 3-4 bars. When my Galaxy S4 tries to stay on the digital signal, often my phone doesn't receive incoming calls, or suddenly a bunch of texts are delivered at once instead of spaced out like they were originally sent. Can someone tell me how to force my phone to use the analog signal only (and how to re-allow the digital signal for when I head into town). Thank you for your time!
    05-11-2013 05:26 PM
  2. Aquila's Avatar
    My house is in an area where the digital signal (3G or 4G) is very marginal, one or sometimes 2 bars. The analog signal, however is pretty good 3-4 bars. When my Galaxy S4 tries to stay on the digital signal, often my phone doesn't receive incoming calls, or suddenly a bunch of texts are delivered at once instead of spaced out like they were originally sent. Can someone tell me how to force my phone to use the analog signal only (and how to re-allow the digital signal for when I head into town). Thank you for your time!
    Turn off mobile data. In the settings under Data usage.
    05-11-2013 05:41 PM
  3. matxor's Avatar
    Depending on the ROM, you should be able to set what radio is forced. Try going into the mobile data section and selecting GSM preferred

    Sent from my One X using Tapatalk 2
    05-11-2013 05:43 PM
  4. fantom305's Avatar
    If the mobile data is turned off, no messages will be received and is not the solution. Like matxor said go into the setting of mobile data and select that proper radio settings.
    05-11-2013 07:16 PM
  5. Aquila's Avatar
    If the mobile data is turned off, no messages will be received and is not the solution. Like matxor said go into the setting of mobile data and select that proper radio settings.
    Texts still arrive when mobile data is turned off. I do it almost every day while sleeping so that I only receive texts and phone calls, but no e-mails or app notifications. It's not airplane mode.
    05-11-2013 07:18 PM
  6. Aquila's Avatar
    Turning mobile data off turns off your access to your data plan, which is LTE, 4G, 3G, 2G, 1X, etc. You can still send/receive texts because those travel on your cellular service along with voice calls. This is how you can receive texts on phones that do not have a data plan at all. Try it out, turn off mobile data and send yourself a text. They'll get it and you'll get the reply if they reply to it.
    05-11-2013 07:24 PM
  7. Ducky7's Avatar
    I've spent quite a bit of time looking around the mobile data section (and others) and still cant find where to select which radio is preferred. Anyone had any luck finding the controls on a Galaxy S4?
    05-11-2013 09:59 PM
  8. brianphrack's Avatar
    My house is in an area where the digital signal (3G or 4G) is very marginal, one or sometimes 2 bars. The analog signal, however is pretty good 3-4 bars. When my Galaxy S4 tries to stay on the digital signal, often my phone doesn't receive incoming calls, or suddenly a bunch of texts are delivered at once instead of spaced out like they were originally sent. Can someone tell me how to force my phone to use the analog signal only (and how to re-allow the digital signal for when I head into town). Thank you for your time!
    Which carrier are you on?
    05-11-2013 11:02 PM
  9. Aquila's Avatar
    I've spent quite a bit of time looking around the mobile data section (and others) and still cant find where to select which radio is preferred. Anyone had any luck finding the controls on a Galaxy S4?
    As far as I can tell, changing what type of mobile data network you are on should have no impact whatsoever on your text sms. If you want something that is a toggle, it's mobile data. That will allow you to receive calls and texts while disabling access to your data plan.
    05-11-2013 11:09 PM
  10. Ducky7's Avatar
    AT&T. Android version 4.2.2 I've tried going down about every rabbit hole I can find through the menus, but not had any luck finding any controls for radio preference. Starting to think that this (unfortunately) is a control that either Samsung or Google don't think we're smart enough to make our own decisions on...
    05-12-2013 12:58 AM
  11. JudH's Avatar
    First try "Network" by Philipp Mangelow on the Play store. It gives you an option to limit the network type until the next boot. It may not run on the S4.

    Then try the method documented here.
    http://forums.att.com/t5/Android-Dis...f/td-p/3326169
    (Google "samsung g3 disable lte" if the link doesnt work). They may have fixed this loophole in the G4 haven't heard.

    There is another way to permanently turn the network option on but it involves changing some system files so you have to be rooted. It should be in the google search above.

    AT&T just doesnt comprehend that some of us live in weak signal areas and the phone uses about 30% more power constantly switching to a faster network only to have to switch back.

    By the way, your phone isn't switching from ANALOG to digital. AT&T phased analog out several years ago. Some of the other small carriers kept it a bit longer but I think it's totally gone now. Everything is digital now. The phone is switching between GSM only, then 3G/4G, then LTE. I don't see much difference battery wise if the phone stays put--its the constant hunting that kills the battery.
    05-12-2013 10:12 AM
  12. JudH's Avatar
    One more thing--mobile data has nothing to do with the phone switching network types due to weak signal so turning it on or off will have no effect on this problem. I keep mobile data turned off on our two phones unless it's needed and they still do the network shuffle unless I force them to one type.
    05-12-2013 10:20 AM
  13. Rick Bray's Avatar
    Settings > Connections > More Networks > Mobile Networks > Network Mode

    there you can select:
    "LTE/GSM/WCDMA (auto connect)", which are 4g, 2g, and 3g, respectively
    "GSM/WCDMA (auto connect)", just 2g and 3g
    "GSM only", 2g
    "WCDMA only", 3g

    hope this helps

    EDIT: enabling/disabling mobile networks won't affect regular phone calls, nor regular SMS's, but it WILL affect MMS's

    Samsung Galaxy S4 SGH-I337m
    juststart and Hugo Pi like this.
    05-14-2013 09:47 AM
  14. Eric Kane's Avatar
    Go to the Phone app. Open the keypad.

    Dial #*#*4636*#*#

    This is your testing settings. I don't advise to touch anything else on these settings, by the way.

    Click on "Device Information"

    Scroll down to a drop down menu that should say "LTE/GSM auto (PRL)" if you're using the AT&T or TMobile versions. Might be WCDMA/LTE for Sprint.

    Select "GSM auto (PRL)" for just HSPA+ on TMobile or AT&T. Select "CDMA auto (PRL)" for just 3G on Sprint.


    Hope that helps.



    Just for clarification, most carrier-branded versions of the S4 don't allow you to change the network mode. AT&T, for instance, isn't interested in letting you use HSPA+ and saturate that network when they have a perfectly good LTE network that makes you use more data. It's just the way it works. What I posted above is a way around that. I can turn off LTE on my device whenever I feel like it.
    Hugo Pi likes this.
    05-14-2013 09:57 AM
  15. Omer San Gabriel's Avatar
    My house is in an area where the digital signal (3G or 4G) is very marginal, one or sometimes 2 bars. The analog signal, however is pretty good 3-4 bars. When my Galaxy S4 tries to stay on the digital signal, often my phone doesn't receive incoming calls, or suddenly a bunch of texts are delivered at once instead of spaced out like they were originally sent. Can someone tell me how to force my phone to use the analog signal only (and how to re-allow the digital signal for when I head into town). Thank you for your time!
    I have Galaxy S4 I9505 16gb, Try this.

    Go to Settings -> More Networks -> Mobile Networks -> Network Mode -> Choose GSM Only. I think this will limit your carrier to be only in 2g.
    05-14-2013 10:05 AM
  16. Almeuit's Avatar
    Turn off mobile data. In the settings under Data usage.
    This.

    Sent from my Sprint S3 using AC forums.
    05-14-2013 10:17 AM
  17. maggieo's Avatar
    Hi Eric,

    Do you know of any way to do this on Verizon's Galaxy S4? The option isn't in the menu - which for those who are looking for it - settings->connections->More Networks->Mobile Networks ->Network Mode. Under there is Global, LTE/CDMA, GSM/UMTS. When I have a weak 4G signal, I can't use the internet, but I can't change it to stay at 3G - on older android os I could.. but on verizon model of Jelly Bean 4.2 Galaxy S4 I can't.. If there is ANY way you can figure out for me to do this it would be huge... Thank you in very much. (You would think they'd let us use slower/less data - but they won't!) I just want my phone to work..
    07-17-2013 10:55 PM
  18. jball32's Avatar
    I don't have the link handy but ifbu search "phone info"app for LTE/gsm/CDMA u might come across the download I found and it will give u the options u r looking for.I do not have network mode in my settings either GS4 I337
    08-08-2013 05:12 AM
  19. prampe's Avatar
    The correct code is *#*#INFO#*#* or *#*#4636#*#*
    08-30-2013 03:36 PM
  20. monkeyhouserodge's Avatar
    Eric, is there a code like that that will work on the S4 Active?
    10-14-2013 09:51 AM
  21. jball32's Avatar
    The apk i was talking about so long ago

    https://www.dropbox.com/s/jetl0n0mer...one%20info.apk

    Nexus 5 via Android Central App
    06-17-2014 04:25 AM

Similar Threads

  1. Does anyone know a way to force my GS3 to roam?
    By hawaiijedi in forum Verizon Galaxy S III
    Replies: 3
    Last Post: 07-02-2013, 04:46 PM
  2. Replies: 2
    Last Post: 12-14-2012, 02:13 PM
  3. Is there a way to "force" the S3 to connect to a 4G network?
    By Metorks in forum AT&T Galaxy S III Rooting, ROM's, and Hack's
    Replies: 3
    Last Post: 09-24-2012, 11:54 PM
  4. Thunderbolt not connecting 3G or 4G
    By Sam_Winchester in forum Verizon HTC Thunderbolt
    Replies: 21
    Last Post: 08-03-2012, 05:07 PM
  5. How to force an app to use WiFi
    By Tennessee in forum Motorola Droid
    Replies: 0
    Last Post: 11-10-2009, 09:57 AM
LINK TO POST COPIED TO CLIPBOARD