07-30-2017 07:10 AM
30 12
tools
  1. Mojie Naghi's Avatar
    Thank you taking the time to post this. You save me so much time and aggravation!
    Again, much appreciated!!!
    08-19-2013 05:49 AM
  2. itslunchbox's Avatar
    Ditto -- lots of issues with my DLINK DIR-655 (version A2 running 1.35NA firmware) for the last 2 weeks -- started exactly when I brought my beautiful new Verizon S4 home.

    Today I notice a firmware upgrade to 1.37 on DLINK's web page which states "Improved compatibility issue with Samsung Galaxy S4". It is dated 6/11/13. I just installed it and hopefully it works. Everyone in the house is frustrated as my router keeps freezing for everyone.....

    D-Link | DIR-655 Wireless N Gigabit Router
    I can confirm as well that this firmware resolved the issue.
    09-06-2013 12:52 PM
  3. pavan123's Avatar
    Hello guys,

    I had the exact same problem with my Samsung Galaxy S4 and DIR-655 (A4 revision, 1.32 firmware). Installing the latest firmware 1.37 completely fixed the issue. The release notes for this firmware version (released in 6/11/2013) says "Improved compatibility issue with Samsung Galaxy S4". I knew my problem was solved when I saw that statement.

    You can find the firmware download from dlink's site using the following steps. First connect your laptop using an Ethernet cable to your router. I read somewhere that it is better to have a wired connection while updating the firmware. Maybe you really don't need it. I don't know; I used a wired connection for this operation. Then, simply type DIR-655 in Google, choose the first link which has to be dlink.com. In the middle of the page, there is a "Downloads" tab. Click that and then click the link "Go to the DIR-655 support page". Then type "DIR-655" (without quotes) in the search box that appears. The search results should list DIR-655 Xtreme N Wireless Router. Choose that. Then from the drop-down for the hardware revision, choose "A" (or whatever is correct for *your* modem; the revision number and firmware number is at the back of the router). Finally, you are presented with the download for the firmware (make sure it lists 1.37 or more). Hitting the download button downloads it as a .zip file. Unzip it to extract the lone .bin file inside it. Then go to the router's admin page (it is 192.168.0.1 unless you have changed it). Log in using admin password (it is empty unless you have set it). Then click the "Tools" tab. Then the "Firmware" tab. You should see buttons to choose a file on disk and to actually upload it to the router for installation. Pretty straight forward from here. BUT WAIT!!!!. Uploading this firware version wipes all your existing settings. Which meant that I had to reset the Wifi password again, etc. If you reset it to the same password it was before the wipe, you don't have to re-enter a new password into all your mobile device in your home. This was a minor hassle compared to the joy of getting my router back in action. One more thing, on the Firmware page that allows you to upload the .bin file, there is a "Check Now" button. I assumed it would smart to actually detect that my firmware was old and download the new one. But no such luck. It just said that the firmware was up to date. Liar! Just use the manual upload path explained above.

    I owe a thanks to this forum for fixing my problem. Hopefully, my detailed notes help others. Best of luck!
    10-02-2013 01:08 PM
  4. andersm's Avatar
    Just posting a possible fix for anyone having related issues.

    I had problems connecting my S4 to internet through my dlink DIR-655. It connects to the wifi, but no internet.
    None of the fixes suggested like updating firmware, changing to TKIP etc worked for me.

    I tried to change different settings on the router and on the phone and suddenly I noticed on the S4 it had an IP-address outside the range of the router.

    Solution:
    On your router:
    1. Log in to the router. Note the LAN IP address of the router (Mine was dlink default 192.168.0.1)
    2. Note the DHCP IP range on your router. (On my dlink was is found under Setup/Network settings, and the settings were default: 192.168.0.100 to 192.168.0.199)
    On your Samsung
    3. Go to settings/connections/wifi (click the icon, not the on/off switch)
    4. In the list of networks, click and hold the name of your wifi to see the menu. Choose "Change Configuration".
    5. Change IP-settings from DHCP to Static.
    6. Change your IP-address to one in the range as described in 2. (I set mine to 192.168.0.199 which is the last in the series, to avoid conflicts with other users that might have gotten one of the first IP-adresses)
    7. Change Gateway to your router's IP as described in 1. (Mine was dlink default 192.168.0.1)

    Hope this helps someone. It took me several hours to figure this out.
    12-18-2013 06:03 PM
  5. dasjenige's Avatar
    I would also like to share what worked for me.
    Initially Samsung S7 Edge wouldn't connect to Wi-Fi via D-link DIR-320 router: it detected the network, but made no attempts to connect, or when forced to connect manually, nothing happened. A dozen other devices in the household were working with this router seamelessly.
    Updating firmware to the latest official version, or using alternative versions DID NOT work.

    After experimenting with settings a bit, I discovered that these ones worked!
    Particularly, changing WPA2 to WPA-Auto-Personal, and TKIP + AES to TKIP.

    samsung galaxy s4, D-Link routers, wifi issues solved!-.jpg

    Hope this saves someone the hours I spent in frustration, Google, and trial & error
    07-30-2017 07:10 AM
30 12

Similar Threads

  1. Samsung Galaxy S4 SD Card Issue
    By Joel Innard in forum General Help and How To
    Replies: 284
    Last Post: 02-23-2016, 06:14 AM
  2. Replies: 55
    Last Post: 10-31-2013, 10:41 PM
  3. Samsung Galaxy S4 to feature 5G WiFi
    By deesugar in forum Samsung Galaxy S4
    Replies: 2
    Last Post: 02-21-2013, 10:20 PM
  4. WIFI ERROR Samsung galaxy tab 7.0 plus wifi only
    By lycanknight in forum Samsung Galaxy Tab 7.0 Plus
    Replies: 8
    Last Post: 12-02-2012, 08:23 PM
  5. Samsung Galaxy Tab 10.1 16gb Wifi
    By Jrid32 in forum Marketplace Archive
    Replies: 18
    Last Post: 05-20-2012, 12:41 AM
LINK TO POST COPIED TO CLIPBOARD