07-30-2017 07:10 AM
30 12
tools
  1. jim1745's Avatar
    this is a thread I started on the D-Link DIR-655 forum. not sure if I can post any links so I will just copy to this thread.
    Hi all,
    My current set up:
    D-Link router Model: DIR-655
    Hardware Version: A4
    FW: 1.21
    mixed 802.11n, 802.11g, 802.11b
    Auto Channel Scan: Enabled
    Transmission Rate: Best ( Automatic )
    Channel Width: Auto 20/40 Mhz
    Security Mode: WPA-Personal
    WPA Mode: WPA2 only
    Cipher Type: AES

    Symptoms:
    from reading various threads all over it seems that D-link and Samsung phones don't play well with each other . like everyone else with this issue I can connect. however signal will terminate after about 1 minute or so and I would have to manually go into my phone settings and shut down Wi-Fi, open it again to establish connection again. but like before it will only hold for a min or so before it freezes yet again.
    I did find a way around this issue, it seems that if I change the Cipher Type from AES to TKIP the wifi issue goes away and I am able to hold the connection.

    what I ended up doing is creating a guest zone SSID. other then changing the Cipher to TKIP on my guest account I left all other setting the same as my main SSID. also For ultimate security I made sure that Enable Routing Between Zones box is unchecked. my phone is been connected with zero dropouts for the last 3 hours
    by creating a guest zone SSID with the TKIP Cypher I only connected my Samsung phone to it and nothing else. thus leaving all my other devices on my main SSID using the AES Cypher.
    the only draw back that I can see is that TKIP is using the G band and is not compatible with the N band, however when using any powerful device there is little difference when opening applications or surfing the web. infact, from what I can see from playing with my phone for the last two hours is that pages on the web actually open up faster then on the N mode. I think it has to do with the less encryption\decryption that pages has to go thru with the AES Cypher? not really sure but my phone is flying fast
    anyways, I'm Golden now. Hope this is helpful to others with same issues with Samsung phones as well.

    here is a link on the 'how to' for creating a guest zone SSID for those who are not familiar with the router settings:
    www DOT gilsmethod.com/how-to-create-a-guest-network-with-d-link-routers
    Hope this will help others with same issue.
    Jim
    05-15-2013 06:17 PM
  2. vasyok's Avatar
    I have an Asus RT-AC66R and had the same problem. It would constantly disconnect, so I searched the web and found this solution for GSIII (figured it might work on GS4) to set wireless not to turn off when phone goes to sleep. I am giving it a shot. I will report back to see if it worked. I am adding a link if anyone else wants to try it.


    Fix the Samsung Galaxy S3 Wi-Fi connection | TechRepublic



    20 minutes later and this fix did not work
    05-15-2013 06:43 PM
  3. jim1745's Avatar
    I have an Asus RT-AC66R and had the same problem. It would constantly disconnect, so I searched the web and found this solution for GSIII (figured it might work on GS4) to set wireless not to turn off when phone goes to sleep. I am giving it a shot. I will report back to see if it worked. I am adding a link if anyone else wants to try it.


    Fix the Samsung Galaxy S3 Wi-Fi connection | TechRepublic



    20 minutes later and this fix did not work
    Sorry to hear that vasyok... my GS4 is been running smoothly with no Wifi issues since doing this method. maybe try it again without enabling the wireless not to turn off when phone goes to sleep.
    for me, I didn't have to do that for the wifi problem to go away.
    05-15-2013 07:43 PM
  4. vasyok's Avatar
    Your method did work, 2 days no problems. Thanks
    05-16-2013 07:36 PM
  5. jim1745's Avatar
    Your method did work, 2 days no problems. Thanks
    Glad to hear it all worked out for you vasyok.
    vasyok likes this.
    05-17-2013 04:59 PM
  6. Nick Floussov's Avatar
    No such luck with my Galaxy S4 and D-Link DIR-655.
    I mean, this is default setting for "Keep Wi-Fi open during sleep" - "Always".
    Even more - looks like in some time Samsung jams router and
    the whole network becomes disabled.
    And I have to restart router to make it work again.
    ...
    P.S. OK, there is one important issue - FW version!
    I had 1.21 for my DIR-655 Rev A4
    It is not possible to find right upgrade on the official website and
    I was lucky to find the link to the latest 1.36 upgrade:
    http://wrpd.dlink.com.tw/router/firm...FW136NAB02.bin
    So far it works.
    05-20-2013 06:35 AM
  7. bdmridgback's Avatar
    My Dlink and S4 have work flawlessly since the day she came home.

    Sent from my Sprint GS4
    05-20-2013 08:52 AM
  8. Nick Floussov's Avatar
    My Dlink and S4 have work flawlessly since the day she came home.
    Could you make it a bit clear:
    - carrier
    - Dlink model: 655, 825...
    - Dlink revision: Ax, Bx
    - S4 from carrier or Google?

    Thanks.
    05-20-2013 01:13 PM
  9. ka7bsk's Avatar
    I cant begin to thank you enough. I have the D-Link router. The back door made it happen!! I had begun to box it up to ship back but the last site was this one and I gave one more try. I am using the guest door and it holds the connection beautifully. Now to fix the overheating. Somewhat disappointing all the anticipation and lots of operational issues. The phone is absolutely perfect except for the heat...thank you again for the back door!!
    05-24-2013 08:06 PM
  10. bdmridgback's Avatar
    Could you make it a bit clear:
    - carrier
    - Dlink model: 655, 825...
    - Dlink revision: Ax, Bx
    - S4 from carrier or Google?

    Thanks.


    Dlink model DIR-615 and on Sprint with S4


    Sent from my Sprint GS4
    05-24-2013 08:47 PM
  11. gmanish's Avatar
    I have an Apple Airport Express and I am having the same issue. I find it hard to believe that it's a firmware or router hardware problem since all the other devices I have a home - iPhone, LG Optimus Smartphone, Samsung Galaxy Note 10.1, PS3, MacBookPro and iMac all use the same access point without any problems.
    05-27-2013 01:36 AM
  12. Erik Hagen1's Avatar
    It's a known issue with the S4 and Samsung is not doing anything about it.

    I wish I had known about it before purchasing the phone. I would have gone with another phone. As it is, I turn off my Wi-Fi at work, thus making the entire point of having the phone pointless. I work at UCLA and have no control over the routers. IT is aware of the issue, but like all bureaucracies, who knows when something will be done. In the mean time, no Wi-Fi.

    Off Wi-Fi, my Mobile Data has increase exponentially over my BlackBerry Torch. If you turn off Mobile Data, be sure to shut down background data on your heavy use apps. Otherwise, be prepared to buy into a new data plan. If you can afford it, get unlimited, but be sure to have a charger with you at all times as it drains the batter in less than an 8 hour day at work.

    Samsung acknowledges Galaxy S4 wi-fi connection problem | ZDNet
    How to Fix Samsung Galaxy S4 WiFi Problems
    05-28-2013 03:00 PM
  13. GrooveRite's Avatar
    Ahh this is good to know! This would explain why I couldn't seem to connect my mothers S4 to the 655 this past weekend. The funny thing is that my S3 connected fine to the 655 but the S4 was the one having trouble.
    05-28-2013 03:35 PM
  14. soljah12's Avatar
    Thanks for this information op! Glad I now have my home wifi and S4 working without issues. Before this information, I couldn't even use my home wifi as the S4 was somehow jamming the router non-stop and the whole network was down.

    Hope Samsung fixes this issue in the near future. Thankfully we can find and use workarounds like this for personal use but it doesn't help when you have issues connecting to work or commercial wifi spots and have this connection problem.
    06-09-2013 10:47 PM
  15. Parker Davis's Avatar
    I have a Dlink DIR-825 and experienced extremely poor wifi performance with both my wife's and my new Galaxy phones (Express and S4). After trying the various "solutions" posted online for the phones, I tinkered with the router settings and tested just about everything. Finally I tried to limit the security of my 2.4ghz band to WPA only and TKIP and the problems seem to have cleared up. It seems Samsung and/or Android and/or Jelly Bean phones don't like the more secure WPA2 standard and AES cypher.
    06-13-2013 01:42 AM
  16. Vance McDougall's Avatar
    I have to say thank you very much . I had the hardest time figuring thus out until I found your resolution. I but I didn't follow it exactly to the T the first time, second time I did and it works flawlessly. Thanks again. :-)
    06-26-2013 11:10 AM
  17. Spencer Bullard's Avatar
    Hi people,
    So I have a Dlink DAP 1155 wireless router, works fine with S3/iphones/blackberrys but the S4 is killing me. Have changed the settings to WPA, tried every combination of 802.11xyz, the only way I can get a connection is to set the security to none, but obviously this isn't an option (not unlimited internet). Any help would be greatly appreciated, oh and I upgraded the Firmware to the highest version I could find (Dlinks website is not so good)
    06-27-2013 08:49 AM
  18. bdmridgback's Avatar
    I don't have any issues with my Dlink DIR-615 and my S4 and my wifes S3 with connections. I know I have our phones set to always stay connected even while sleep. I also went to Dlinks site and compared the 615 and 655 and really don't see any differences in specs.

    Sent from my Sprint GS4
    06-27-2013 12:13 PM
  19. RLangerman's Avatar
    Ditto -- lots of issues with my DLINK DIR-655 (version A2 running 1.35NA firmware) for the last 2 weeks -- started exactly when I brought my beautiful new Verizon S4 home.

    Today I notice a firmware upgrade to 1.37 on DLINK's web page which states "Improved compatibility issue with Samsung Galaxy S4". It is dated 6/11/13. I just installed it and hopefully it works. Everyone in the house is frustrated as my router keeps freezing for everyone.....

    D-Link | DIR-655 Wireless N Gigabit Router
    SixFourTwo and DataHawg like this.
    06-30-2013 12:57 AM
  20. SixFourTwo's Avatar
    Today I notice a firmware upgrade to 1.37 on DLINK's web page which states "Improved compatibility issue with Samsung Galaxy S4". It is dated 6/11/13. I just installed it and hopefully it works. Everyone in the house is frustrated as my router keeps freezing for everyone.....

    D-Link | DIR-655 Wireless N Gigabit Router

    Finally the issues have been solved with this update!!!!

    Sent from my iPad using Tapatalk HD
    06-30-2013 06:38 PM
  21. RLangerman's Avatar
    I've been running the new DLINK firmware now for 24 hours and everything has been stable. Finally!!
    07-01-2013 12:15 AM
  22. N0AN's Avatar
    Latest Firmware revision download and install solved the Galaxy S4 problems for me.
    I could not stay connected long enough to download a 100 mB map file at 6 mbps, until I upgraded my A1 version 1.00 firmware on my D-Link 825 router.

    Success! Very nice.

    Thanks so much for the tip.

    ...hasan
    07-16-2013 06:42 PM
  23. MrMeMyself's Avatar
    I am a daily traveller at the London underground and the phone has massive problems in connecting to the wifi network under ground as well asin my own home as well as other homes.
    I can not change anything on the underground as it is the property of London Underground.

    I have three phones, S2, S3 and S4. The S4 works bad on all Wifi networks while the others are brilliant.
    I have the same problems on a BT (Brittish Telecom) as well as on a Virgin Media router as on a DLink router.
    07-28-2013 11:07 PM
  24. Cris Samai's Avatar
    hey, I was having same problem, I changed my 802.11 band from 2.4 Ghz to 5Ghz and the problem was solved, hope it works for you. Look for your wireless settings.
    08-08-2013 01:11 AM
  25. ibnbattuta's Avatar
    Hi, I've a D-link dir 655 firmware 1.31EU, 2010/01/14, and had similar kind of wifi connection problems with my new samsung galaxy s4 active as jim 1745 reports. I can also confirm that by switching the wifi router cipher protocol from "tkip and aes" to "tkip" my connection problems went away. fyi I run wpa mode "Auto (WPA or WPA2)", security mode "WPA personal", auto channel scan, transmission rate "best" and 802.11 mode "Mixed (n + g +b)".
    08-18-2013 10:37 AM
30 12

Similar Threads

  1. Samsung Galaxy S4 SD Card Issue
    By Joel Innard in forum General Help and How To
    Replies: 284
    Last Post: 02-23-2016, 06:14 AM
  2. Replies: 55
    Last Post: 10-31-2013, 10:41 PM
  3. Samsung Galaxy S4 to feature 5G WiFi
    By deesugar in forum Samsung Galaxy S4
    Replies: 2
    Last Post: 02-21-2013, 10:20 PM
  4. WIFI ERROR Samsung galaxy tab 7.0 plus wifi only
    By lycanknight in forum Samsung Galaxy Tab 7.0 Plus
    Replies: 8
    Last Post: 12-02-2012, 08:23 PM
  5. Samsung Galaxy Tab 10.1 16gb Wifi
    By Jrid32 in forum Marketplace Archive
    Replies: 18
    Last Post: 05-20-2012, 12:41 AM
LINK TO POST COPIED TO CLIPBOARD