11-12-2017 08:25 PM
69 123
tools
  1. whoiskevinrich's Avatar
    Your fix worked like a charm. Pesky cable all along. Thanks
    09-02-2013 09:08 PM
  2. Chris Vellrath's Avatar
    After connecting via USB and receive the message "connecting as installer" on your phone's screen, make sure you're phone isn't on the lock-screen and swipe down from the top (or at least on my Verizon device) you can access "USB PC connection" settings under the "ongoing" tab. Check one of two options, MTP or PTP. This would be the same pull-down where you would quickly alter various settings, view downloads and be able to link to recent notifications. This will effectively switch out of installer mode so that you can access your phone's directory and that of any sub sequential micro SD card. Hope this helps.
    09-05-2013 05:46 PM
  3. Adam Smithee's Avatar
    I have the same problem with Verizon S4, and solved with:

    in phone mode type *#0808#
    Choose : AP on upper part and
    for USB Setting, choose : MTP.

    Reboot, fine!
    I just wanted to say thank-you. I looked everywhere, in dozens of different threads, for a way to simply plug in my S4, and have it connect via MTP automatically. Now I don't have to tap on USB options and manually select MTP every time. Daaaayum!
    09-14-2013 03:57 AM
  4. steeger's Avatar
    im a service manager for sprint. type in the dial pad ##3424# click on the usb setting button and select the second option from the bottom this will fix the problem. your welcome
    09-17-2013 03:28 PM
  5. WEOD's Avatar
    Another thing to consider is the cable. I tried for days to connect and browse my S4 from my computer using a USB cable that shipped with a Samsung Galaxy S3. The S3 cable was connected from the computer to the S4 but it would not recognize the device. ...it would charge the battery but it would not allow me to browse it. Then it hit me that I never tried connecting it with the USB cable that originally shipped with the S4. Once I plugged it in, it immediately recognized the device, installed the drivers and allowed me to browse it.

    Also, be aware that if the phone is encrypted with a password, you may need to unlock the phone before the computer will recognize the device and make it browsable.

    Hope this information helps.

    This information is pertaining to a Verizon Galaxy S4 SCH-I545 16Gb Mist Black

    WEOD
    Mabel Mwaba likes this.
    09-24-2013 12:46 PM
  6. Michael Principe's Avatar
    for people having problem if its not the USB cable. Here is some solution

    1. Install the airdroid app on playstore (fix mtp cannot be installed and drivers)
    2. if phone is rooted,and found bugs that the mtp on *#0808# is not check even rebooted, go to recovery and clear dalvik cache (this error most problably occured if your phone is rooted) and also click the fix permission option
    10-01-2013 08:23 AM
  7. Mabel Mwaba's Avatar
    This was very helpful. My laptop could not recognise my galaxy s4. After reading this I decided to try the old Sony Ericsson cable and it in now working!!!!
    10-07-2013 04:38 AM
  8. Deejay_Soulless's Avatar
    I do tech support for T-Mobile and she was having this issue, i walked her through installing Kies but it still didnt recognize the device. Shes on a laptop so I know its not the wrong usb port, like the front vs back ports on a laptop
    10-15-2013 11:08 PM
  9. lancedal's Avatar
    No you aren't the only one!! I cannot connect either. No sign of phone when usb connection is used. Tried everyhting you have as well! Repaired Kies 4 times, not a blinking thing .............. PC doesn't even flicker when I connect the phone. USB port fine I use it to upload photos from my camera fine. Help screen on phone not helpful, keeps reiterating choose usb connection but doesn't give me an icon for it!!
    10-16-2013 10:27 AM
  10. STSVA's Avatar
    No you aren't the only one!! I cannot connect either. No sign of phone when usb connection is used. Tried everyhting you have as well! Repaired Kies 4 times, not a blinking thing .............. PC doesn't even flicker when I connect the phone. USB port fine I use it to upload photos from my camera fine. Help screen on phone not helpful, keeps reiterating choose usb connection but doesn't give me an icon for it!!
    On my phone after I connect to a USB port on my computer the USB connection options appear in a dropdown when I swipe the notification bar at the top of the screen. Also, perhaps it would help if you activate USB debugging in the Developer Options menu on the phone. That supposedly lets a Windows computer see the phone as an external drive.
    10-16-2013 02:32 PM
  11. pac4eva15's Avatar
    I have the same problem with Verizon S4, and solved with:

    in phone mode type *#0808#
    Choose : AP on upper part and
    for USB Setting, choose : MTP.

    Reboot, fine!
    After months of having this issue, this worked! Thank you!
    njabulo1980 likes this.
    10-16-2013 05:56 PM
  12. njabulo1980's Avatar
    Thank you so much a billion times you are a star pac4eva15.....God bless you.....
    10-21-2013 02:00 PM
  13. caiocesarja's Avatar
    already didi everything i could , and i'm not a noob in rooting and mobile costumizations, tried every ti , none of them worked, i'm almost giving up and taking it to customer care but as it is still in warranty i dont loose it, theres someese with another tip Please????

    Already :

    Installed drivers and kies , unistalled and rebooted
    Tried another PCS and cables , and tried my GF S3 in my pc and worked fine
    tried the *#0808# thing
    Debuging mode


    I'm in gt-i9505 rooted device! Pleaaaaaasee heeeelllppppp
    10-21-2013 09:34 PM
  14. Abdul Butt's Avatar
    Thank you BOSS !!
    I had this problem where the phone was not being detected by windows XP and your solutions did the TRICK.
    Thumbs UP Bro ..

    I have the same problem with Verizon S4, and solved with:

    in phone mode type *#0808#
    Choose : AP on upper part and
    for USB Setting, choose : MTP.

    Reboot, fine!
    10-22-2013 06:34 PM
  15. Steven Vavrek's Avatar
    /Agree : )

    I was having trouble getting my S4 to connect to my pc but once I plugged in the cable that CAME WITH THE PHONE it worked. Go figure
    10-29-2013 04:57 AM
  16. daveyoul's Avatar
    I had exactly the same problem.

    Ended up using a different USB port on the computer and everything worked fine.

    Originally I was trying to use one of the USB ports that remains powered even when the computer sleeps - and the same on my notebook dock. Neither of them worked, but then I swapped to a different regular USB port, and all worked as it should.
    11-07-2013 02:15 PM
  17. walexbounty's Avatar
    thanks so much.....this worked for me after spending countless hrs in search of solution.
    11-14-2013 03:15 AM
  18. Moreno Raveloson's Avatar
    Thanks for Your tuto. My phone is detected in my xp pc
    12-07-2013 07:51 AM
  19. aravind voonna's Avatar
    I have the same problem with Verizon S4, and solved with:

    in phone mode type *#0808#
    Choose : AP on upper part and
    for USB Setting, choose : MTP.

    Reboot, fine!

    I have followed the above setps and pc is able to detect my phone
    12-08-2013 11:35 PM
  20. Esiso Mefenaye's Avatar
    Thank Bro. U saved me from returning my GS4 from AT&T
    12-11-2013 12:40 PM
  21. jr0010's Avatar
    Changed to MTP mode with SG USB Mass Storage Enabler, rebooted. IDK why the drivers wouldn't load the phone all of a sudden, but whatever.
    01-08-2014 01:26 PM
  22. Tonya Riffe's Avatar
    I'm having the same problem with my daughter's phone. She can't download her music because the computer doesn't recognie her phone! Any help would be appreciated! Isn't it a simple thing to download music, or should be!?:-
    01-08-2014 04:59 PM
  23. Robb Goodrum's Avatar
    I found lotsa good ideas in this thread, but I think(?) there is something wrong with my S4?

    I've tried 3 different USB-cables on 2 different PC's across many ports. The kicker is that my wife's S4 works just fine on all the above. The *#0808# doesn't do much for me since I'm still stock and not rooted(?)

    One odd thing that I also notice is that when I do connect either USB-to-PC or USB-to-charger, is that there is a notification about "The dock is connected" ???

    Any further pointers would be greatly appreciated.

    thx,
    ~~Robb
    03-25-2014 11:20 PM
  24. metle_geek's Avatar
    You mentioned that you connected it to a computer earlier in 4.2.3 and up you have an rsa key you need to reset it as it wont connect to other computers... settings< more< developer options< revolk usb debugging authorizations


    must have unlocked boot loaders!!
    03-26-2014 07:33 AM
  25. austin da kasin's Avatar
    05-13-2014 09:22 AM
69 123

Similar Threads

  1. pc can't detect phone
    By Atomic_Monkey in forum Thunderbolt Rooting, ROMs, and Hacks
    Replies: 35
    Last Post: 01-25-2016, 10:01 AM
  2. Galaxy S4 - Where can I get these widgets?
    By felloffthetruck in forum Samsung Galaxy S4
    Replies: 3
    Last Post: 04-30-2013, 06:45 PM
  3. Replies: 2
    Last Post: 04-01-2013, 12:11 PM
  4. Need to relock Bootloader but PC can't see my Galaxy Nexus
    By famasfilms in forum Google / Samsung Galaxy Nexus
    Replies: 6
    Last Post: 11-04-2012, 05:34 PM
  5. can't detect galaxy on SWM
    By apgomez85 in forum T-Mobile Galaxy S II
    Replies: 0
    Last Post: 10-14-2011, 05:52 PM
LINK TO POST COPIED TO CLIPBOARD