1. Ranger Danger's Avatar
    Got the S4 on launch day and noticed both Google maps and Waze wouldn't always work. Sometimes they would and sometimes not. Then at some point, 14 days after I had the phone (past the return policy window), the GPS stopped working completely. I did a complete reset and got it to work for a short period of time but then it crapped out again. AT&T is sending me out a new phone. Well a "like new" phone. They said it's most likely new because the S4 is a recent handset. Has anyone else experienced any GPS chip issues? I can't keep doing a full reset on my phone because the GPS isn't working. I sure hope this "like new" phone doesn't have this problem.
    homestead likes this.
    05-30-2013 12:38 AM
  2. Ranger Danger's Avatar
    Hello? No one has been having GPS issues? Really? I guess I got a bad chipset in mine.......
    05-30-2013 12:14 PM
  3. GB333's Avatar
    I honestly haven't even used it yet. I just got my (Verizon) phone last week. But since I read this thread - I turned on the GPS, went to maps, and directed it to find me on the map. It says my current GPS location is unavailable. That is worrisome! I'm going to look into it some more.

    EDIT: Went to the Nav app and it seemed to work fine. Sorry you got a bum phone! I hope you get your replacement soon!
    05-30-2013 12:21 PM
  4. videian's Avatar
    My issue is that when I use an app like waze, it will not activate the gps, sits there and says no gps even tho the gps option is turned on. I have to physically switch it off then back on and it pops right in almost immediately.

    Wtf?

    Sent from my SAMSUNG-SGH-I337 using Tapatalk 2
    05-30-2013 12:51 PM
  5. t073's Avatar
    No GPS problems here, I have used my phone to log runs, bike rides and navigate with the GPS and it has worked fine.
    Looks like you might have just received a dud, hopefully the next one will work.
    05-30-2013 12:54 PM
  6. Infinity's Avatar
    05-30-2013 01:11 PM
  7. thepktrckt's Avatar
    I'm having a very similar issue as well with my 32GB AT&T S4. I had both my Note and S4 in my car today and the Note 2 worked perfect while the S4 worked great and then would just start bouncing all over and lose GPS signal often. I haven't read through all the threads yet but I wanted to say you aren't alone.
    05-30-2013 04:29 PM
  8. Bright Harry's Avatar
    My issue is that when I use an app like waze, it will not activate the gps, sits there and says no gps even tho the gps option is turned on. I have to physically switch it off then back on and it pops right in almost immediately.

    Wtf?

    Sent from my SAMSUNG-SGH-I337 using Tapatalk 2
    I had the same issue and I found that Yahoo Weather was the cause. Just uninstalling Yahoo Weather fixed the issue. Hope this helps.
    06-24-2013 02:11 AM
  9. ihbsbA's Avatar
    I had the same issue and I found that Yahoo Weather was the cause. Just uninstalling Yahoo Weather fixed the issue. Hope this helps.
    Just read a long thread about Yahoo weather being the culprit. Uninstall it.

    Sent from my Galaxy S3 using Tapatalk.
    06-24-2013 08:38 AM

Similar Threads

  1. My Nexus has been disabled....So my question is
    By AndroidFanatic84 in forum Google Nexus 7 Tablet (2012)
    Replies: 3
    Last Post: 10-22-2012, 05:19 PM
  2. My GPS is not working like ec22 since ec30! :)
    By prEvo in forum Sprint Epic 4G
    Replies: 3
    Last Post: 01-27-2012, 07:31 PM
  3. My TBOLT IS BROKEN!
    By androidjake in forum Verizon HTC Thunderbolt
    Replies: 4
    Last Post: 06-03-2011, 06:27 PM
  4. Help! My Phone Is Broken! stuck at hboot screen
    By Gabezermeno in forum Verizon Droid Incredible
    Replies: 5
    Last Post: 05-25-2011, 05:06 PM
  5. My GPS is stilll miserable
    By brb198#AC in forum Verizon HTC Thunderbolt
    Replies: 3
    Last Post: 05-12-2011, 09:33 PM
LINK TO POST COPIED TO CLIPBOARD