1. ThePremier's Avatar
    Does anyone else have problems with the YouTube app not loading videos all the way? Videos will get half way (if that) and then just stop. Like it will be frozen. Regardless if I am on wi-fi, 4G or 3G.

    I know it is not just my Galaxy S4 because I had this exact same issue with my iPhone 4S before I got the galaxy. It is actually becoming a very bad annoyance which is pissing me off. Does anyone know of a solution, have this same issue or know why the YouTube app sucks in general? Thanks.

    Sent from my SAMSUNG-SGH-I337 using Android Central Forums
    05-31-2013 10:26 AM
  2. ThePremier's Avatar
    Anyone?...

    Sent from my SAMSUNG-SGH-I337 using Android Central Forums
    06-03-2013 02:15 PM
  3. DreamSTi's Avatar
    Happens from time to time for me on all of my devices, definitely a YouTube issue.
    20blks likes this.
    06-03-2013 02:16 PM
  4. OhAlfie's Avatar
    Happens to me on pretty much every phone I've had, iphone, S3, now S4. My kids Nabi tablet also has YT freeze up numerous times while trying to play even the shortest clip.

    It doesn't matter if I'm a mega download router or a 3mb download household router, it all freezes multiple time.

    Very frustrating.
    06-03-2013 02:17 PM
  5. ThePremier's Avatar
    Thanks for replies. Glad to hear I'm not the only one or losing my mind lol!!! Thanks again.

    Sent from my SAMSUNG-SGH-I337 using Android Central Forums
    06-03-2013 04:24 PM
  6. SpookDroid's Avatar
    Mine is having issues but with 4G only...if I switch to 3G or WiFi, I can watch videos with no problem. But going into 4G, most videos won't play (Connection to server lost, touch to retry). It's really weird but it seems the problem is on Google's end, because it used to work fine...
    06-03-2013 04:42 PM

Similar Threads

  1. playing youtube videos in browser?
    By gabe3 in forum HTC Hero
    Replies: 1
    Last Post: 11-16-2009, 03:36 AM
  2. Deleting user account on Youtube app
    By kkwan77#AC in forum Motorola Droid
    Replies: 1
    Last Post: 11-11-2009, 10:15 AM
  3. youtube problem
    By slosh in forum Motorola Droid
    Replies: 8
    Last Post: 11-10-2009, 10:40 PM
  4. Youtube videos?
    By ICON76 in forum HTC Hero
    Replies: 11
    Last Post: 10-29-2009, 11:01 PM
  5. Uploading To Youtube??? Camera Lacking!!!
    By ticklemepinks in forum HTC Hero
    Replies: 10
    Last Post: 10-12-2009, 05:55 PM
LINK TO POST COPIED TO CLIPBOARD