1. bluepumpkin87's Avatar
    Hey guys,

    I'm sure that this has probably been talked about before but i just couldn't find exactly what i need in any of the forums.
    I'm having a problem with my S2, i just cannot get any data signal, normal signal is fine. It's saying it's connected to data signal, i have tried resetting the Access Point back to default, turning flight mode on and off, turning the phone on and off, taking out the battery, taking out the sim card, i have deleted some apps because i thought maybe one of them was causing an issue... i think however it may be down to Juice Defender, which i have now seen can cause people many problems. This app has been deleted... Not really sure what to do next.

    Could anyone help me out with this, because i would like to try everything before doing a factory reset. I've had the phone a while so there is a lot of stuff on it and i know you can back it all up but it still makes me nervous to reset the whole phone, and then it still might not even work after that. I don't even know if it's the phone or the network.

    Please help before i go mad from not being able to fix this!

    Thanks in advance.

    Kayleigh
    06-04-2013 09:52 AM
  2. Almeuit's Avatar
    You are in the S4 section not the S2 .

    But anyway.. What carrier? When did the data start dropping?

    Sent from my Sprint S3 using AC forums.
    06-04-2013 09:52 AM
  3. neebi007's Avatar
    Uk 3 network had a data outage since last night but its sorted now... everything working ok.

    Sent from my GT-I9300 using Tapatalk 4 Beta
    06-04-2013 10:01 AM
  4. bluepumpkin87's Avatar
    Thanks, but mine has not been working all day and still isn't. It's still saying connected but there's no 3g signal. I'm not sure if what's affecting it now is that in the access point names bit, there is nothing written there anymore... could that maybe be why it's still not working?
    06-04-2013 10:32 AM
  5. bluepumpkin87's Avatar
    I have managed to put the APN back on but it's still not connecting to the internet...
    06-04-2013 10:42 AM
  6. neebi007's Avatar
    Thanks, but mine has not been working all day and still isn't. It's still saying connected but there's no 3g signal. I'm not sure if what's affecting it now is that in the access point names bit, there is nothing written there anymore... could that maybe be why it's still not working?
    Some times taking out your battery and removing sim card then replacing Every thing back after few minutes resets network and everything works.

    《★Nbz★》
    06-09-2013 07:03 AM

Similar Threads

  1. Replies: 1
    Last Post: 02-10-2013, 08:33 AM
  2. Help my Samsung Galaxy s2, got problem unknown baseband and imei
    By sorsaopiseth71 in forum Samsung Galaxy S II
    Replies: 6
    Last Post: 08-14-2012, 03:32 PM
  3. Unethical review of T-mobile Samsung Galaxy S2 by Android Police
    By Thomasdoc in forum T-Mobile Galaxy S II
    Replies: 21
    Last Post: 04-09-2012, 08:11 PM
  4. T-mobile Samsung Galaxy S2
    By fallensoulja in forum Samsung Galaxy S II
    Replies: 1
    Last Post: 07-21-2011, 03:45 PM
  5. T-Mobile to carry Samsung Galaxy S2
    By grayfox99 in forum General News & Discussion
    Replies: 2
    Last Post: 04-30-2011, 09:44 PM
LINK TO POST COPIED TO CLIPBOARD