1. kladysandroid's Avatar
    I am trying to do this on a number of apps until the WiFi at my home is fixed (to avoid Verizon's mobile charges). I don't seem to be doing it correctly (Settings-More-App Manager-then uncheck Notifications and Disable (if Possible). For example, Samsung's WatchOn automatically updated when I turned on my phone this morning, despite the fact that notifications isn't checked. What am I doing wrong?

    Also, is it possible to set it so that nothing updates unless I'm connected via WifFi, or is that simply wishful thinking?

    Thanks.
    06-05-2013 07:35 AM
  2. SpookDroid's Avatar
    You have to configure it in two places:

    1) Google Play apps (the general app world in your phone). Go into Google Play Store, go to Settings, and make sure that "Automatically Update Apps" is not selected and you can even restrict that to WiFi only.

    2) Samsung Updates. This is where your Sammy-sanctioned updates for system files and stuff happens. Go into Settings, select the "More" tab, scroll down to "About Device", then click on "Software Update". There, you can go into the settings and tell it not to auto-update and, again, restrict these updates to WiFi only.

    Oh, by the way, what you did by disabling notifications on the App Manager only disables the app's ability to notify you in the background and you might not want that... Also, if you disable the app, it is completely 'frozen', meaning you can't use it anymore until you re-enable it.
    06-05-2013 07:39 AM
  3. EvilMonkey's Avatar
    I am a bit confused on what you're trying to accomplish. I think you might be mixing up some terms. Which of these are you trying to do?

    1. Notifications: These are simple either pop up messages or things that appear in the notification bar. It has nothing to do if an up actually is using mobile data or not (for example, you can disable email notifications showing up there, but it's still checking to see if you have email....just not telling you that you do).
    2. App Updates: Do you mean the app itself is being updated (from the Play Store....as in there's a new version of the app)? If so, then you have to go to the app on the Play store, then press menu, and you'll see a checkbox for "auto-update" that you need to make sure is unchecked. You can also go to Menu->Settings and make sure the auto-update is unchecked there (and there is an additional option here to only update them on WiFi which is what you may want). I think there is another setting for Samsung apps since they are outside the Play store, and you should be able to find those within the Samsung settings somewhere (sorry...not sure where)
    3. Data Sync: This would mean the apps are actually connecting to the internet to get data (checking email, Facebook updates, Words with Friends notifcations, etc). If you want to stop that and you only want to use WiFi, then pull down the notification bar from the top, and click on "mobile data" so it's not green (I am assuming Touchwiz on the GS4 is the same as my GS3).
    06-05-2013 07:46 AM
  4. kladysandroid's Avatar
    You have to configure it in two places:

    1) Google Play apps (the general app world in your phone). Go into Google Play Store, go to Settings, and make sure that "Automatically Update Apps" is not selected and you can even restrict that to WiFi only.

    2) Samsung Updates. This is where your Sammy-sanctioned updates for system files and stuff happens. Go into Settings, select the "More" tab, scroll down to "About Device", then click on "Software Update". There, you can go into the settings and tell it not to auto-update and, again, restrict these updates to WiFi only.

    Oh, by the way, what you did by disabling notifications on the App Manager only disables the app's ability to notify you in the background and you might not want that... Also, if you disable the app, it is completely 'frozen', meaning you can't use it anymore until you re-enable it.
    Thanks. It's worked in the PlayStore. The other doesn't work for me because I don't have a settings option after I hit Software Updates in "About Phone". It just tells me the status and the last time the status was checked and gives me the opportunity to "Check New". hmm.
    06-05-2013 07:47 AM
  5. kladysandroid's Avatar
    Thanks. It's Item 2. When I turned on my phone the Samsung WatchOn app automatically updated. I'm assuming there's a data charge for that while on Mobile Data, so I'd like to set it so that it only updates while connected to WiFi. I figured it out for apps from the Play Store, but not for the Samsung Apps.
    06-05-2013 07:54 AM

Similar Threads

  1. Automatic Updating Apps
    By snppr22 in forum Motorola Droid X
    Replies: 8
    Last Post: 04-22-2011, 09:08 PM
  2. Weather Won't Automatically Update Anymore
    By DD917 in forum Verizon HTC Thunderbolt
    Replies: 6
    Last Post: 04-10-2011, 10:14 AM
  3. How to prevent OTA updates
    By Upstreammiami in forum Incredible Rooting, ROMs, and Hacks
    Replies: 2
    Last Post: 12-13-2010, 05:16 PM
  4. Replies: 5
    Last Post: 09-02-2010, 08:43 PM
  5. Automatic Updates Not...Updating?
    By Tattrpuff in forum HTC EVO 4G
    Replies: 11
    Last Post: 08-26-2010, 08:38 AM
LINK TO POST COPIED TO CLIPBOARD