1. maxrmnf's Avatar
    I have a Samsung S4 connected to a Prius via Bluetooth. When ever I'm on the phone the people who I am talking to sound like they are underwater! I tried re pairing the Bluetooth still not working. what should I do?
    06-25-2013 12:53 PM
  2. Zod1010's Avatar
    Agreed. I've had a Droid X, a Droid RAZR and the HTC One that all connected without issues. The S4 is **** poor at handling Bluetooth. Slowly starting to regret trading my HTC One in for this. I really hope the update fixes a few things.
    06-25-2013 01:16 PM
  3. OhAlfie's Avatar
    No such issues with my S4 nor it's Bluetooth.
    06-25-2013 01:38 PM
  4. Zod1010's Avatar
    No such issues with my S4 nor it's Bluetooth.
    Then you're lucky. It's a recurring theme with these phones, that I've seen on different forums, and it shouldn't be.
    06-25-2013 03:09 PM
  5. OhAlfie's Avatar
    Then you're lucky. It's a recurring theme with these phones, that I've seen on different forums, and it shouldn't be.
    What is? The "underwater sound"?
    06-25-2013 03:26 PM

Similar Threads

  1. [Closed] Win 1 of 2 Samsung Modus 6450 Bluetooth headsets
    By Bla1ze in forum Android Central Contests
    Replies: 3
    Last Post: 01-17-2014, 12:58 AM
  2. xProDock for Samsung - Bluetooth Question
    By cceller in forum Verizon Samsung Galaxy S4
    Replies: 6
    Last Post: 07-12-2013, 03:03 PM
  3. Samsung Nexus (GT-I9250) Stops by Bluetooth SIG
    By nemov in forum Verizon Galaxy Nexus
    Replies: 26
    Last Post: 09-27-2011, 04:34 PM
  4. Samsung WEP870 Bluetooth headset and the EVO
    By whats77inaname in forum EVO Accessories
    Replies: 0
    Last Post: 07-28-2010, 11:03 PM
  5. Samsung bluetooth headset issues
    By gewcmr in forum Motorola Droid
    Replies: 1
    Last Post: 02-22-2010, 11:30 AM
LINK TO POST COPIED TO CLIPBOARD