1. cr6789's Avatar
    I just got a Samsung Galaxy S4 a few weeks ago. The issue I'm having if my Wi-Fi is not shutting off automatically when the phone goes to sleep even though I have set it to do this under Wi-Fi advanced settings. I have disabled all GPS and Google location settings, as well the network notification option in settings but this does not help. I would be grateful for any suggestions. Thanks.
    08-09-2013 08:56 PM
  2. HPferoxCraft's Avatar
    Go under settings, tap wifi, tap smart mode, if that's on turn it off.

    Posted via TriForced Sprint GS4
    08-09-2013 09:10 PM
  3. cr6789's Avatar
    I don't have a smart mode setting on my phone. Anything else it could be? Thanks.
    08-09-2013 09:23 PM
  4. HPferoxCraft's Avatar
    When you are in settings and hit wifi you don't see this? What s4 do you have?
    Attached Thumbnails wi-fi-screenshot_2013-08-09-22-30-15.jpg   wi-fi-screenshot_2013-08-09-22-29-52.jpg  
    08-09-2013 09:35 PM
  5. cr6789's Avatar
    It shows "To see available networks, turn on Wi-Fi", but there is no smart mode option. My model is SGH-1337M and I have it through a Canadian carrier.
    08-09-2013 09:46 PM
  6. HPferoxCraft's Avatar
    Ok so that's not it. I'm guessing there's an app somewhere that is triggering wifi while it's sleeping then. Not sure which one but maybe an app like wakelock detector can help you figure it out.

    https://play.google.com/store/apps/d...detector&hl=en

    I'm not thinking router related because I'd think it would have the opposite effect. So my money's on an app causing it. Sorry I can't pinpoint it for you.

    Posted via TriForced Sprint GS4
    08-09-2013 10:36 PM
  7. tytlyf's Avatar
    Go into the Settings > Wifi again and pull up the settings for the Wifi Screen (button next to home button). From there select advanced.
    08-10-2013 11:41 AM
  8. cr6789's Avatar
    Thanks for the replies. I actually exchanged the phone since today was the last day I could. I thought there might be a hardware issue. But the new phone does the same thing, so either it's the software or my router.
    08-10-2013 05:43 PM
  9. tytlyf's Avatar
    This is the screen you should see by going into the Wifi and opening it's advanced settings.

    08-11-2013 09:58 AM
  10. HPferoxCraft's Avatar
    What's the router brand? I'm guessing, since you said you changed it in advanced settings, you chose 'never' in the keep wifi on while sleep tab?
    I'm still leaning toward an app keeping this on.
    Maybe gps or an apps location function is enabled.
    Does your advanced screen look like the above poster, or do you also have a wifi timer option?
    If not maybe this app could help.

    https://play.google.com/store/apps/d...ifitimer&hl=en

    Posted via TriForced Sprint GS4
    08-11-2013 10:28 AM

Similar Threads

  1. Fix For Nexus 4 4.3 5ghz Wi-Fi issue
    By Tyler555 in forum Google Nexus 4
    Replies: 23
    Last Post: 03-11-2015, 06:15 PM
  2. Wi-Fi stops working on Nexus 4
    By billdz in forum Google Nexus 4
    Replies: 10
    Last Post: 08-23-2013, 11:41 AM
  3. My EVO 3D won't connect to home WI-FI
    By Irene Sheridan in forum HTC EVO 3D
    Replies: 1
    Last Post: 08-05-2013, 07:58 PM
  4. Wi-Fi connection problem for my HOX
    By Atikur Rahaman in forum HTC One X
    Replies: 1
    Last Post: 08-04-2013, 12:38 AM
  5. Wi-fi turns on by itself......
    By txfarmboy in forum Sprint Galaxy S III
    Replies: 5
    Last Post: 08-03-2013, 07:43 AM
LINK TO POST COPIED TO CLIPBOARD