1. Nathanael Fernandez's Avatar
    Every time I try to connect my galaxy s4 to my laptop as a media device it connects and charges but not as a media device. On the drop down notifications it says its docking and I get a docking icon at the top of my phone. I know its not the cord because I tried it with my brothers galaxy s4 and it instantly connected as a media device. Even though my laptop couldnt see any of the two, my brothers s4 still connected as a media device and the laptop showed a notification message saying that it could not recognize the device. Then when I plug my s4 in, it charges and goes into docking mode (nothing happens on the laptop). What can I do? Please help are there any solutions?
    08-16-2013 12:03 PM
  2. adsthedevil's Avatar
    I also have this problem.
    GT-I9505, android 4.2.2, I9505XXUBMEA
    I tried lots of things but I narrowed my connection problem down as my phone itself is not "Connecting as a Media Device"
    My phone informs I have the latest software, but when I insert the USB cable, it acknowledges with a beep, and the PC finds and connects it, but the Phone has no message saying it is connected.
    The PC does not show the phone as hard drive or anything.
    I need to tell the phone to "Connect as Media Device" when inserting teh USB cable, but I have no idea how to achieve this.
    08-24-2013 03:13 AM
  3. PdhPhd's Avatar
    I had the same problem. I decided to try Samsung Kies. I happened to have the phone connected when I installed Kiies and it did all the magic necessary and now when I hook up the phone it connects as a media device without having to run Keis.
    08-24-2013 08:17 AM
  4. Darnell0216's Avatar
    Make sure you guys are installing the Samsung Drivers. You need them to connect your phone to the PC. Our S4's do not connect as the old school "Mass Storage Device" that connects it as a removable drive and doesn't require drivers. Go here and click the Downloads tab: Support - Sprint Cell Phones SPH-L720 | Samsung Cell Phones

    And no worries, the drivers are the same for all versions of the S4 Device(Install),USB Driver (Software) (ver.v1.5.14.0). Kies installs this driver by default, which is why PdhPhd was able to successfully connect.
    08-24-2013 09:31 AM

Similar Threads

  1. Samsung Galaxy Tab 2 10.1 recharging problem
    By altair42 in forum Samsung Galaxy Tab 2 10.1
    Replies: 2
    Last Post: 11-29-2013, 01:11 PM
  2. beans rom galaxy note 2
    By 11cfcblues11 in forum Verizon Galaxy Note 2
    Replies: 5
    Last Post: 08-23-2013, 04:58 PM
  3. my samsung galaxy s3 problems
    By krissey in forum Samsung Galaxy S3
    Replies: 8
    Last Post: 08-17-2013, 11:52 AM
  4. GS3 not staying connected to wi-fi
    By SSDCarroll3 in forum US Cellular Galaxy SIII
    Replies: 0
    Last Post: 08-16-2013, 11:51 AM
  5. how to play the usb hdd on lg g pro? pls help....
    By Sumon Baisya in forum LG Optimus G Pro
    Replies: 0
    Last Post: 08-16-2013, 11:23 AM