1. GamerSheh's Avatar
    My S4 wont register on my network (Fido) it even detects it. I tried it with 3 lte sims from fido and the sims work on other phones. The phone has a unblocked IMEI also it gets signals. Just wont connect. I tried hardbooting it. Any suggestions?
    10-05-2013 06:59 PM
  2. dancing-bass's Avatar
    First of all, if you purchased the phone from Telus, return it and get a new one.

    If you purchased it 2nd hand, it may be locked due to an unpaid bill. If this is the case you're pretty much screwed until the bill is caught up.

    Either way, I'm guessing a trip to your nearest Telus store or outlet is in your future!
    10-06-2013 06:45 PM
  3. GamerSheh's Avatar
    Hey, I bought it from Fido and they said theres a problem with the phone... It even connects to the towers and get signals. I dont know what the problem could be. Also the phone is not locked.
    10-06-2013 08:51 PM
  4. GamerSheh's Avatar
    Fido said they would lock the account not the phone. The phone has a clean IMEI. Any suggestions?
    10-06-2013 08:55 PM

Similar Threads

  1. Micro SD Card Size for the S4?
    By K Williams in forum Samsung Galaxy S4 Accessories
    Replies: 32
    Last Post: 01-31-2014, 06:04 PM
  2. Question on 4.3 after install
    By les7699 in forum HTC One M7
    Replies: 6
    Last Post: 10-10-2013, 05:27 PM
  3. What's your opinion on 10 inch tablets?
    By chowdog13 in forum General News & Discussion
    Replies: 10
    Last Post: 10-08-2013, 02:54 PM
  4. Verizon galaxy note 3 in best buy on the release date of 10/10
    By Nicole Simmons in forum Samsung Galaxy Note 3
    Replies: 2
    Last Post: 10-05-2013, 10:41 PM
  5. battery drainage issue PLEASE HELP :(
    By nicole ande in forum Samsung Galaxy S3
    Replies: 6
    Last Post: 10-05-2013, 07:57 PM
LINK TO POST COPIED TO CLIPBOARD