1. kingtech's Avatar
    I have two Exchange accounts for work and using the stock mail app with just one account works great. When the second is added though it goes haywire, showing emails from the first account in the second and tons of emails from both are just plain missing. Even when going into the second account (not viewing the combined inbox) it is displaying emails from the first. Remove the second account and everything is back to normal. Anyone else experiencing this and is there a fix?
    10-09-2013 09:54 AM
  2. krnldude's Avatar
    I'm seeing that same thing on my new galaxy note 3. Here's what found:

    1) The password storage type on the server was set to SHA1 which the android client does not support. (I was having the same issue in the eMClient desktop mail application showing the same data for the two different accounts). This is probably not causing you an issue.
    2) I was using the same password for both accounts. (I changed on of them). As you will see in minute, this is why both accounts showed the same data.

    Once I changed the pasword in one account and disabled SHA1 password storage, the eMClient mail application does now shows the correct mail information for each account. However the android client is not longer able to login successfully on the second account. Looks at logs on the mail server I found that the android mail client is sending the WRONG username for the second account. It's sending the username of the first account, but the password for the second account! So if your passwords are the same, then you get the same data in both.

    This is a HUGE bug in the android mail client. Obviously multiple accounts are not part of their QA test matrix. It's not really enterprise ready apparently.
    10-23-2013 02:04 AM
  3. kingtech's Avatar
    I agree. It doesn't make much sense to me that they obviously intended to make it capable to access more than one Exchange account but I would think in QA this should have been a glaring problem. Not sure how they overlooked this.
    11-20-2013 08:49 AM

Similar Threads

  1. Surprised the Galaxy Gear works with the s4
    By shanezam203 in forum Samsung Galaxy Gear
    Replies: 14
    Last Post: 12-01-2013, 03:15 PM
  2. Multiple processes open
    By MGW1138 in forum Google Chromecast
    Replies: 2
    Last Post: 10-14-2013, 11:45 AM
  3. Samsung Galaxy S4 16GB (AT&T) Black Mist w/ 32GB sd card
    By scorpiodsu in forum Marketplace Archive
    Replies: 2
    Last Post: 10-13-2013, 11:42 AM
  4. Replies: 2
    Last Post: 10-09-2013, 12:19 PM
  5. Problems with charging a Samsung Galaxy S4
    By Jenje in forum Samsung Galaxy S4
    Replies: 5
    Last Post: 10-09-2013, 11:36 AM
LINK TO POST COPIED TO CLIPBOARD