08-08-2021 11:00 PM
29 12
tools
  1. manda0413's Avatar
    Hi there!

    I frequently enter giveaways, contests, and sign up to receive freebies through different websites. Sometimes, a website will post that if I text a number, for example "467467" with a keyword, I will receive whatever product is being given away. Or for example, if I want to follow someone on Twitter through SMS, I can send a message to 40404.

    However, one day last week, I was trying to sign up to receive a freebie from my phone, sending it to a number similar to my examples above. It popped up a message and said I might be charged (as it usually does). This time, I checked a box that said "Remember my answer" and I clicked way too fast and accidentally blocked myself from sending a message to these types of numbers.

    Now, whenever I try to send a message to a number like above, it fails immediately. I've looked all through my phone settings, message settings, even my account settings online and I cannot figure out how I can change this option.

    Does anybody know what I can do?

    Thanks!
    missy adams likes this.
    10-10-2013 09:28 AM
  2. VDub2174's Avatar
    Have you tried clearing the cache for the messaging app?
    10-10-2013 01:27 PM
  3. manda0413's Avatar
    It took me a bit more googling this morning after I posted this, and I finally found my answer on a T-Mobile forum (even though I have Verizon). I had blocked myself from Premium Messaging and the forum had a short tutorial on how to fix it.
    10-10-2013 02:48 PM
  4. VDub2174's Avatar
    Good deal

    Sent from my AT&T GNote 2 on top of a Beanstalk
    10-10-2013 03:03 PM
  5. mommito4's Avatar
    I've also done this today & can't find how to unblock myself please could u help??
    12-29-2013 01:58 PM
  6. vbaezan's Avatar
    04-22-2014 12:55 PM
  7. Jane deaux's Avatar
    I know this is old. However I would like to provide the answer in case someone else finds themselves here without an answer as I did.

    Galaxy S5. Im sure with a little wisdom, this can be used on most newer androids.

    Go to Settings>
    Application manager>
    scroll over to All >
    scroll down to messaging>
    scroll down to permissions>
    make your selection. Allow all, ask, or do not allow.
    12-02-2015 11:04 AM
  8. LukeBrown55's Avatar
    Has anyone got any solutions for the same problem but galaxy s7?
    03-23-2016 03:07 PM
  9. Ladycairistiona's Avatar
    Has anyone got any solutions for the same problem but galaxy s7?
    I'm having the same problem and can't find a solution.
    05-13-2016 06:33 PM
  10. joseph234's Avatar
    I found out the way to turn on again about asking premium sms with SAMSUNG S7
    setting->app manager, them choose MORE, SHOW SYSTEM APP, them you should scroll down to find Message Service, tap on it. And you will see its permissions "Send premium text message"
    07-22-2016 03:48 PM
  11. lyfsabeach's Avatar
    Thank you for posting this - I did the same thing this morning and the above instructions weren't working for my S6 - but yours did!!! All is well again!
    08-06-2016 09:58 AM
  12. Sarah Zamora's Avatar
    joseph234's
    Posts2 Posts
    I found out the way to turn on again about asking premium sms with SAMSUNG S7
    setting->app manager, them choose MORE, SHOW SYSTEM APP, them you should scroll down to find Message Service, tap on it. And you will see its permissions "Send premium text message"

    I wanted to let everyone know that I tried this on my J7 Samsung and it worked. I tried call the mobile company ( Metro PCS) and They were no help at all. They told me to keep turn off and on my phone for the phone to reset.
    I followed the directions Joseph234's posted and they worked great.
    10-31-2016 01:06 PM
  13. MOBAD8004's Avatar
    it took me a bit more googling this morning after i posted this, and i finally found my answer on a t-mobile forum (even though i have verizon). I had blocked myself from premium messaging and the forum had a short tutorial on how to fix it.
    hi can you share the link to unblock a number i did the with by accident i cant find anything in my settings.
    Thank you m.
    03-05-2017 03:42 AM
  14. rongweaver's Avatar
    Has anyone got any solutions for the same problem but galaxy s7?
    So i figured out with the new android update ( v7,0) you go to app manager then hit the settings at the top right with the three dots and its under "special Access" from there you can access premium text message services. not from the message service app. so with the new update on android, every post has it wrong. took me a while but i got it. goood luck.
    Adzrhino, AnnKenyan and andytheguv like this.
    04-10-2017 02:00 PM
  15. Adzrhino's Avatar
    So i figured out with the new android update ( v7,0) you go to app manager then hit the settings at the top right with the three dots and its under "special Access" from there you can access premium text message services. not from the message service app. so with the new update on android, every post has it wrong. took me a while but i got it. goood luck.
    You are my hero! I had to sign up just to thank you. I've been blocked since I got the phone as a replacement for my Note7 last year. Thank you!
    missy adams likes this.
    05-11-2017 09:17 AM
  16. NATALIE222's Avatar
    I've tried with the best of my best abilities to follow this, but I have a different type of phone. I have the same problem, though my phone is a ZTE ZMAX PRO. Please someone help me with this!!!
    09-24-2017 05:15 AM
  17. missy adams's Avatar
    I have a Samsung Galaxy S8 and havent been able to reply back to any of my bank, ppal or promo texts for months! Thank you! 💜💜💜

    *So i figured out with the new android update ( v7,0) you go to app manager then hit the settings at the top right with the three dots and its under "special Access" from there you can access premium text message services. not from the message service app. so with the new update on android, every post has it wrong. took me a while but i got it. goood luck.
    ibrahim balci likes this.
    07-20-2018 03:15 PM
  18. AnnKenyan's Avatar
    Thank you so much. This is the only thing that has worked after months of looking for answers.
    08-06-2018 06:09 AM
  19. gardenHeather's Avatar
    So i figured out with the new android update ( v7,0) you go to app manager then hit the settings at the top right with the three dots and its under "special Access" from there you can access premium text message services. not from the message service app. so with the new update on android, every post has it wrong. took me a while but i got it. goood luck.
    THANK YOU!!!! FINALLY! You have no idea how many months I've been trying to get that fixed.
    08-30-2018 04:08 PM
  20. Crystal Pelleymounter's Avatar
    I've tried this and when I tap on 'use premium text message services' It tells me I have 'no applications'

    There is nothing for me to select. I have no idea what to do at this point.
    09-08-2018 12:56 AM
  21. 21hcassel's Avatar
    I was having this problem with my AT&T Samsung Galaxy S7 and the way I fixed it was a little different:

    I opened my phone and went to SETTINGS -> Applications, then i clicked on the three dots on the corner and hit SPECIAL ACCESS. After that the third from the bottom choice said USE PREMIUM TEXT MESSAGE SERVICES and i hit the and hit ASK. That fixed the problem.
    10-01-2018 08:15 AM
  22. PattiCakesOhio's Avatar


    I read ALL of these posts and responses and have been working on this for an hour and a half straight with no luck. People would say go to this go to that but the same words or options just were not there! I may not be a technician but I'm not a dingbat.

    Then resolved it in 10 seconds with this email. There is a God!

    And yes I went through the whole rigmarole of five minutes of verification just to get on here to share this video.

    I hope watching this video help somebody be as happy as I am right now. 😁🤗
    Rcwamw likes this.
    10-31-2018 12:05 AM
  23. Rcwamw's Avatar
    Thank you so much Sprint upended texting which has me resigning up for everything! Then they wanted to do a hard reset and 3 minutes after watching video I fixed problem!!
    I do wish I could hug you right now!!!
    11-01-2018 12:50 AM
  24. Kimann76's Avatar
    I had to sign up just to say THANK YOU!! I've been trying to fix this issue for months, I've read so many posts and did everything but a factory reset because I was afraid of losing everything on my phone!! It took me less than 10 seconds to follow these instructions and it worked instantly!! Again thank you so so much!! I am forever grateful!!
    01-21-2019 12:40 PM
  25. Jodee6969's Avatar
    It took me a bit more googling this morning after I posted this, and I finally found my answer on a T-Mobile forum (even though I have Verizon). I had blocked myself from Premium Messaging and the forum had a short tutorial on how to fix it.
    How did you fix it. I did the same thing.... Please help
    06-21-2019 12:14 PM
29 12

Similar Threads

  1. Droid Mini - Cant find anything to fit the 3.5mm headphone jack
    By dmagic17 in forum Motorola Droid Mini
    Replies: 4
    Last Post: 10-26-2013, 02:01 AM
  2. Replies: 7
    Last Post: 10-16-2013, 08:40 AM
  3. Replies: 2
    Last Post: 10-11-2013, 11:27 AM
  4. US Cellular S3 - Certain headphones won't work anymore.
    By Kaleel Soares in forum US Cellular Galaxy SIII
    Replies: 2
    Last Post: 10-11-2013, 06:29 AM
  5. Replies: 3
    Last Post: 10-10-2013, 11:52 AM
LINK TO POST COPIED TO CLIPBOARD