1. Theodore Chidiac's Avatar

    I've just recently joined because it's been a week I've been confused with this System Update issue.

    My Samsung Galaxy S4 phone:
    Model GT-I9500
    Android Version 4.2.2
    Baseband Version I9500XXUAMDK
    Kernel Version 3.4.5-526212 se.infra@SEP-111 #1
    Build Number: JDQ39.I9500XXUAMDK

    To be honest I have 0% knowledge in technical issues concerning the Samsung Phones, really, 0%... I'm saying this because I read a 1000 thread and posts with lots of words, from kernels to ROMS to rooted to unmounted to TWRP and CWM to to to and I really have no idea what all of this means.

    What I hope I could find help with is updating my System software, for all the reasons and benefits (phone turns off when I enter the camera etc,...)

    When I enter to settings => More => About Device => Software Update => Update, it gives me Your device has been modified. Software updates are not available.

    Anyone could help me updating my S4?

    Thank you in advance

    bernz zenarosa likes this.
    10-27-2013 04:04 PM
  2. Theodore Chidiac's Avatar
    10-28-2013 09:05 PM
  3. HPferoxCraft's Avatar
    I would guess the phone was rooted with a custom rom/recovery.
    In settings, more, about device, status, what does it say at the bottom under device status? I'm guessing custom.
    Did you buy it used?
    I know you said you knew 0% but did you try rooting and flashing roms?
    That's what it sounds like to me. But I'm no expert just tossing out some thoughts.

    Posted via Android Central App
    10-28-2013 09:59 PM
  4. Theodore Chidiac's Avatar
    Hey, thank you for your reply, yep under device status it says custom... and no, I bought it brand new supposedly.

    Ok, I was downloading today the Titanium backup app, and it said my phone needs to be rooted to be able to use it, and thats where I tried to research a bit about rooting and did actually root my phone and finally have the Superuser app... BUT each time I click on it, it says that the app must be updated, and when I click on Install, it says There was an error installing Superuser. Please send a log of the error to the developer. I also tried accessing Titanium Backup and it didnt work yet...

    So what do you think next :P each step I go forward, things getting complicated more and more, all I get are error messages and bad signs :P

    Thanks in advance once again
    10-28-2013 10:48 PM
  5. HPferoxCraft's Avatar
    If it said custom before you messed around with rooting, then maybe it wasn't 'new' new. My guess is someone rooted, did whatever they did an did not properly or at least completely unroot to full stock. Could explain the borked camera.
    Titanium BU, will need root access.
    How did you attempt to root it because it sounds like it's failing to me, did you check with the app Root Checker?

    Here's a link worth studying.

    Here's another.

    Study up and follow directions to a T.
    At the least, if it was me, I'd be following the path that flashes me to a rooted but full stock firmware state for that exact phone. Immediately make a nandroid backup and keep a copy on your Extsdcard, then keep studying. Keep root or not, I bet it'll fix your camera though.

    "Just posting my thoughts. Not an expert. Please search, read and make backups."
    10-29-2013 01:57 AM
  6. Theodore Chidiac's Avatar
    I followed the rooting instructions cited here: How to Root the Samsung Galaxy S4 | Rooting Instructions

    Thank you for your msg again I read their contents, I'm not sure I will know how to fix it... I think my best solution is to just forget about all of this case, I'll give it a try and go to the dealer who sold me the phone maybe he can help with it.

    Thank you again
    10-29-2013 12:09 PM
  7. HPferoxCraft's Avatar
    That's your problem imo, the motochopper method.
    That cfautoroot link will get you there. It's actually a lot easier than it appears, you just need to follow the instructions and download links in the OP for your model# and not the others.
    It'll take you a whole couple minutes.

    "Just posting my thoughts. Not an expert. Please search, read and make backups."
    10-29-2013 12:56 PM
  8. Theodore Chidiac's Avatar
    Hey again Great news, I went back to the thread you linked me to, the one about the cf auto root, and finally my phone is rooted the titanium backup works fine now... so this is a problem that is now solved, but yet I cannot update the software, it still gives me the same message... I was looking back at your first reply, and you suggested rooting and flashing roms. I finally accomplished the first suggestion :P I don't know about the flashing roms, I'll try to search a bit on youtube and get back with the results.

    Thank you again
    10-29-2013 08:45 PM
  9. HPferoxCraft's Avatar
    Alright that's great, good job.
    1st thing you should do is go into your twrp recovery and make a nandroid backup. In case anything goes wrong from this point on you can flash that to get you back to the spot you made it at.
    If you want the update you'll have to Odin back to stock with stock recovery. A custom recovery will most likely block the update.
    Say the word and I can PM you and walk you through all the above. The nandroid is an absolute must if you plan on modifying anything Ron based, it will save you a lot of hair pulling if you make a mistake.
    Glad your going in the right direction.

    "Just posting my thoughts. Not an expert. Please search, read and make backups."
    10-30-2013 12:07 AM
  10. Theodore Chidiac's Avatar
    Back again :P it seems everyday I have an extra dimension in my brain added :P Ok so today I downloaded GooManager and did the custom recovery through TWRP. Plus I download my phone model's firmware from samfirmware.com even though I dont think it is the updated one, I dunno why I downloaded it, maybe I thought I would be able to restore Device status back to official but didn't work. As for firmwares with the new update, I can't find my phone model. Anyway what I found out in my search is that I cannot used Triangle Away on S4 I9500, I don't know if this would be a stumble for reaching my goal.

    So as for rooting I did root, but how exactly do I flash roms? is there any link I should follow, cuz I did somethings today dunno If they were considered flashing roms...

    Again and again thank you for your follow up
    10-30-2013 08:38 PM
  11. HPferoxCraft's Avatar

    Dont mess with the other sites. Everything and anything that has to do with your model of phone is right there. Android development is where the devs will be posting/maintaining their roms that will be heavily TW based.
    Original Android development is where you'll find more vanilla android based roms. ONLY use files for your specific model #. READ the stickies, watch the vids.
    Good luck

    Posted via Android Central App
    10-30-2013 10:31 PM
  12. JoeLoveATL's Avatar
    I agree with the previous post, do not mess with your phone if you are not expert. If you had not done all of these grasping things you could have just removed the SD Card, shutdown, and your phone would be Official. Anyone else that is having this issue may use this approach.
    12-03-2013 02:51 PM
  13. liliwowcher's Avatar

    My new (not so new now bought in Sept) - has this message saying my phone status is custom with my sd card in it. Never rooted my device as I dont know how. Not a technical expert.
    Every time I took my sd card out and reboot my phone the status says official.
    Each time I put my sd card back in the phone and reboot it the status says CUSTOM.

    Does that mean that I cant use my SD card at all? I used it to store my pictures / docs / other stuff

    Please advise.

    12-29-2013 05:06 AM
  14. Tanvir Hassan's Avatar
    This happened to me also. Unmount your sd card, reboot the phone without it. Check for the update. Then reinsert the sd card.
    04-03-2014 06:03 AM

Similar Threads

  1. Anyone dropping the Note 3 to go back to the S4 once 4.3 hits?
    By CompMan2012 in forum Verizon Samsung Galaxy Note 3
    Replies: 59
    Last Post: 11-05-2013, 12:28 PM
  2. I'm dumping my note 3 for my S4 once the 4.3 update hits!
    By CompMan2012 in forum Verizon Samsung Galaxy S4
    Replies: 13
    Last Post: 10-31-2013, 10:05 AM
  3. S4 LTE-A Bricked - URGENT
    By josephk11 in forum Samsung Galaxy S4 Rooting, ROMs & Hacks
    Replies: 1
    Last Post: 10-29-2013, 10:07 AM
  4. Replies: 0
    Last Post: 10-28-2013, 04:28 PM
  5. Samsung Galaxy Note 3 - S note. Czech characters.
    By jospav in forum Samsung Galaxy Note 3
    Replies: 0
    Last Post: 10-28-2013, 03:05 PM