11-08-2016 10:47 AM
172 123 ...
  1. DhanushkaSG's Avatar
    I recently upgraded my Galaxy S4 to Android 4.3 version. Then after I cannot connect my mobile to PC via USB port. I checked USB port of my PC and it works well. I checked connecting Galaxy Tab2 7.0 (Android 4.1) to the same PC USB port it is recognizing.
    Is there anyone experience same USB connection problem? Can anyone suggest some possible solution?..

    PS: Nexus 4 has some USB connection problem after upgrade to Android 4.3. There are some forum threads also. But no one talking about concrete solution. And no one reporting about Samsung Galaxy S4.
    CHC VINCHIYA likes this.
    11-02-2013 05:33 AM
  2. Haalcyon's Avatar
    Welcome to Android Central!

    You may need to install/re-install the S4's drivers. Give that a shot if you haven't tried that yet.
    DhanushkaSG likes this.
    11-02-2013 06:04 AM
  3. jtguk's Avatar
    Make sure you use Samsung Kies 3
    DhanushkaSG likes this.
    11-02-2013 08:44 AM
  4. sfilansno1fan's Avatar
    i had to upgrade my version of kies after i did the update it said it wasnt compatiable and i had to download kies 3
    DhanushkaSG likes this.
    11-02-2013 10:30 AM
  5. DhanushkaSG's Avatar
    I installed Kies 3..It works..Thanks..
    sfilansno1fan likes this.
    11-02-2013 08:58 PM
  6. K Edwards's Avatar
    You will need to make sure you have the usb connection set to MTP mode. You can do that by simply going to Settings>Storage> at the very top on the right side of the device should be 3 dots. Click those 3 dots to open up the menu for the Usb connection. Mac users you will need to do this also and download Android File Transfer. I hope this help those out there having the same issue
    12-05-2013 04:55 AM
  7. pjfayer's Avatar
    OK, installed Kies3, and used it to reinstall the device driver.
    Then I rebooted both my recently updated S4 (Android 4.3) phone and my (Win 7 Pro/64-bit) PC.
    USB PC connection is set to MTP.
    Still no joy: Some folders open easily, others are VERY slow or hang the explorer.
    Also downloaded and ran v1.5.14.0 device driver from https://forums.androidcentral.com/e?...token=hGyIy6tt

    Does anyone have any other ideas?
    12-06-2013 09:26 AM
  8. abdiBentley's Avatar
    hej, Im trying to connect my samsung galaxy s4 to the computer, but it doesent work even after I installed Kies 3. How can I can I make it work.
    12-06-2013 03:31 PM
  9. TerracottaWarrior's Avatar
    Yep same here! very annoying.

    Used to work but sent my phone for repair last week now it does not seem to recognise it.

    Although is obviously does as the phone will start charging when I out the USB on?
    12-06-2013 05:30 PM
  10. golthing's Avatar
    I'm having the same problems. The connect with USB button doesn't show up anymore.

    Thanks for the horrifying update Samsung.

    If somebody took a 6 month old car to the dealer and they jacked it up this bad, the dealer would get shot.

    "Oh, just do a factory reset" is like saying "oh, just remove and reinstall the engine and all will be well"

    "Oh, just reinstall the drivers". Sure, thanks for nothing. My phone was working just fine before this update and now it's crap.
    jayannbayobay and DarkUltra like this.
    12-12-2013 07:24 PM
  11. aramiscal's Avatar
    Hi K Edwards, I'm getting to make sure my usb is set to MTP but can't I can't find the "3 dots"... am I blind? Please help!
    12-21-2013 08:28 PM
  12. BabyPanda's Avatar
    I'm having the same problem with my galaxy note 2. After updating to Android 4.3, connected to kies 3. So far so good. Tried to run a backup on kies 3 (cos kies 2.6 didn't work with 4.3). Started OK, but much slower than prev backups. Backup went OK till it started backing up pictures, when it hung at 11%. Tried again and couldn't backup anything, after which couldn't connect to kies. After restarting phone, pc, reinstalling kies3 etc, kept having same results as above. So tried manually copying files using Explorer. Started OK then hung half way thru. After that pc couldn't read files on the phone. My conclusion is USB connection is unstable. Can't find an option to connect wirelessly. Will try to reinstall USB driver. F samsung for wasting hours of my time. The note 2 restarted itself yesterday while I was using it, first time after 11 months of use. F Samsung
    12-24-2013 04:20 AM
  13. Tony Lim2's Avatar
    Am also facing the same issue ( cannot connect to Klies 3 ) after upgrading to 4.3 on my S 4.
    Can any one help ?
    12-25-2013 04:39 AM
  14. abhijit panda's Avatar
    I had been facing the same issue and here is what I did

    Please remember, we dont need Kies app for wired connection. So no need to download kies if you need to connect your device via USB cord.

    1. Go to settings and select "More" tab. There you can see the 3 dots..

    2. Please select "About Device" which is the last option under "More".

    3. Please tap "BUILD NUMBER" for 7 times. Remember "BUILD NUMBER" will be disabled when you start clicking.

    4. 7 times clicking build number will start the "Developer Mode" and now you can see the MTP mode while connecting the USB.

    I also felt my phone has become very slow and here is a solution to that:

    Make Touchwiz go faster.
    To make Touchwiz look good, Samsung created some animations to transit between screens. These animations take some times and can make your phone seems slow. The solution is to go in your phone Settings-> Developer options and turn off -> "Windows animation scale", "Transition animation scale" and "Animator duration scale".

    Please let me know whether it works.. Thank you
    anthony_tan83 likes this.
    12-25-2013 06:40 AM
  15. Tony Lim2's Avatar
    I was able to find the developer options by taping my device 7 times.

    Even though i have the debugging mode tick on; i am still unable to detect ( with and without Kies app ).

    I don't see any options to switch to MTP mode. Am I missing something ?
    12-25-2013 05:02 PM
  16. Dave-in-Decatur's Avatar
    Just out of curiosity, I tried this procedure, abhijit panda, and it worked. Now, however, I'd like to get rid of it! I can turn off options by tapping Developer options and turning off the slider at the top. But I'd like to hide the Developer options section altogether, as it was before I did this. Any ideas how to do this?
    12-25-2013 08:54 PM
  17. Krishna Moorthi's Avatar
    Me too having the same problem. my galaxy s4 also not connecting to pc with usb cable after updating the android 4.3. i installed kies 3 also. but its not detecting in any pc . i changed my data cable also. but still not working. please someone reply me a right solution.
    12-27-2013 11:05 AM
  18. dhgrand's Avatar
    ditto exact same problems, Win 7 PC does not see the S4 phone running 4.3 but used to just fine (w/o Kies, I could see all my files and copy to/from using explorer)

    tried developer mode, no three dots anywhere, no settings - 'connections' option, no MPT mode anywhere (including 'settings - storage'), both user manuals claim connection mode should appear in 'notifications' after the USB cable is connected (it does NOT, but I do get the audible feedback when the cable goes in), tried Kies 3, pulling battery, etc...no change.

    I too would like to know how to exit developer mode, if possible. The on/off slider at the top of the Developer options may be all there is. The 'developer options' still appears in the setting menu - I guess I can live with that.

    BTW - the USB interface 'broke' more than a week after I was running 4.3. This makes me wonder if a new app and 4.3 are interacting badly to disable the USB MPT mode?
    Ahmed Zahir likes this.
    12-28-2013 03:03 PM
  19. Meraz Hoque's Avatar
    Same issues with my PC not recognizing the S3 with 4.3 version. (SGH-I747M)
    I've updated the Kies to Kies 3, still no help.
    Couldn't find the USB options in the developer mode, I see "USB Debugging" ... should that be checked off?
    Hope someone has found an update now, would like to transfer some files. was working great with the previous android version
    12-30-2013 10:14 AM
  20. Jake Lloyd's Avatar
    Same problem with me as well on a sprint GS4 running the sprint updated 4.3. My S4 works great but I'm running the TriForce ROM. Trying to get my wifes phone rooted but kinda hard to do if I can't connect it to anything. I've tried two different cables (both work with my phone), Kies3 (works with my phone). Uninstalled and reinstalled drivers, debugging is on and phone is set to MTP. BTW, for you sprint S4 users the menu to set to MTP you have to go to your key pad and dial ##3424# and go to USB settings.

    I'm assuming this has something to do with the over the air 4.3 update as I've seen lots of threads from many different mobile devices having this same issue after the update. Hope someone can find a fix for this as I have spent the last 2 hours working on it and have nothing to show for it.
    01-01-2014 10:49 PM
  21. bmdiz's Avatar
    Same issue, tried everything. Does anyone have a valid fix?
    01-03-2014 05:19 PM
  22. Dawid Kolodziej's Avatar
    i have same issue .i thought s4 is a good phone and i am samsung fan but after that i think i'm gonna change for sony again !!!
    why this smart!!!phone can connect as before??? i mean plug and play via usb and done ????
    01-04-2014 03:40 PM
  23. Dawid Kolodziej's Avatar
    i have same issue .i thought s4 is a good phone and i am samsung fan but after that i think i'm gonna change for sony again !!!
    why this smart!!!phone can connect as before??? i mean plug and play via usb and done ????
    01-04-2014 03:58 PM
  24. Nicki Keyter's Avatar
    I'm blonde as i get as far as unlocking the developer mode then get lost. Would you mind helping a stupid person a bit further along. Step for step.
    01-06-2014 06:27 AM
  25. Shaz Barker's Avatar
    OK I don't have a fix but I did manage to transfer stuff from my phone to my laptop via the Bluetooth option. Not really a fix but if you are desperate that does work. It also works when you transfer items from your laptop to your phone.

    Very disappointed with the latest update from Samsung!! Especially considering you couldn't not update it, was very annoying and persistant until I finally gave in and did it. Very disappointed that I did!!
    01-12-2014 05:28 AM
172 123 ...

Similar Threads

  1. Stock on White HTC Screen on My Rezound trying to load the Android 4.1.2
    By danfunboyd in forum Rezound Rooting, ROMs, and Hacks
    Replies: 2
    Last Post: 01-23-2014, 05:59 PM
  2. How do I get my pics to look less pixelated?
    By RiverK in forum Google Nexus 7 Tablet (2013)
    Replies: 4
    Last Post: 11-03-2013, 12:18 PM
  3. logo won't come out on galaxy note 2
    By Doron Benkin in forum Samsung Galaxy Note 2
    Replies: 1
    Last Post: 11-02-2013, 06:37 AM
  4. Is there a way to search for songs in a playlist on Google play?
    By RiverK in forum Legacy Android & Other OS's
    Replies: 0
    Last Post: 11-02-2013, 04:21 AM