1. SNOOP97DAWG's Avatar
    so today i had a full charge and my GS4 randomly shutoff. I tried to get it to turn on and it wouldnt respond.
    i got in the car and used my charger the only thing the phone did was show the battery icon like in the photo and vibrated once.
    I figured maybe the battery was bad but nothing else was happening. I got home took the battery out swapped it with a fresh fully charged battery took out sim card
    and it still wouldnt respond. I tried holding volume down, power and home button and still wouldnt respond
    safe to say i got a dead device. I called VZ and they basically just told me that they will replace the phone.
    not sure if anyone else has had this problem i tried searching and couldnt find a thread for it

    Verizon Galaxy S4 shutdown wont respond-img_20131103_023839-1-.jpg
    11-03-2013 01:56 AM
  2. Haalcyon's Avatar
    Ack, that's no good at all. However, it IS good that Verizon is going to do the correct thing and replace the device.
    11-03-2013 04:43 AM
  3. ladyhaly's Avatar
    I think I've seen someone post the same thing happening.... I'm guessing this isn't an isolated incidence. Might have to do with all the bloat or modifications VZ added to the actual update but who knows? It's a good thing they are replacing the phone though.

    Sent from my GT-I9505 using Tapatalk
    11-03-2013 05:45 PM
  4. SNOOP97DAWG's Avatar
    that's what I'm thinking...
    something in 4.3 caused it
    11-04-2013 07:56 PM

Similar Threads

  1. s4 galaxy crash after software download
    By jimmy crackcornx in forum Samsung Galaxy S4
    Replies: 9
    Last Post: 04-29-2014, 04:10 AM
  2. White LG G2 on Verizon?
    By Roman J in forum Verizon LG G2
    Replies: 12
    Last Post: 12-05-2013, 02:44 PM
  3. Extremely unhappy with Galaxy S4...
    By chocochip9 in forum General Help and How To
    Replies: 19
    Last Post: 11-05-2013, 04:31 AM
  4. Galaxy s4 Verizon 4.3 update
    By Gabe622 in forum Samsung Galaxy S4
    Replies: 5
    Last Post: 11-03-2013, 12:12 PM
  5. Samsung Galaxy S4 IS STILL "Not Registered on Network"
    By raegrace in forum General Help and How To
    Replies: 0
    Last Post: 11-03-2013, 01:54 AM