05-27-2018 09:55 AM
31 12
tools
  1. anony00gt's Avatar
    Phone in question is a Galaxy S4 on Verizon. Android 4.2.2

    OK so I usually use Chomp SMS as a text messaging app, with Swiftkey set as a default keyboard. Today for the first time I decided to try the voice-to-text feature in Swiftkey (long-press the mic button). Problem is, I long-press the button and get the vibration indicating the long-press has happened, but nothing happens from there. No change in the screen, no voice recognition at all.

    I tried the stock messaging app, same thing. Tried going back to the Samsung keyboard, couldn't even get a mic button there after playing with settings. Tried the Google keyboard, same thing, couldn't even get a mic button. I looked all over settings in all the keyboard apps and phone settings but could not figure out what I'm doing wrong. I'm sure there's probably some stupid setting that I'm missing somewhere...

    S-Voice (driving mode) works, but as of now that seems like the ONLY way I can do voice-to-text. Any ideas?

    Thanks
    Cheri Whisonant likes this.
    11-05-2013 03:36 PM
  2. Dave-in-Decatur's Avatar
    You didn't by any chance disable S Voice at some time did you? What you describe sounds like what happens to me in some apps with S Voice disabled/turned off. But I wouldn't think that would affect the Google keyboard!
    11-05-2013 04:35 PM
  3. anony00gt's Avatar
    Nope. S-Voice works fine and voice control is enabled.

    Posted via Android Central App
    11-05-2013 04:51 PM
  4. anony00gt's Avatar
    I updated to 4.3, still no go.

    Finally fixed it though. I had Google search disabled. Enabling it again fixed the issue. No idea what one has to do with the other but ok.

    Posted via Android Central App
    Emily MacDonald likes this.
    11-05-2013 05:12 PM
  5. ladyhaly's Avatar
    Ah... I see. Voice to text actually uses the Google Search service to send the sound data which will be interpreted by Google, so you can figure out from there why. I wonder though... Why did you disable it?

    Sent from my GT-I9505 using Tapatalk
    11-05-2013 06:45 PM
  6. anony00gt's Avatar
    Because my battery life was horrible. Since then I've gotten a Gorilla battery, which helped a lot.
    11-06-2013 07:30 AM
  7. Lissette Torres's Avatar
    Because my battery life was horrible. Since then I've gotten a Gorilla battery, which helped a lot.
    -Thank you!! I enabled my Google search and that worked!! :-)
    01-18-2014 02:48 AM
  8. Emily MacDonald's Avatar
    Thank you!!! That was making me CRAZY 😜
    01-31-2014 07:16 PM
  9. Lauryn H's Avatar
    I cannot thank you enough!!! I have been trying for months to fix the TTS mic and never did it occur to me (nor would it) to enable "google search". It works perfectly now! Thank you... Thank you... Thank you
    02-28-2014 03:34 PM
  10. Liz Rainey's Avatar
    That worked for me too. Thanks a bunch for posting.
    03-28-2014 09:03 PM
  11. Adam Wendland's Avatar
    I updated to 4.3, still no go.

    Finally fixed it though. I had Google search disabled. Enabling it again fixed the issue. No idea what one has to do with the other but ok.

    Posted via Android Central App
    I have the same problem. How do enable Google search again. I went through a deleting phase and messed everything up.
    04-25-2014 06:38 AM
  12. ryanmtech's Avatar
    I have the same problem. How do enable Google search again. I went through a deleting phase and messed everything up.
    Go to settings > application manager > go to the farthest right tab which is "turned off" > there you should see google search > click on it and re-enable it

    Thanks to everyone in this thread, i just had a customer with this issue and could not figure it out before coming on here.
    06-18-2014 10:50 AM
  13. Bruce K Gillespie's Avatar
    I had turned off "Storybook" and that caused the mic to disappear as well.. That is a lame design..
    07-25-2014 01:38 PM
  14. PEB_S4's Avatar
    Voice-to-text microphone vanished. That key was replaced by Swype. Holding down that key produced a pop-up of various alternate functions like Swype, smiley, settings, etc. but no microphone. Previously microphone was one of the choices. This happened 1st to my wife's Galaxy S4 using Verizon running Kit-Kat V4.4.2 (last updated 05/10/2014). Then a few days latter it happened to my Galaxy S4 which is configured the same.
    The Samsung reps at Best Buy were very helpful and quickly went to:
    Settings > My device > {scroll down to} Language and input > Under the Keyboards and input methods:
    Turn on Google voice typing {my wife's was turned off}
    Turn on Swype {if both were already on, then turn-off Swype and exit}
    Try a text message to see if the microphone is now available. You may need to hold down the key left of <space> to see the microphone selection.
    For my phone both were on so I turned off Swype. That made my microphone available again. When I went back to check the Swype setting it was turned back on. All works normally now.

    I'm not sure what update caused this change. I'm certain I didn't change anything. I suspect it was caused by a Swype update that was not disclosed at all on my phone. However, my wife's phone received an update message about Swype prior to her microphone vanishing.

    This happened to my wife's phone about 29 July 2014. Then it occurred on my phone on 2 Aug 2014.

    Hope that helps others with this problem.
    08-03-2014 02:06 PM
  15. ajl's Avatar
    Voice-to-text microphone vanished. That key was replaced by Swype. Holding down that key produced a pop-up of various alternate functions like Swype, smiley, settings, etc. but no microphone. Previously microphone was one of the choices. This happened 1st to my wife's Galaxy S4 using Verizon running Kit-Kat V4.4.2 (last updated 05/10/2014). Then a few days latter it happened to my Galaxy S4 which is configured the same.
    The Samsung reps at Best Buy were very helpful and quickly went to:
    Settings > My device > {scroll down to} Language and input > Under the Keyboards and input methods:
    Turn on Google voice typing {my wife's was turned off}
    Turn on Swype {if both were already on, then turn-off Swype and exit}
    Try a text message to see if the microphone is now available. You may need to hold down the key left of <space> to see the microphone selection.
    For my phone both were on so I turned off Swype. That made my microphone available again. When I went back to check the Swype setting it was turned back on. All works normally now.

    I'm not sure what update caused this change. I'm certain I didn't change anything. I suspect it was caused by a Swype update that was not disclosed at all on my phone. However, my wife's phone received an update message about Swype prior to her microphone vanishing.

    This happened to my wife's phone about 29 July 2014. Then it occurred on my phone on 2 Aug 2014.

    Hope that helps others with this problem.
    Thanks for sharing your findings.
    08-03-2014 06:09 PM
  16. Lacey_Underalls's Avatar
    I'm having the same problem with my voice-to-text no longer working. I've been using Kii keyboard for over one year and now when I press the microphone button, I get one of two error messages (see pictures). Nothing happens when I press the microphone button in the Swype keyboard (no pop up error message, doesn't open the voice-to-text feature). I reenabled Google Search as anony00gt suggested, restarted and no change. I attempted to find the Google Voice Typing setting mentioned by PEB_S4, but did not see it anywhere in my keyboard/input settings. Any suggestions?
    Voice-to-text not working properly-2014-09-05-22.29.15.png
    Voice-to-text not working properly-2014-09-05-22.30.30.png
    09-06-2014 12:32 AM
  17. D Hols's Avatar
    I have the Galaxy S5. After spending 3+ hours researching this issue, I was brought to this thread. Here's what worked for me: Google Search did not show up in Google Settings or in the Application Manager. I went to the Play store and searched for “Google Search”. It showed that I have it installed but was disabled. I clicked it to enable it and voila, voice-to-text is working again. Finally “Search and Now” shows up in the Google Settings and has returned to settings > application manager > Google Search. Thank you for this thread.
    01-12-2015 02:48 PM
  18. David ricany's Avatar
    I have the Galaxy S5. After spending 3+ hours researching this issue, I was brought to this thread. Here's what worked for me: Google Search did not show up in Google Settings or in the Application Manager. I went to the Play store and searched for “Google Search”. It showed that I have it installed but was disabled. I clicked it to enable it and voila, voice-to-text is working again. Finally “Search and Now” shows up in the Google Settings and has returned to settings > application manager > Google Search. Thank you for this thread.
    01-31-2015 05:26 PM
  19. David ricany's Avatar
    I have had the same issues with my lg phone and came to the conclusion that it was Dropbox and I had recently installed. That was the culprit. I deleted Dropbox rebooted my phone and all was well.
    01-31-2015 05:29 PM
  20. andean fry's Avatar
    Using kitkat on s4. I believe the suggestions that helped me were
    1,downloading the language (in settings-language and input-google voice typing settings-languages. )
    2.Search language set to same language downloaded in step 1. This setting is under the apps-google settings-search and now-search language.
    11-09-2015 04:24 PM
  21. James-0-0-7's Avatar
    I updated to 4.3, still no go.

    Finally fixed it though. I had Google search disabled. Enabling it again fixed the issue. No idea what one has to do with the other but ok.

    Posted via Android Central App
    Thanks heaps, was driving me crazy.
    03-09-2016 06:29 PM
  22. Summer11580's Avatar
    For Samsung Galaxy Stardust, went to Settings > My Device > Language and Input
    Under Keyboards and Input Methods, unchecked "Google Voice," then rechecked "Google Voice."
    This worked for me.
    07-06-2016 10:39 AM
  23. Sabbath 69's Avatar
    If you go to edit on the pencil in your contacts then hold down the zero and the plus sign and put A1 before the phone number speech-to-text will work correctly I guarantee it
    08-04-2016 07:08 PM
  24. ifixedit's Avatar
    To get your mic back drag the cog key and it will spread into options on keyboard where you can pick mic again to voice text. I did it too.
    03-08-2017 06:42 PM
  25. cgunday's Avatar
    Hello everyone,

    I have strange problem. And couldnt find any proper solutions, maybe you can help me.

    I have galaxy s6

    When I say "ok google" it detects my voice and detects properly my speech.
    But when I try to use TTS with other writing options (eg. with WhatsApp or SMS or Google Documents to write smth.) I am having problem.

    It doesnt work. When I tap green button, it sounds and suddenly I hear another sound. ITs like trying to find microphone (first bleep) and in a second couldnt find (second bleep). Even I try to say smth, there is no waves, which syndicates the system analyzing your voice.

    Surprisingly, in main screen ,everything fine with ok Google...

    I have tried to switch to Smasung TTS but result is same...

    Any ideas?
    03-18-2017 05:17 PM
31 12

Similar Threads

  1. iHeartRadio not working on KitKat
    By Brainerd in forum Google Nexus 5
    Replies: 43
    Last Post: 11-29-2013, 08:21 PM
  2. Phone numbers not recognizing pause in calendar app
    By wfroelich in forum AT&T Samsung Galaxy S4
    Replies: 2
    Last Post: 11-14-2013, 01:39 PM
  3. How to disable or limit "autobackup"?
    By steven stier1 in forum General Help and How To
    Replies: 1
    Last Post: 11-06-2013, 07:31 AM
  4. S cover to custimize? To make calls when its closed?
    By ozgurs in forum Samsung Galaxy Note 3
    Replies: 2
    Last Post: 11-06-2013, 03:18 AM
  5. How to get Sprint 4.3 manually.
    By Gelst in forum Sprint Samsung Galaxy S4
    Replies: 9
    Last Post: 11-05-2013, 09:48 PM
LINK TO POST COPIED TO CLIPBOARD